Previous 1 2 Next 27 Replies Latest reply: Jan 31, 2010 4:41 AM by BadgerDog
thesaint_dfw Level 1 Level 1 (0 points)
I am trying to play some Mp4 movies that I uploaded to my MobileMe gallery and I cannot play the same on my Mac. I get a question mark within the Q symbol. No movies on my MobileMe is playing after upgrading to 10.6. Any suggestions?

MacBook White, Mac OS X (10.6)
  • Donald Palmer Level 4 Level 4 (2,170 points)
    Try opening the movies with QT7 that is located in your utilities folder. Use "open with" command.
  • thesaint_dfw Level 1 Level 1 (0 points)
    Have 10.6 on my Mac. So, no QT7. Also, I am streaming a video off the internet, hence cannot say open with QT7 I guess.
  • Donald Palmer Level 4 Level 4 (2,170 points)
    Quicktime 7 is in the optional installs on your SL disk.
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    I got QT7 installed automatically because I had QT Pro. I'm still trying to figure out the relationships between Safari, QTX and QT7, and haven't yet come to a real understanding of what is going on. From what I've discovered so far I can say that all the movies I have in my Web Gallery actually play, on my computer, in the QT7 player (you can tell by the controller), and that when they are playing in Safari this is what is being used:

    /Library/Internet Plug-Ins/QuickTime Plugin.plugin

    Further, that that plugin is version 7.6.3, in other words it is the old QT7, not QTX, and was installed by the Snow Leopard upgrade, it isn't "left over" from the Leopard installation (the plugin that was there in Leopard was version 7.6.2). I have been experimenting to try to find something that plays in Safari in QTX, and have found a couple of things, but have been unable to determine why those will play in the new QTX, while most things I have continue to play in the QT7 plugin. I can't imagine that everyone who didn't get QT7 installed can no longer view their Web Gallery movies! That doesn't make sense.

    Also, I have heard that if you run into content that can't be be played by QTX you should automatically get an offer to install QT7, just as with printer drivers and Rosetta.

    So I would think that either your MobileMe movies should just play, or you should receive the offer to download and install QT7. I find the fact that neither is happening mystifying.

    You could try popping the Snow disk back in, go to the Optional installs and go ahead and install QT7 yourself and see if you get the QuickTime Plugin and if things work correctly after that.
    Francine


    Francine
    Schwieder
  • thesaint_dfw Level 1 Level 1 (0 points)
    Thanks for the suggestion. I called Apple this am hoping to get a fix for this issue. Here is a summary of the conversation. Hope this helps y'all.

    1) Updating to QT7 thru the SL disk didnt work.

    2) The movies from MobileMe plays fine on a PC, so its a Mac issue

    3) The support agent tried on Mac's that were running SL and told me the same issue. (Assures me that it aint a corrupt install of SL)

    4) Didnt have this issue when using Leopard

    5) MP4 and other videos plays fine when opened thru QT7 or QTX

    6) Issue escalated to a specialist

    7) Narrowed down to a plugin not compatible with Snow Leopard. Insisted that I download that particular file to the HD and view it thru QTX or QT7

    Also, installing Perian didnt help and I have the Quicktime Plugin installed.

    The specialist mentioned that this might be an issue with SL and there might be an update to QT or Sl itself to fix this issue later sometime. I am seriously thinking of going back to Leopard thru backup. Hope this helps everyone.

    Alex
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    Don't know whether you want to continue to pursue this question here, but if you do, I have a couple of questions:

    1. Could you share the address for your MobileMe gallery? I would like to take a look and see if I can either get them to play on my machine, or try to figure out why they don't.

    2. Take a look at my Web Galleries and see if the movies there play on your machine.

    http://gallery.mac.com/francines#gallery

    All play on my machine just fine, although the streaming speed today leaves something to be desired. Also, all three seem to be using the QT7 plugin from the Internet plugins folder in /Library.

    3. I believe all three movies were uploaded using either iMovie or QuickTime Pro from Leopard, quite some time ago. How were yours uploaded? Additionally, since I used the automatic functions to save for my gallery pages, they were evidently saved as m4v files.

    4. Which leads to a final question: how were yours made and saved?

    Finally, here's a list of the the plugins I have in /Library/Internet Plug-Ins:

    Flash Player.plugin
    flashplayer.xpt
    Flip4Mac WMV Plugin.plugin
    Flip4Mac WMV Plugin.webplugin
    iPhotoPhotocast.plugin
    JavaPluginCocoa.bundle
    NP-PPC-Dir-Shockwave
    nsIQTScriptablePlugin.xpt
    Quartz Composer.webplugin
    QuickTime Plugin.plugin
    WacomSafari.plugin

    There's also a Disabled Plug-Ins folder, but it is empty, as is my user ~/Library/Internet Plug-Ins. Don't know whether it matters, but I also have Perian installed.
    Francine


    Francine
    Schwieder
  • thesaint_dfw Level 1 Level 1 (0 points)
    Sure not a problem at all. Please find my answers and thanks for spending time in digging into this issue.

    1. http://gallery.me.com/ashwin/100315

    2. Thanks for sharing your Gallery. It works for me too. I tried o play two movie and it works perfectly fine.

    3. The files I have are MP4 and has been taken thru Sony Digital Camera.

    4. I also have perian installed, but to no luck.

    5. These are plugin in my /Library/Internet Plug-Ins

    DivXBrowserPlugin.plugin
    DRM Plugin.bundle
    Flash Player.plugin
    flashplayer.txt
    googletalkbrowserplugin.plugin
    iPhotoPhotoscast.plugin
    JavapluginCocoa.bundle
    NP-PPC-Dir-Shockwave
    npdivx.xpt
    nsiQTScriptablePlugin.xpt
    Quartz Composer.webplugin
    Quicktime Plugin.plugin
    Windows Media Plugin

    You also have SL if am not wrong. I am not sure how its working for you.
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    Well, I am still no wiser, but will let you know if anything else occurs to me. Your movie will not play for me either. The page loads, and the poster frame loads, get a spinning pizza for maybe 20 seconds, and the a notice plastered to the bottom of the movie that QuickTime can't play it. It will download, and then plays in QT just fine. From this I'm going to assume it isn't a problem with your plugins, since it won't play for me either.

    Since it was playing in QT after I downloaded it, I tried uploading it from QTX to my web gallery:

    http://gallery.mac.com/francines#100086

    I'll take it down of course as soon as I finish trying to figure this out. Anyway, the point is that it plays there just fine, but I quickly discovered that QTX had converted it to the m4v format for the two larger versions, and to a 3gp format for the smallest version.

    So I wondered if the mp4 format was the problem. I seem to have disposed of most of my mp4s online, but did find one still up:

    http://homepage.mac.com/francines/.Movies/kenstr.html

    Oddly enough in the web page it plays in the QT7 plugin (you can tell by the control bar), but downloaded it plays in QTX. And if I drag the downloaded mp4 into the Safari window it plays with QTX, as does the download I did of your movie!

    And I am indeed running Snow Leopard, and have been working on my review here:

    http://www.pinkmutant.com/articles/snowleo1.html

    It is working surprisingly well. This is the first real glitch that I can't understand AT ALL that I've run into.

    One final question: how did you get your movie into your Gallery? I ask because there are several different ways to do that. As I mentioned above, I put your movie up using the QTX Player, went to the Share menu and selected MobileMe Gallery.
    Francine


    Francine
    Schwieder
  • thesaint_dfw Level 1 Level 1 (0 points)
    I played the Mp4 format that you had uploaded and it works fine as well. I downloaded the Mp4 on my PC and then I uploaded the same thru Firefox onto MobileMe. If you dont mind can you re-upload the Mp4 that you downloaded from my site using iPhoto and check if this methodology works?

    FYI, all the Mp4 files work perfectly fine on my PC. Why is it not working on my Mac?
  • Johnathan Burger Level 6 Level 6 (15,540 points)
    Play fine for me in firefox.
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    OK, first the only mp4 I had was the tiny one of my friend Ken, not in the Web Gallery. YOUR movie, which I uploaded to the Web Gallery with QTX, is NOT an mp4. QTX converted the original mp4 into mv4 when instructed to upload to the Web Gallery. It did so autmatically without any instruction from me.

    Putting your mp4 into iPhoto, then instructing it to upload to my Web Gallery preserves it as an mp4, and now, as is the case on your Web Gallery, it won't play. Here's the direct link:

    http://gallery.me.com/francines#100094

    I'm still no wiser as to what the problem is, since other mp4s will play just fine off the iDisk.
    Francine


    Francine
    Schwieder
  • thesaint_dfw Level 1 Level 1 (0 points)
    Thanks. I agree with you; however, the files that I have uploaded to my MobileMe plays fine on my PC. So, it aint the file issue I guess. Its not playing on Mac for some reason. My PC has QT7 and Mac SL with QT 7 and X. Its very strange.

    Also, these files were working when I had Leopard. The problem started when I upgraded to SL.

    Message was edited by: thesaint_dfw
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    Now for something completely weird. I have a page that specifies playing an mp3 in the QuickTime player, which works fine:

    http://homepage.mac.com/francines/Sites/articles/markmusic.html

    The mp3 should load, and since I have QT 7 installed, that controller loads and you can play the song, no problem (not sure what will happen if one only has QTX).

    So I replaced the link to the mp3 with a link to your mp4, and it takes awhile to load, as if it really is fetching the file. But it is broken, you just get the Q with a question mark. HOWEVER, directly below where the movie should be is a direct link to the mp4, and if you click that "Movie" link the mp4 actually loads and plays, once it finishes re-loading.

    http://homepage.mac.com/francines/.Movies/movietest.html

    I tried the page in the Opera web browser, and the movie loaded and played using QT 7 just fine!

    So my conclusion is that something is broken in the relationship between Safari and the QuickTime plugin when it comes to handling mp4s. Safari can actually play mp4s, and so can both QT7 and QTX. But when Safari is told to play an mp4 using QT, it breaks down.

    I'm going to see if I can round up a QT expert to take a look at this thread and make some sense of all this.
    Francine


    Francine
    Schwieder
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    You should have QT10 (comes with 10.6). Also, look in your Utilities Folder for QT7. If it's not there, then you don't have it. You very well may have an alias for an older version of QT in your Dock. Look in your Applications folder for QT10.
Previous 1 2 Next