Previous 1 2 Next 23 Replies Latest reply: Jan 26, 2014 1:08 PM by elmodd
aecampbell Level 1 Level 1 (0 points)
After updating to iTunes 9 I have found that I can't edit the "media kind" label on any of my tracks. This is particularly annoying as I use audiobooks a lot, and now I have to store them as music. In fact, it seems that I can't edit anything under Options at all, such as "skip when shuffling" etc. Any ideas? I have never had a problem with this before and any help would be much appreciated.
Thanks!
  • Sam11 Level 1 Level 1 (130 points)
    Can you describe what you're doing more specifically? I just converted a whole bunch of books from cd's into audiobooks in itunes 9, I right clicked the tracks and used "get info>options>media kind." Which it sounds like you tried.

    Are you seeing the media kind drop down menu but it's just grayed out and not clickable? It's a stupid suggestion, but have you double checked that you're viewing the tracks within the "library" section of itunes and not viewing tracks from the ipod section or anything?
  • giarcnella Level 1 Level 1 (0 points)
    I logged in and saw only this thread. I want to edit Media Kind to batches of files using Automator and that does not seem possible. Is there some other method one could use?
  • joemaurice Level 1 Level 1 (15 points)
    I have a similar problem, i changed the media kind for some tv shows using the "get info/options" panel.

    I changed them from TV show to PODCast (do not ask why...!?)

    Now i cannot change them back, the drop down will let me choose TV show, but nothing happens

    I have tried using a script from dougs script archive as well, but this produces an error " xxNumber of files could not be changed"

    I have removed the files from Itunes and re added them, but they come back to PODcasts

    The only thing i can think of is to re encode the movies and begin again

    They are a mixture of .MOV and .MP4 files some are protected, purchased content from itunes store and some isnt

    Wierd!, any ideas anyone?
  • Lance Smith1 Level 1 Level 1 (20 points)
    Has anyone solved the above problem? I'm having the same trouble.
  • Dave623 Level 1 Level 1 (0 points)
    If anyone has figured out why this wont work can they please tell me
  • maddowdle Level 1 Level 1 (0 points)
    If you have a PC itunes has to have administrator privileges to modify the song tags. Right click on the iTunes icon and go to Properties. In the Compatibility tab, at the bottom of the page there is an option to allow the program with administrator privilege. This should solve your problem.
  • maddowdle Level 1 Level 1 (0 points)
    after i did that I had to empty my library and add all the files back into it. then i was able to change the media kind. but my id tags are all fixed except for the media kind so this wasn't a big deal for me. and my itunes is run from a hard drive. if you keep your files on your computer you may not have to delete them and re-add them.
  • pigonthestairs Level 1 Level 1 (0 points)
    I'm having the same problem with my Mac. The first time I changed "Media Kind" from music to audiobook the files moved from the music to the books library. When I went back to the books library and looked at the Media Kind setting on these files, it had reverted to music (even as it sat in the books library) and wouldn't allow me to change it. That is, I'd change it, click OK, then open it again and the setting was back to music.

    Strangely, if I look at one file at a time the setting says audiobook, but when looking at them all together it says music.

    I should add that since moving to the books library these files won't sync at all with the iPhone (yes, it is set to sync all books).
  • syd3n Level 1 Level 1 (0 points)
    has pigonthestairs' issue been resolved? i am having the same problem.
  • abbott_56 Level 1 Level 1 (0 points)
    I had this issue in Itunes 10 and have apparently fixed it.

    It started when front row was placing my TV shows in the Movie folder as well, and being such an OCD person, this just would not do. I read somewhere that by changing my tv shows to the podcast, and then back, it would alter the appearance in front row.

    Well, after changing my TV shows to podcast, they then would not revert back to being a tv show. I then downloaded MetaX from the apple downloads site, as i'd read that I could change the type before importing them. I did this, but they were still importing as a podcast. However! Since downloading MetaX and changing the types once, itunes is now letting me change the type within the programme.

    A bit confusing, and one of the only issues i've ever had running my mac. But i'd say try downloading metaX and see what happens.
  • Nekcarccm Level 1 Level 1 (0 points)
    Does anyone have a solution to this? I'm having the same issues as pigonthestairs.

    Individually the files seem to have a media kind of audiobook (and are therefore showing in the books library) But if I select multiple files and check the Media Kind via get info, it shows as "music"?

    It's not a problem right now because they are appearing in the Books library, but the issue is when I update computers or reinstall or whatever, when I re-import the files from back up into a fresh iTunes install the audiobooks, podcasts, TV Shows, etc, all revert back to music and appear in the music folder.

    Thanks,
    Shannon
  • Sweetpea87 Level 1 Level 1 (0 points)
    I was trying to do this under my playlists, after trying to change the file under library it worked. Thanks.
  • Mark Harris5 Level 1 Level 1 (10 points)
    I've had this issue twice now for multiple files throughout my library, mostly TV shows misclassified as movies. (Twice I've had the issue 'cuz I have been moving files around a lot from disk to disk...sigh.) Each time I have solved it with a permissions fix--for some reason, after moving a file and re-adding it to an iTunes library, it gets "custom" access, not "read/write" access. (Probably has something to do with my library being on an external disk, though I'm not 100% sure.) Easiest, though slowest, solution: quit iTunes, Get Info (in Finder) on your iTunes Media folder, and set "everyone's" permission to "read/write" -- and click the gear icon to Apply to all enclosed items.

    It'll take a good long while if you have a lot of files. But you'll be able to edit after it's done. If you're only having the trouble with one file, you can edit the permissions just on it (that's also worked for me).

    Mark
  • turingtest2 Level 9 Level 9 (55,285 points)
    Just a couple of general points that may help in future.

    Unless a file has the Podcast flag set, audio files imported into iTunes will be treated as Music (apart from m4b audiobooks) and video files as Movies. You need to manually change the Media Kind after import.

    As well as "Media Kind" there is another property inside iTunes called "Video Kind" which indicates if a file is a Movie, TV Show or Music Video. Current builds of iTunes *do not* alter this value in tandem with a change in Media Kind. This could potentially cause problems with smart playlists and perhaps even remote access to the library. The Video Kind property can be set from script.

    Given that Media Kind is an internal property of the iTunes database there is no good reason that it can't be applied to any file whether locked or not, but I suspect iTunes first checks for write permissions before making changes so permissions may be an issue whenever you are unable to change the Media Kind.

    Unless your selected audiobook files are all in .m4b format iTunes will report any selection of two or more audiobook files as being Music. Ignore it. It can't handle mixed property values either, e.g. a mix of compilation and non-compilation tracks will always show as *Part of a compilation: No.*

    When working with single audiobook files you cannot change the status of the *Remember playback position* and *Skip when shuffling* flags. Simply select more than one file to adjust.

    For more tips on audiobook organisation see http://samsoft.org.uk/iTunes/audiobooks.asp

    tt2
Previous 1 2 Next