Previous 1 2 3 4 Next 51 Replies Latest reply: Feb 16, 2010 1:31 PM by DoubleTs
FelipeRaul Level 1 Level 1 (0 points)
I was very happy with Safari 4 performance in my 2008 iMac. But since I upgraded to Snow Leopard (10.6.1) the browser is simply too slow to be usable. Really, really slow. You can see every single element of a website loading (like the background drawing from top to botton, things like that), while before it just appeared instantly.

I have an old macbook (2.0ghz, Core Duo - not core 2 duo, 512MB RAM) running Leopard and I did some side by side tests. My iMac has a 2.66 Core 2 Duo Processor with 4GB of ram. Both machines side by side, on the same Wifi network.

Even tough I pressed enter simultaneously in both machines, the iMac is now taking 3 to 5 SECONDS more to load a page than the old macbook ! I did tests in MANY websites, like, new york times, college humor, and so on.

What gives ? Why is Safari so slow in snow leopard ?

Apple Macbook 13inch 2.0ghz Core Duo 512 60GB White SuperDrive, Mac OS X (10.4.7)
  • Barry Hemphill Level 8 Level 8 (37,065 points)
    Hello f:

    In short, it is not slower. What is happening in your situation is related to what is or is not installed on your system.

  • FelipeRaul Level 1 Level 1 (0 points)
    You are wrong. Like I said, it was MUCH faster while it had Leopard running on it, not by a little marging, but by something like 5 times faster.

    The Macbook has a really old and well used Leopard installation, really bloated with DJ Software and has only 4GB left in the HD (the iMac has 68 GB free), and even considering all this the Macbook is still blazing fast while surfing the internet if compared to the iMac with snow leopard.
  • Barry Hemphill Level 8 Level 8 (37,065 points)
    I am not here to argue with you, but I am certainly not wrong. What is happening in your system is not indicative of what is happening everywhere else in the Apple community.

    If you want help to solve your problem, ask. If you want to rant, no one will pay any attention.

  • ~Bee Level 7 Level 7 (31,270 points)
    Hi Felipe --
    After you upgraded to SN,
    Did you Repair Permissions?
    Did you check your Font Book Application for duplicate, unresolved fonts?

    Sometimes these two little things can make all the difference.
  • FelipeRaul Level 1 Level 1 (0 points)
    Nope, I hadn't done either of them.

    I opened my font catalog and I clicked Edit > Select Duplicates, and then Edit > Resolve duplicates. There were quite a few of them, specially in Arial ! Now the duplicates are showing "inactive", is that all I should do ?
  • ~Bee Level 7 Level 7 (31,270 points)
    Repair Permissions:
    Go to the Hard Drive icon, upper right of your screen.
    Double click, go down to Applications folder. In there, find the Utillities folder.
    Open Disk Utilities, select your HD icon on the left hand side of that pane,
    and then select "Repair Permissions."

    Relax. It will take several mins, anywhere from 5 to 15, depending.

    And now there are no moer duplicates, right? Tiny dost all gone?
  • DaveInDetail Level 1 Level 1 (0 points)
    He is not the only one with this issue. My MBP 4,1 is running Snow Leopard horribly. First thing I noticed about it was how awful Safari is running.

    So, do us all a favor, and either get your nose out of the air and give a helpful suggestion without jumping to conclusions... or stay off the replies. Thank you.
  • Donnie Ashworth Level 3 Level 3 (875 points)
    Many are having this issue, including me. Example:

    I used the suggestion to use Open DNS, and so far my speed seems to be showing some improvement.
  • Dennis Bolt Level 1 Level 1 (0 points)
    I think this is Safari and not SL, since I have these troubles now with Safari 4.03 and I am running Tiger. There are many threads in this forum saying that Safari is slow. You may not be "wrong" Barry, but this appears to be a problem. I do know that these boards end up with complainers, since people with no problems don't need to ask questions here.
  • Kurt Weber Level 6 Level 6 (13,960 points)
    If it is only Safari that is running slowly you may also have an incompatible plugin. Are you using any third party software plugins or input managers with Safari? For the plugins, the easiest test is to disable plugins in the preferences and see if this improves things:

    Safari Menu/Preferences
    Click on the security tab
    Uncheck the "enable plugins" check box

    If Safari runs better you probably need a newer version of some of your plugins.

    Safari was drastically improved in Snow Leopard. It is now a 64 bit app. It is a speed demon on my machine, with only the speed of the server to slow things down.

    Are all apps running slow or is it just Safari?

  • ekimgnuj Level 1 Level 1 (0 points)
    Barry, I think you are wrong. I am experiencing exactly the same problem since the upgrade, and at least 6 other people in my office are experiencing the same problem. All on our home computers, nothing to do with the office network. There is definitely a problem with the Safari/Snow Leopard combination that affects some, though not all, machines.
  • t.lee Level 1 Level 1 (0 points)
    I went on your thread and followed some of the users suggestions and Safari works so much better!!!

    I had a problem where Safari kept crashing after I instaled Snow Leopard. At one point It took over 90 seconds for a new tab to be opened and work without the turning rainbow wheel. It would lag every time; firefox was not as bad but it did run noticeably slower. Even Dashboard and Exposé would lag/hang like crazy.

    I find that now everything works faster, safari, firefox and finder.

    I did a few things I'm not sure what did the trick exactly.

    -I tried disabling the internet plug-ins to see if it changed anything. I don't think this did much. I checked my folder (/Library/Internet Plug-Ins/) and nothing really looked suspiciously out of date except for 'Flip4Mac WMV'

    -I got OpenDNS, I don't think this was a solution but it seems like a useful thing to have in the long run

    -I also played around with the Render Before Display timer, but that didn't do much either. (

    -I went through all my applications and got rid of a bunch of the ones that weren't necessary and may be clashing with Snow Leopard, especially since a lot of them wouldn't have been updated for the new OS

    -Repairing Disk Permissions from Disk Utility did wonders I think. I never thought to do this after I installed Snow Leopard but after it finished everything seems to be running a lot smoother

    Everything seems to be a lot quicker now, so hopefully it'll stay this way after a reboot. Good luck with your computer, I think it is a matter of little kinks here and there slowing the computer down overall especially in the web-browsing area. Run Disk Utility and go through your applications and update/put away the ones that are out of date and may clash with Snow Leopard
  • Kurt Weber Level 6 Level 6 (13,960 points)
    Another thing to try is to make Safari run in 32 bit mode. Quit Safari, Find it in the Applications, press ⌘ +i and check the "run in 32 bit" checkbox. If it runs better than you have some 32 bit app that is messing with it.

  • KCinCan Level 1 Level 1 (0 points)
    I just upgraded to OS X 10.58 and downloaded a bunch of updates incl Safari 4.0 while waiting for my Snow Leopard to arrive. This "upgrading" has essentially slowed my network connection to molasses. It has also slowed my system response too. I want to thank Bee for her suggestions on the Permission repair and font thing....I think it helped some. I am also trying disabling the plug-ins, as suggested here, to see if it helps. So far it is still SLOW! Funny thing is that I cannot load an Apple page without going into my security software (InternetCleanup) and erasing all cookies.....doing that seems to allow the Apple pages to load. Does this give a clue to what is going on? My security program is about a year old. My system was running just fine until I upgraded. One more question......anyway to disable the icon "favorite sites" in Safari 4.0? I am very concerned about loading Snow when I get it.
Previous 1 2 3 4 Next