Previous 1 2 3 Next 156 Replies Latest reply: Mar 4, 2015 12:06 PM by jmn
Aaron Scott Level 1 Level 1 (10 points)
I have a MacMini (Early 2009). I fails to connect at gigabit ethernet speed when connected to either a netgear GS605 switch or a brand new Airport Extreme base station.

I have tried different cables, different OSs (both 10.5 and 10.6).

When I force it to 1000baseT the connection jumps between connected and not connected.


This is getting ridiculous, that Apple can't make it work properly, as there are lots of others that have the same issue.

Does anyone have any ideas?

MacBook Pro Santa Rosa 2.2GHz, Mac OS X (10.6)
  • BSteely Level 5 Level 5 (7,635 points)
    What are you using for an ethernet cable? Is it rated CAT5e or CAT6?
  • Aaron Scott Level 1 Level 1 (10 points)
    I've tried both Cat5e and Cat6
  • Shane Davis Level 1 Level 1 (75 points)
    i've had the same issue. 100 base works fine. Either thru the cabling in my wall or directly plugged into the switch. (5e in the wall, 5e to it, 5e to the switch). Try to force gig, says no cable is plugged in.

    got some cat6 cable. I swear i got gig for 1 morning plugged into the wall (mini cat6 to wall, cat5e wall to router). but now neither plugged into the wall, or the cat6 to the switch it self will gig work. No issues at all with 100base though. its baffling and i have no idea how to fix.
  • LeeOwen Level 1 Level 1 (0 points)
    Same problem here. Mac Mini wont connect gigabit to an Airport Extreme. It's not my cable. If I take the cable and plug into my macbook, it connects gigabit. When I plug into my Mac Mini it connects at 100. If I force 1000, it says ethernet not connected.
    I'm not sure when this started. I only recently noticed when media over the network began to get choppy and I went and checked what link speed I had.
    I've upgraded to Snow Leopard and I'm current with all updates.

    Help... anyone!
  • John Scott1 Level 2 Level 2 (300 points)
    I had problems using a Linksys 4 port switch. I condemned the switch but I think its Snow leopard.
    I reinstalled Snow leopard and have had no problems. Even though not everyone has had these issues and it may be connected to what hardware we use for networking. The end result is that SL does not seem to like some networks? I have given up knowing why and just use leopard until Apple addresses the issue.
  • maido Level 1 Level 1 (0 points)
    Reporting same problem here, my new mac mini just arrived yesterday, tried on 2 totally different networks, initially ethernet is correctly set on 1Gbit, then after a while, randomly, it either switches to 100Mbit, 10Mbit or no connection at all.
    Setting it to 1000Gbit manually just disconnects it as a whole.
    I was thinking it to be a hardware failure 'til I found this thread... will have to switch to Wireless 'til someone gets a clue... so much for Gigabit networking
  • daverx7 Level 1 Level 1 (0 points)
    Add another Mac Mini to the list where it will not connect in automatic or forced 1gigabit. I manually drop it to 100mbits, it connects. As the others say, I have tried known good cables and multiple switches. I am at the latest OS.

    -Dave
  • Ted_X Level 1 Level 1 (0 points)
    For the record, my mini is doing it too. I didn't know what the problem was, but my ethernet just wouldn't connect, so I was forced to connect via wireless. When my Verizon FIOS wireless got flaky, I got more annoyed with my ethernet not connecting, which prompted my google search and led me here.

    After reading the discussions, I switched to 100Mb/s half-duplex, and it connected right up. I've got a G5 and a G4 connected to the same switch at 1000Mb/s and have interchanged the cables, and the mini just will not connect at a gig.
  • daverx7 Level 1 Level 1 (0 points)
    Hmm... anyone there? It certainly doesn't look like an isolated issue here.

    ^^bump^^
  • gnwiii Level 1 Level 1 (10 points)
    I don't think this only an issue for the mini. We have problems connecting to our Gb switch with iMac and Mac Pro machines, but the wiring is old and some drops work where others connect and disconnect or will only connect at 100 Mb. For one office we ran a new drop and that solved the problem. The ports that don't work sometimes show problems (e.g., "low signal on pin x") with a cable tester.

    The old drops are in conduit, and never were reliable with SGI Octanes at 100Mb, so are clearly marginal, but booting the Mac's with Knoppix linux sometimes works when the Apple networking falls down, and windows machines don't appear to have problems (but we know from experience that windows is prone to duplex mismatches -- it is just that user expect Windows to be slow so don't notice). I have also had a case where connecting a Gb box to one drop seems to cause
    disconnects on another drop -- not sure if this is a problem in the switch or maybe crosstalk between cables that share a conduit.

    When we have problems, the log often has:

    fuji mDNSResponder[31]: Note: Frequent transitions for interface en0 (X.X.X.X); network traffic reduction measures in effect

    Once this happens you may need to delete the interface in Net Prefs and "redo from start".
  • mooblie Level 4 Level 4 (1,935 points)
    FWIW: I have a Mac mini2,1 Intel Core 2 Duo 1.83 GHz connected to a NetGear 1Gbit 8-port switch via a 6ft Cat5e cable, and I've never, ever, had any problems at connecting to it automatically at 1Gbps. So it can be done.
  • jasleinstein@mac.com Level 1 Level 1 (0 points)
    I have a new 2.5.3 Mac Mini and a 1.66 duo core. They both connect to the Airport, a five port linksys gig switch and 8 port linksys switch perfectly. Unless you are running very long runs (300ft) there is no difference between Cat 5 and Cat 6. The gig mac layers developed are so much better than previous ethernet mac layers spending money on cat 6 is a waste of money. Make sure the switches are not managed and have the ports locked down. With older switches you might need to power cycle them, also some switches have uplink ports that can behave weirdly.
  • jasleinstein@mac.com Level 1 Level 1 (0 points)
    for those of you using in wall wiring. There is quite a difference between 100Mb and Gigabit. 100Mb will run over cat 5 connections even with a wire in the wrong location. (i.e. the A configuration vs the B configuration) 1000 is a different story. It uses all 8 wires and they all have to be in the right connection. After we wired my house I bought a cable tester and found several wires not punched down or switched.
    We have also seen several issues with cheap patch cords. About a year ago I went out a bought a,, new good quality patch cables.
    hope this might help.
    This may be stupid info, but remember when you are looking at the light indicator, it indicates the signal at the other end of the cable. so if you see a wrong LED config on switch A, it is switch B that has the issue. Same is true for a systems ethernet connection if not a switch.
  • daverx7 Level 1 Level 1 (0 points)
    Thanks to those posting in this thread. It is good to know that it is being looked at by the community.

    I have to say that this problem is odd as when I 1st got my Mini, I was able to go 1Gbits... then it stopped connecting via Ethernet. That is when I switched to wireless to just surf. With it turning into my main media PC in the home theater, I have to go wired and believe I need 1Gbit.

    To test my in wall cabling, I got a $10 (i.e. CHEEEEAP)cat5 tester that will check for line breakage and if the lines are crossed, and all is good there. For the price of the tester, it does not test for the quality of the connection... It is better than nothing tho.

    For this particular Mini issue (still fighting a color static from time to time) and to get get things ready for putting media PC's around the house, I decided to up the network infrastructure a bit. With this being said, I got an HP Procurve 1800-24G, and my Mini is directly connected to it... Still 100Mbits.
    *I made sure the switch was at factory defaults... Still 100Mbits
    *I updated the firmware on the switch... Still 100Mbits

    My next step is to start from scratch on my cables and go overboard and get Cat6 cables from monoprice. They are on order, and will post the results when they come in.

    Another thing I could try is go back to the original OS and see what happens, but I really do not want to do that.

    I have a feeling that I will end up having to buy a $200 Acer Aspire Revo and run XBMC to do the work that the Mini is struggling with. Ugh.. So disappointed with this situation.

    -D
Previous 1 2 3 Next