Previous 1 4 5 6 7 8 Next 162 Replies Latest reply: Mar 11, 2016 8:28 PM by BeijingPablo Go to original post
  • CraigSmith Level 1 Level 1
    Sorry Boece, didn't even check what part part of the forum I was in. Just posted on the correct section now.

    Just realised also, all my cables and internal wiring in the network sockets are cat6.

    It's strange how my mac mini connects at Gigabit when it is the farthest computer from the switch and uses 2 x cat6 patch leads + 20m of cat6 in the loft to connect to the switch.
  • Shane Davis Level 1 Level 1
    just did the update. still no gig connection. thanks apple.
  • tphc Level 1 Level 1

    has anyone made any concrete progress on this? I'm on my second logic board and low and behold 6 months since its been changed and it drops the 1gb connection all the time. Worked flawlessly up to now... I have even just changed the switch from a belkin to a netgear and it worked for about 10 mins before dropping again.


    Very disappointed by this... my three year old macbook pro will connect fine at 1gb - and there seems to be plenty of people around who have had the same issue with their Mac Mini's.

  • Doomsdaze Level 1 Level 1

    I think I may have found a solution to this issue. I've been dealing with the same thing for two days now and finally tried re crimping my cat6 cable as a cross over cable. With my Mac Mini set to auto, it has negotiated to 1000 full duplex.


    These are my system and router specs:


    Model Name: Mac mini

    Model Identifier: Macmini3,1

    Processor Name: Intel Core 2 Duo

    Processor Speed: 2 GHz

    Memory: 4 GB

    OS Version: 10.6.8


    Router Model: Apple AirPort Extreme 2nd Gen

    Firmware Version: 7.5.2


    I am using cat6 cable rated at 600MHz. My cable length is about 46 feet. Let me know if this helps anyone out. If I start having issues again, I'll repost.

  • Ballerman Level 1 Level 1

    Does anyone know if installing OSX Lion will resolve this issue? I bought a Mac Mini back in November of 2009. Just now plugged it in. Ethernet won't work, no how. It has OSX 10.6.8. I am thinking an upgrade to Lion might fix.

  • Ballerman Level 1 Level 1

    I'll answer my own question. For me, at least, it worked. Lion eliminated the "cable unplugged" issue.

  • mortdk Level 1 Level 1

    Having the same issues with my late '09 mini. In the beginning I got 1Gbit/s links with no problems. Then after about 12 months the Mini started playing up.

    Same pattern as described in the other posts - other machines connect just fine at 1Gbit/s.


    Mini -> Netgear GS605 switch -> Linksys WRT54 router.


    also tried


    Mini -> DLink GB switch -> Linksys WRT54 router


    So today I tried re-crimping my cable to cross-over, and when inserted into the mini, the Network Utility would show the Link Speed switching between "1 Gbit/s" and "inactive" before finally settling on 100Mbit/s. This is with automatic hardware settings.

    Forcing a manual 1000baseT hardware setting switched between "not connected", "unknown state" and "Connected", before finally settling on 1 Gbit/s.


    With the cross-over cable and the mini reporting a 1 Gbit/s link however, I get:

    Internet speed has dropped from 16mbit to about 1.5mbit.

    LAN performance is rediculously slow

    Recv. Errors are piling up very fast (Network Utility)


    So even though it seems like a 1 Gbit/s link, there are issues.

    Back to the regular cable and 100Mbit.




    Side note: first saw the issues in Snow Leopard. Upgrade to Lion did not help.

  • Givememyethernet Level 1 Level 1

    We bought a mini this week (Lion, i5 2.3) and just experienced this issue.

    Same story as many posts here - no connection at 1000baseT.

    Using a D-Link DGS-1016D


    I can't believe this hasn't been addressed yet, come on apple!

  • High_Jumper Level 1 Level 1

    The fact that apple dismisses their problem and blames it on switch manufacturers says it all. On top of that they're still manufacturing macs with this problem. We have the new early 2011 macbook pros and also have the same problem. We have been forced to plug in macbook pro users into our OLDER 100base switches as opposed to our newer 1000base (cisco, btw, the largest switch manufacturer in the world!) 3750G switches. We never had the issues with the older 08,09 macbook pro models. We'll be upgrading to lion shortly but I doubt it will make a difference, I'm going to try and be positive though...

  • Mr. Isles Level 1 Level 1

    Also make sure that the ports of your router are all set to 1Gbit/s. Some routers have a power save feature that allows you to set ports to 100Mbit/s (and some have this set as a standard). For me, this fixed the problem. My router, a AVM FritzBox 7390, was set so that only port one was 1Gbit/s and the other three were set to 100MBit/s.

  • mortdk Level 1 Level 1

    I bit the bullet and tried a third switch: Linksys SE2500 Gigabit Switch


    This worked for me - now everything is back to gigabit. I just hope it lasts.

  • thangkho Level 1 Level 1




    Mine is 2008 imac. This is my Ethernet card info: Marvell Yukon Gigabit Adapter 88E8055 Singleport Copper SA


    I guess we can still settle with 100Mbps if we want a wired connection.


    In case you have problem with the link. Here is the instruction:

    To change the speed setting:

    1. From the Apple menu, select System Preferences...
    2. Select the Network pane.
    3. Highlight the Built-in Ethernet line and click the Configure... button.
    4. Select the Ethernet tab.
    5. Change the Configure: drop-down menu to Manually (Advanced).
    6. Change the Speed: drop-down menu to 100baseTX.
    7. Click the Apply Now button.
  • sebastiansulinski Level 1 Level 1

    I was going nuts - because of this.

    I have 3 iMacs and one MacBook Pro on the network - none of them works with 1000TbaseT.


    I use ES-5240GE (Gigabit switch by Edimax), the whole ethernet network is using CAT6A and the router I use is the DrayTek 2830Vn Plus (Gigabit, heavy duty router).


    The Router and Time Capsule (which I also have connected to the network) work with gigabit, but none of the computers.


    Anyone got any luck with that?

  • ckm_apple Level 1 Level 1

    SOLVED!  mortdk has the correct solution!!!


    I have had this problem for over a year.  My Mac Mini (2gh Core2Duo) worked perfectly for a couple of years, then suddenly stopped connecting at 1000baseT - it only worked at 100bT.


    I tried a bunch of things, from short high-end Cat6 cables to mucking around with kernel extensions from the command line and every possible software setting.  I also bought four routers:


    • TrendNet TEG-S50g
    • Netgear GS105
    • Dlink DSG-1005G
    • Linksys SE2500


    I also connected it directly to both a Asus Black Diamond router and a ZyXel SOHO 5 Firewall.  


    In the end, only one thing actually solved the problem, the Linksys SE2500.  I bought it last week directly from Cisco, it was $29 + shipping. 

  bit-Ethernet-Switch_stcVVproductId140936323VVviewprod.htm?icid=se2500_new_pdp&sr c2=se2500_new_pdp


    Completely worth it and seems to be the appropriate solution.  My ethernet connection has been stable at 1000bt for a couple of days....





  • danwoody Level 1 Level 1

    Hi Chris,


    I'm having the same problem on my Mac Mini and was wondering if you still have a stable gigabit connection using the Linksys SE2500?




Previous 1 4 5 6 7 8 Next