Previous 1 5 6 7 8 9 Next 157 Replies Latest reply: Sep 1, 2015 1:13 PM by shooterEET Go to original post
  • ckm_apple Level 1 Level 1 (0 points)

    It's stopped working a couple of times (unplugging, plugging in fixes it) under heavy load, but nothing like what it was before (which was unusable).   However the speed is no better at 1000bt than it is at 100bt, so YMMV - that could also be down to my NAS appliance.


    I'm just happy it's not disconnecting every minute.

  • Robert Sinton Level 1 Level 1 (15 points)

    RESOLVED by enabling flow control on switch


    Apologies if this or something like it has already been mentioned — it's a long thread!


    I have a brand-new Cisco gigabit managed switch, iMacs and MacBooks connecting to it fine at gigabit speeds. Two brand-new 2011 Mac Minis refused to


    From hints here and elsewhere about IEEE 802.3, I eventually found that the Cisco's ports defaulted to having "flow control" turned off. It turned it on and the Mac Mini I was testing with immediately connected at 1000BaseT - problem solved! (Hopefully it sticks.)

  • UFOGoldorak Level 1 Level 1 (10 points)

    Have we gotten anywhere with this??


    I just spent my whole day rewiring my house with cat6, upgrading to 5th generation extreme base stations, replacing all switches with netgear gigabit switches and replacing all patch cables to cat6.


    1 Signle stupid mac mini refuses to connect at 1000BaseT.  When I connect the cable I can see it in the advanced hardware tab switching to 1000BaseT then diconnecing a few times.  After 5 or so tries is settles and connects at 100BaseTX.  I unglug cable from back of mac mini and plug it into macbook pro and boom instant 1000BaseT.  What gives??  I have an older mac mini that works just fine.  A new mac mini that works just fine.  Tested all my laptops all connect no problem at 1000BaseT.  Only this stupid 1.8 Core Duo mini running 10.5.8.


    If I force it to 1000BaseT after connecting and disconnecting a while if finally connects but bandwith is about 0.


    Is it the OS??  Firmware??

  • Ladiv Level 1 Level 1 (0 points)

    We also have a 2011 Mac Mini running Lion that refuses to connect at 1000BaseT.  10 foot Ethernet cable to the Airport Extreme in Bridge Mode, but all our other macs - imac and macbook pro - when using the SAME cable, connect with no problem at 1000BaseT.  Any suggestions??? Help please!

  • Gerry Brown Level 3 Level 3 (795 points)


    What is your setting in the System Preferences -> Network -> Ethernet -> Advanced -> Hardware -> Configure.  It should be set at Automatically.


    If that doesn't work, set it to "Manually", Then set speed to "1000BaseT", Duplex to "full-duplex, flow-control" and finally MTU to "Standard (1500).

  • Ladiv Level 1 Level 1 (0 points)

    Thanks for the tips Gerry, but it doesn't get me any further... When I go to manual and all the associated settings, it stops recognizing the cable. In automatic the speed goes automatically down to 100baseT. Since the same cable connected to the iMac and MacBook pro functions perfectly, I assume it's not the cable, but I did try switching it out, same sad results. Any other ideas would be most welcome!

  • mhvrr Level 1 Level 1 (0 points)



    Did you find a solution to your problem ?

    I have a similar one with 2 10.6.8, one 10.7.4...

    The 10.6.8 won't ever negotiate 1Gbit (only in manual) and if I set it in manual -> link dead: )

    If you found any magic solutions, please let me know.

  • Ladiv Level 1 Level 1 (0 points)

    Hi Mhvrr, we never did figure it out.  We checked absolutely everthing and it just wont work.  Let me know if you figure it out.

  • mhvrr Level 1 Level 1 (0 points)

    I'm upgrading to Mountain Lion this week as I've exhausted all the polite means of finding a solution.

    Some time ago, forcing the card to 1000Base-T and connecting it to something else (not another Macbook) used to work (port forced on the other side also).

    Now with my current setup that is failing also.

    It's not a switch, cable, other laptop thing...I guess it's a bug

    Will let you know if the upgrade fixes it.

  • ckm5 Level 1 Level 1 (0 points)

    It's a flow control collision between the Mac hardware/software & the switch.  I solved it by upgrading to a better quality switch (see above).  No amount of operating system tweaking or upgrades will solve it.


    I have a new iMac and it has similar (though not as severe) upstream problems.  I've got a new core switch coming that should solve that issue.


    The real mystery is why this became a problem later rather than being a problem right at the begining.  My guess is that Apple decided to change flow-control in a way that broke a lot of cheap switches...

  • mhvrr Level 1 Level 1 (0 points)

    not a switch in my case.

    Macbook Pro - back to back with another Macbook Pro.

    The Snow Leopard one never does auto negotiate 1 Gbps (not even with a switch; but with a switch it accepts at least the interface forced into 1Gbps and it works).

    The Mountain Lion (the second Macbook Pro) autonegotiates at 1 Gbps in all cases and this is good.

    So I think mine is a software issue with Snow Leopard.

  • ckm5 Level 1 Level 1 (0 points)

    Believe what you want, but flow control is known to cause issues, particularly with TCP/IP traffic, and not just in Macs (OSX does seem to be more sensitive than Win,Linux & BSD, however).



    I've upgraded operating systems twice - from Leopard to Snow Leopard to Lion and it's made zero difference.  Neither has downgrading to a previous OS.  Switching to better hardware, however, made a huge difference.  1000bt was stable.  Basically, if your switch doesn't support 802.1x flow control (and most under about $150 don't), then you should look at that first.


    But, hey, go ahead.  If it fixes your problem, great, but you would be the exception rather than the norm...

  • mhvrr Level 1 Level 1 (0 points)

    If by saying that I'm connecting back 2 back two Macbooks you can see any switch present in the setup, then the beer is on me ! (with two other Macbooks here at work that functions without any problem in the same setup).

    The flow control thing I already tried with one of those "cheap Cisco switches"

    Will let you know how my quest goes and maybe I have more luck than the previous poster before me (Ladiv)

  • ckm5 Level 1 Level 1 (0 points)

    You're right, I didn't pickup on your linking them back to back.  However, just because you hook up to machines back to back doesn't mean the flow control issues go away, it may actually make them worse - read the link I sent.


    If you are using a Cisco switch (and you've made sure it has 802.1x, not all of them do - the old low-end Linksys line doesn't, for example), then I'm going to guess your hardware is bad like a couple of other people upthread.


    The real test would be to install another OS (Windows, Linux or BSD) and see if you still have issues.  If not, it's def. the software and downgrading to a known working version is the most sensible approach.

  • Ladiv Level 1 Level 1 (0 points)

    Upgrading to mountain lion on all my devices has solved my problem! 

Previous 1 5 6 7 8 9 Next