Previous 1 27 28 29 30 31 Next 571 Replies Latest reply: Oct 15, 2015 2:46 AM by MDJCM Go to original post Branched to a new discussion.
  • Qholmes Level 1 Level 1

    I have had this issue every since i got my iMac about a year ago. I never have to reboot i just force to to sleep either with the on button or using the key sequence. I wait for 10 sec and then wake it up with the keyboard or mouse. Works fine but is a pain. I too hate the thought of wasting energy for no reason..... especially with an expensive Mac... I sent my machine into local apple service and they had it for a couple weeks while i was away and when i got back the just said they could not recreate the issue....................... they could have let me know before then i thought. So went down changed the sleep settings to a short time and it did the error right in front of everyone. I was not there 5 min and left again....... They changed the video card or something and sent me on my way but it happened as soon as i took it home again. Changing the setting to wake up on Network access to off seemed to help mine a bit. It did not do it as much but still does it. I think upgraded to Lion just a couple weeks ago and that did not change anything either. I use the Mac Bluetooth keyboard and a usb wireless mouse. I also have an external drive for time machine.


    My Mac does this when it tries to go to sleep but does not quite make it.. I have an external monitor as well and that monitor does wake up but the main display does not.


    Before Lion when i was trying to figure out what was going on.. i even had the display not come on a few times when it booted.


    I am in the middle of a Mac project right now but once i get some time i will haul it over to the repair center and let them play with it some more i guess.


    The only other think i have that is extra is 4 gigs of extra ram. Bought it from Apple so i have a total of 8 gigs.



  • italo_sgt Level 1 Level 1

    The sleep problem was a display issue like yellow tinge.. i've tried everything and replaced all (4 display and all with problems, ram, hdd, mainboard and processor), now Apple will send me a new imac. I hope that this will be perfect!

    Apple please change display panel brand (LG) it's ridicoulous, i've spent a lot of money.. i've buyed a dell 22" monitor same years ago for 200€ and it was great, the LG panels on imac cost 600€ and is like a 100€ display!

  • targus Level 1 Level 1

    The initiate sleep and then wake it instead of a reboot trick never worked for me, Qholmes. I suspect there are at LEAST two to three variants on the issue here that we're all lumping together but probably have vastly different causes and solutions (number of bluetooth or usb devices attached, bad logic board, display issues, etc.) It's maddening!

  • targus Level 1 Level 1

    In fact, I'm convinced that I myself have experienced two variants just over the last couple days:


    version 1:

    Fans and drive noise kick in, but monitor won't turn on. Light on attached Wacom tablet off and does not turn on with input. Only choice is to reboot by holding power button down and pressing again. Reboot works with no issue.


    version 2:

    No reaction from computer as far as fan or disk noise. Computer sleeps even when preferences set to NEVER SLEEP. Light remains on on Wacom tablet. Attempted reboot always results in kernel panic.


    For now, I'm really concerned with (2). (1) I think I can learn to live with provided I can prevent the computer from sleeping at all.

  • Qholmes Level 1 Level 1

    Now did you try putting it to sleep and waiting like i said? for 10 sec... if i dont wait then it makes it worse and might need a reboot. It drives me crazy as i have a PC beside my Mac and i work on both at the same time switching back and forth and when i have to wait 30 sec to sort out the display it just ticks me off.. over and over all day. I did finally just set it to a long period of time before anything shuts off but then i think about the extra electricity i am using.. Not a huge deal but i do try to reduce my usage when i can.. and i am sure it is reducing the life of the screen as well..



  • Qholmes Level 1 Level 1

    Yes 2 would bother me too... i was a bit worried the few times i rebooted and i had no display..



  • targus Level 1 Level 1

    I don't know if I waited a full 10 seconds or not. One of the more frustrating things about this problem is that it takes so **** long to troubleshoot. I need at least 4 hours to let the machine go into weird sleep before I can test anything...

  • Qholmes Level 1 Level 1

    Really... i can reproduce it pretty quick. I just set the sleep and display time to something small like 1 and 2 min and i can make it do it.. Maybe not the first time but pretty quick.



  • targus Level 1 Level 1

    I can wake mine from short sleeps, but longer ones (overnight or at least 4 hours in my experience) are what causes the issue. This makes me think that you and I are likely dealing with different issues...

  • Qholmes Level 1 Level 1

    Yes it could very well be different.



  • targus Level 1 Level 1

    Well, I'm sad to report that the computer shut down/went to sleep/went into mysterious coma mode yet again, so I guess it wasn't the Wacom tablet after all. To make matters worse, I get kernel panic errors quite often on reboot - sometimes instantly, sometimes after a little while. When I examine the log, it looks like the cause is different every time (Finder, GeekTools, etc.). That fact, along with the fact that I'm working from a clean install less than 24 hours old leads me to believe there is some sort of hardware issue here, perhaps with the logic board or something...


    Headed to the Genius Bar this evening. Hoping for the best!

  • Mixal Level 1 Level 1
    1/13/12 AM 07:34:50configd[14]Sleep: Success - AC Success 0 Success C1E15221-541D-4099-A92A-7A48B1F153E7


    1/13/12 AM 07:34:50configd[14]Wake: Drivers Failure - AC - MCHC P0P2 EHC2 HDEF RP01 RP02 RP03 EHC1 LPCB SATA SBUS Drivers Failure Failure


    1/13/12 AM 07:51:52UnmountAssistant[568]Volume unmounted successfully Volume unmounted successfully success


    1/17/12 AM 07:36:50configd[14]Sleep: Success - AC Success 0 Success 9C574138-9DD6-4B21-87AE-B304216DA330


    1/17/12 AM 07:36:50configd[14]Wake: Drivers Failure - AC - MCHC P0P2 EHC2 HDEF RP01 RP02 RP03 EHC1 LPCB SATA SBUS Drivers Failure Failure

  • Snagged Level 1 Level 1

    Update: I just bought my 21.5 " IMac back around the first of July 2011 with Snow Leopard installed. When Lion came out I immediately installed it and that's when this issue came up. It just would not wake up 1st thing in the morning. So had to use the power button to turn it off and back on. I happen across this thread and tried a couple of things.


    1. Went into Systems Preferences> Network> and deleted the WiFi  and then added the WiFi  back in.

    2. Went into the Disk Utility and ran Fix Permissions

    3. Installed the 10.7.1 update.


    I don't know which fixed the issue, but, I haven't had reoccurrence of this issue since.

    Hope it helps

  • sean_a Level 1 Level 1

    I've had this problem all along since early 2010, but I think it's more serious than just updating drivers:


    I have a 27" iMac and my wife has a 21" iMac.  This happens to both of us.


    We both use wireless keyboard, wireless mouse and trackpad.  When this problem occurs, none of the devices can wakeup the iMac.  I have to push the power button to see the screen and even then, none of the devices can sync up with the iMac.  This only happens when the iMac is put to sleep (Cmd, Option, Eject) for a long time, such as overnight.


    So I attached a wired USB mouse at that state to see if the system was responsive.  The time was correct, so it wasn't really locked up.  The USB mouse got my cursor back, yet when I tried to open the Bluetooth connection, but it was just hanging.  I decided to "Restart" the Mac.  The screen went white and the Spinning Wheel (not the spinning beach ball) displayed.  The system simply would not shut down, unless if I held the power down and rebooted the Mac.


    This tells me a few things.  1) For any Bluetooth or wireless device to be able to turn on the Mac and bring it out of sleep, the radio for the device needs to be on and in constant communication with the devices, even if the system is in sleep.  2) The nature of Bluetooth is that it created a network connection to each device which is different than WiFi.  That's why you can only use one wireless phone with a bluetooth headset, even though if you pair multiple phones with it.


    So since the "network" connection is disconnected from all available Bluetooth devices, this tells me that the radio inside the iMac is turning off and can't see the devices (that's why neither of them can bring it out of sleep), and when the power is restored by pushing the button, it simply does not come back up again (locks up) because the driver is still running and it thinks the radio is still on, but the chipset is shut down.  A reboot resets the registers in the radio and reconnects the devices based on their MAC address.


    This is either a flaw in the chipset, an issue with the driver or a combination.  My guess goes toward the chipset issue which unfortunately is difficult or impossible to fix without changing the radio module.  These type of chips unfortunately are not programmable and they simply need to be replaced.  I'll do more testing by trying to kill different process while I have the terminal window open next time.

  • daftpunk74 Level 1 Level 1

    I, too, have had this problem with a brand new iMac 27". I've got a slightly different approach that I take when this happens, FWIW.


    This only occurs after leaving the machine for a day without use -- so I'm not sure if this is a "deep" sleep issue only or what. The same problem as others see -- no wake from keyboard or mouse, but I can wake up with power button press.


    I connect via VNC / Screen Sharing and run Bluetooth Explorer. I open Utiltiies->HCI Controller Selector (Cmd-K), and it shows that the "Apple BRCM ..." host controller is not active. I click activate and type in the admin password, then the devices wake up and the OS indicates that the Keyboard, Mouse and Trackpad are connected.


    Seems to indicate an issue reactivating the host controller after coming out of a "deep" sleep.

Previous 1 27 28 29 30 31 Next