Previous 1 2 3 Next 34 Replies Latest reply: Jan 19, 2010 1:01 PM by b noir
kejsarinna Level 1 Level 1 (0 points)
I can't get the new itunes upgrade to install. I tried the update, that didn't work. So I unistalled itunes and quicktime thinking this might help. It didn't. I've tried everything the support says and it still won't download. I then downloaded only and when I go to the "open downloaded files" from the tool bar from the apple software update window, I click on the apple application support and I get this error:

An error occured during the installation of assembly 'Microsoft.VC80.............................HRESULT: 0x8007054F

I can install the itunes and quicktime from the update window, but without the application support, i can't do anything with it. Please Help!

I'm using Vista and running Internet Explorer if that helps.

Dell Studio, Windows Vista
  • b noir Level 9 Level 9 (72,020 points)
    An error occured during the installation of assembly 'Microsoft.VC80.............................HRESULT: 0x8007054F


    ... One of those ...

    A few questions before proceeding, kejsarinna. (This one seems to come in a variety of different flavors, and the details of your answers may help with determining a solution.)

    (1) What particular version of Vista are you using? (Home Premium, Professional, Ultimate, etc.) Is it 32-bit or 64-bit?
    (2) Head into your Windows Update, and click on your Update History. Have updates been failing for you in recent times? If so, doubleclick on each failed update to brinf up further information on each failed update. What *error code* have the updates been failing with?
    (3) Do you currently have a copy of Microsoft Visual C++ 2005 installed on the PC?
  • aid8m Level 1 Level 1 (5 points)
    I hate to jump in on someone else's topic, but I have been getting the same error as above when I tried to upgrade to the latest iTunes on my Vista system. I have tried several suggestions on various threads here, including this one: http://discussions.apple.com/thread.jspa?threadID=2251840&tstart=0&messageID=107 35122#10735122 all with no success.

    I am running Vista Ultimate (64-bit). The Only update I've had fail recently and consistently is Update for Microsoft XML Core Services 4.0 Service Pack 2 KB973688 with error code 643. I currently have a copy of Microsoft Visual C++ 2005 Redistributable and Microsoft Visual C++ 2005 Redistributable (x64) on my installed programs list. Can provide more details, if needed.

    I would appreciate any help you can offer b noir. I am getting pretty close to thinking I need to go nuclear and re-install my OS.
  • b noir Level 9 Level 9 (72,020 points)
    Nearly missed you aid8m. My subscription had lapsed to this thread, so I didn't get any reply notifications for your post.

    I currently have a copy of Microsoft Visual C++ 2005 Redistributable and Microsoft Visual C++ 2005 Redistributable (x64)


    Okay ... try downloading and installing the following security update for that one:

    [Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package ATL Security Update|http://www.microsoft.com/downloads/details.aspx?familyid=766a6af7-ec73-4 0ff-b072-9112bab119c2&displaylang=en#filelist]

    Does that install successfully or does it throw a similar 1935 error message (like you get on the iTunes install)?

    If you get the security update to install, can you get iTunes to install afterwards?
  • aid8m Level 1 Level 1 (5 points)
    B Noir,

    Glad you saw this.

    I tried installing the update and I did get the 1935 error message when trying to install that update.
  • b noir Level 9 Level 9 (72,020 points)
    Drat ... that update seems to work for some people, but has the same sort of error message (as the iTunes install) for others.

    Okay ... the next thing we try is attempting to fix the Windows Update error. Sometimes if that can be repaired, the iTunes installation problem can be fixed +en passant.+

    A 643 is a pretty generic error code, so we'll try the "Fix it" button from the following document (first in Default mode and next in Agressive mode):

    [How do I reset Windows Update components?|http://support.microsoft.com/kb/971058]

    Any better luck with an iTunes install after either the default or agressive mode of the fix it?
  • aid8m Level 1 Level 1 (5 points)
    Ran it both ways and still no luck.

    FYI - Wile trying your suggestions, I also downloaded the Update for Microsoft XML Core Services 4.0 Service Pack 2 KB973688 and tried installing it manually and received the error: "An error occurred during the installation of assembly component {7B2B4EA5-1028-B7E6-A06B-D6B9ABF34537}. HRESULT: 80070003"

    I looked up the error on the MS website, and tried the suggestions there, then I contacted Microsoft support, and they suggested I remove and re-install MSXML 4.0 Service Pack 2, MSXML 4.0 SP2 Security Update (KB936181), and Security Update for MSXML 4.0 Service Pack 2 (KB973688). The first two installed fine, but the third gave me the same 80070003 error. I have asked MS Support what i should try next, but I haven't gotten their response.

    Thanks.
  • b noir Level 9 Level 9 (72,020 points)
    These issues seem to be a troubleshooting work-in-progress over at Microsoft. (They certainly are here.)

    Given that you've got a Vista Ultimate, there's something we can check on with your PC that I haven't been able to do with a lot of other folks. The way that the install stops at the "publishing product information" stage of the Apple Application Support install is reminiscent of an ancient (now extinct) issue that could hit iTunes at the publishing product information stage of an install. So there's an exotic setting on your PC (related to that) that it would be good if we could have a look at.

    Open your Control Panel and switch to "Classic View".

    Open "Administrative Tools"
    Open "Local Security Policy"
    Select "User rights assignment"
    Doubleclick "Impersonate a client after authentication"

    What entries show up in the Window there? For example, I have:

    ASPNET
    Administrators
    SERVICE
  • aid8m Level 1 Level 1 (5 points)
    Thanks for checking in again so quickly.

    I see 4 categories under "User Rights Assignment":

    Administrators
    LOCAL SERVICE
    NETWORK SERVICE
    SERVICE

    Also - FYI to anyone who may check out this thread later - Once in "Local Security Policy", I had to go into "Local Policies" to find "User Rights Assignment", so if you're having trouble finding it, you might check that folder.
  • b noir Level 9 Level 9 (72,020 points)
    Once in "Local Security Policy", I had to go into "Local Policies" to find "User Rights Assignment", so if you're having trouble finding it, you might check that folder.


    Ahhh! Thank you kindly. Sorry about that, I should have checked on the Vista box instead of on the XP Pro box.

    Okay ... the key to the old iTunes issue was that there was a missing Administrators and/or SERVICE in there, so I think we've ruled that possibility out.

    I think we can probably rule out the "broken Windows Modules Installer" possibility with you too. Although the poor folks with that variant of things (typically on Vista 64-bit Home Premium boxes) get a 1935 when they try to download the redistributable security update, they typically can't get any Windows Updates to install, and their error message codes are consistently Code 0x80070424 on both the failing Windows updates and the failing iTunes installs.

    For the sake of folks following this thread, here's a link to the thread where we've done the bulk of the troubleshooting work (here to date) on that particular Code 0x80070424 variation:

    http://discussions.apple.com/thread.jspa?messageID=10597133&#10597133

    If you're game for more experimentation, there's a couple more things I can think of that might be worth pursuing.

    The first one is operating system damage. If perhaps one or the other of those files we tried reregistering/resetting (using the Fixit) are damaged rather than deregistered or otherwise-grumpy, then an sfc scannow may be able to help with matters.

    So perhaps try running an sfc /scannow as per the following document:

    [How to use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7|http://support.microsoft.com/kb/929833]

    If the scannow reports that it can't repair any files, could you let us know what the sfcdetails.txt says about them?

    If the scannow does find and repair damaged files, do you have any better luck with the updates and/or iTunes install?
  • aid8m Level 1 Level 1 (5 points)
    Okay, I ran the scannow, and it reported that there were files it couldn't repair. However, I can't get a sfcdetails.txt file. I haven't used DOS or Command Prompt in a long while, so I might be making a simple error. I have copied the session below.


    Microsoft Windows [Version 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>findstr /C:"[SR] Cannot repair member file" %windir%\logs\cb
    s\cbs.log >sfcdetails.txt

    C:\Windows\system32>edit sfcdetails.txt
    'edit' is not recognized as an internal or external command,
    operable program or batch file.

    C:\Windows\system32>
  • aid8m Level 1 Level 1 (5 points)
    Maybe I should note that I did put in the [] brackets above, but the forum tried to turn them into links. I basically copied and pasted the commands from the link you provided.
  • b noir Level 9 Level 9 (72,020 points)
    No, you've got the syntax right ... that message seems to suggest that Windows can't find edit ...

    Most of the informaion I'm turning up on that issue relates to XP. I'm going to dig a little deeper and check to see if I can turn up something a little more Vista-specific.
  • iphone3Gguy Level 3 Level 3 (565 points)
    1. Download WinRar http://www.rarlab.com/download.htm (they have 64-bit version)
    2. right-click itunessetup.exe and choose extract to \iTunesSetup
    3. Open iTunesSetup folder and double click on the AppleMobileDeviceSupport.msi any of the other individual components you want to install within the package.
  • aid8m Level 1 Level 1 (5 points)
    Dude, thanks for the advice, but I've tried that. I can get all of the .msi's within the iTunes setup to work except Apple Application Support, which keeps giving me the error that b noir and I have been trying to solve.
Previous 1 2 3 Next