Previous 1 2 3 Next 39 Replies Latest reply: Mar 14, 2010 8:22 PM by BDAqua
garp_ct Level 1 Level 1 (0 points)
My trusty G4 MDD Dual 1.25 GHz (M8570) has been a true workhorse for the past 6+ years and has performed almost flawlessly. However, I just experienced my first major problem with it, and am in search of some guidance. I’ve spent a few hours reading through the numerous topics here that I believe to be germane to my issue, and have collected lots of useful information and made copius notes, but unfortunately, I still haven’t yet found a solution. So please bear with me!

This past weekend, my neighborhood suffered an 11-hour power outage due to a windstorm. I normally keep my MDD plugged in when it’s not in use, but not turned on or in sleep mode. The power cord is connected to a decent, commercial-grade Isobar power strip with a surge-protection feature.

When I went to use the computer on Monday morning, it wouldn’t start. The MDD’s power button lights up when pressed, and goes out when I release pressure on it. My 20-inch Cinema Display’s (A1038) power button also lights up when touched, and goes out when I remove my finger.

I initially suspected that the PRAM battery might’ve gotten drained during the power outage, so I replaced it with a new one measuring 3.6 volts as part of a logic board reset. When that failed to achieve a normal start-up, I performed a PMU reset. Still nothing.

While I normally turn the computer on using the Cinema Display’s power button, I had read about problems with the MDD’s power button board, and per a suggestion found here, I attempted to start it with an almost-new Apple USB keyboard with a built-in power button (model M2452), but that didn’t work.

I’ve read a lot about power supply failures here on the G4 MDDs, and am hoping/praying that this isn’t the problem with my machine. But this raised two questions:

a) Since the Cinema Display gets its power from the MDD via a 28-volt ADC connection, can I presume that since the display’s power light illuminates when touched that the MDD’s power supply is functioning normally?

b) Does the red LED on the logic board illuminate whenever power is supplied to the computer, or only when the computer is on and running? The LED is not illuminated right now, presumably because I can’t get the machine started.

I don’t own a multi-tester, but I guess my next step would be to purchase one and start checking things, beginning with the +5V trickle charge from the power supply. I also own a G4 Sawtooth that could be cannibalized as part of a rescue operation, but I don’t believe that there are many (if any) interchangeable components between the two machines.

Any guidance would be very much appreciated.

Power Mac G4 MDD Dual 1.25 GHz, Mac OS X (10.4.11)
  • kmac1036 Level 4 Level 4 (2,360 points)
    have you tried plugging the mac directly into the wall? there could have been a brown out or a surge to the mac.

    know this doesn't help now, but surge strips are actually useless for computers, when it justs allows them to abruptly shut down & I'm curious as to how much voltage comes thru before they cut out...

    but, it does sound like the psu has gone south. I believe there should be an LED lit on the board when there is proper voltage to the machine, booted or not.
  • Texas Mac Man Level 8 Level 8 (46,545 points)
    Usually when the no start occurs after a power interruption, a PMU reset "fixes" the problem. See Mac PRAM, NVRAM, CUDA/PMU & Battery Tutorial

     Cheers, Tom

  • garp_ct Level 1 Level 1 (0 points)
    I did attempt to start the G4 MDD after plugging it directly into a wall outlet, but it didn’t produce a different result. I also tested the surge strip with my G4 Sawtooth, and everything seemed to work fine. But I hear ya on the questionable functionality of surge strips — they provide a false sense of security that I haven’t been able to wean myself from.

    I’m going to contact a fellow G4 MDD user this evening to verify your suspicion on the LED issue. It’s been a long time since I’ve looked for that illuminated LED, so I can’t recall if mine was illuminated in the unbooted state.

    Thanks very much for the link to the tutorial, Texas Mac Man. I’m going to go through it this evening with a fine-tooth comb to see if there’s anything I might’ve missed. The fact that the Cinema Display appears to be receiving some power from the G4 MDD’s ADC is giving me a slight glimmer of hope that this may not be a PSU issue. I’m also going to try reseating the MoBo and RAM boards — I have no idea if they could be suspect, but I guess it couldn’t hurt to check. I’ll report back tomorrow.
  • Texas Mac Man Level 8 Level 8 (46,545 points)
    Not sure if it also applies to the G4 MDD, but the red LED on the Power Mac G4 (AGP Graphics) logic board indicates that there is power to the board and does not
    imply a fault condition. Hardware such as DIMMs and PCI cards should not be installed or removed when the LED is on.

     Cheers, Tom
  • Karbon Level 2 Level 2 (285 points)
    Yes, the red light does light up in the MDD when the power light is pressed - looks to be the first thing to react in the one I have here (1.25ghz DP).

    Did you try unplugging the ADC monitor from the MDD (it sounds like you have them directly connected), and see if that helps? The ADC voltage is one of the things suspected in killing the power supplies, as it continues drawing voltage power even when the machine is turned off, creating heat and eventually frying the PSU.
  • garp_ct Level 1 Level 1 (0 points)
    Thanks very much for the suggestion. I tried to power up the MDD with the ADC monitor unplugged, but unfortunately, it didn’t work. I also reseated the cards — including the RAM — with no success.

    It’s odd — the PSU appears to be delivering enough power to illuminate the MDD’s power button and (with the ADC monitor plugged into the MDD) the Cinema Display’s power button, but not enough to “turn the starter” (so to speak). I’m not seeing illumination of the red LED on the logic board when the power button is pressed, so that might indicate a PSU problem as well.

    My neighbor has kindly loaned me his old analog multitester, so tomorrow’s project will be to perform a PSU voltage test.
  • Texas Mac Man Level 8 Level 8 (46,545 points)
    Have you tried the PMU reset as suggested earlier.

    Also, try *Resetting the Logic Board*

    Resetting the logic board can resolve many system problems. Whenever you have a
    unit that fails to power up, you should follow this procedure
    before replacing any modules.
    1 Unplug the computer.
    2 Press the Power On button on the front of the unit.
    3 Open the side access panel.
    4 Remove the battery from the logic board.
    5 Wait at least 10 minutes before replacing the battery.
    6 Make sure the battery is installed in the correct +/-
    direction.
    7 Reassemble the computer and test the unit.

    Note:
    This procedure resets the computer’s PRAM. Be sure to
    check the computer’s time/date and other system parameter settings

     Cheers, Tom
  • garp_ct Level 1 Level 1 (0 points)
    I’ve done a few PMU resets and Logic Board resets, but to no effect. The PRAM battery is new and tests at +3.6V. The MDD’s power button continues to light when pressed, as does the Cinema Display’s power button.

    Using the multimeter, I’ve verified a good +5V trickle charge using Pin #1 (purple, +5V) and Pin #13 (black, ground), so that’s a small glimmer of hope. But I’m stumped as to what I should be checking next. I have a valid pin-out diagram for the PSU connector that indicates appropriate voltages, but there doesn’t appear to be an Apple Support article specific to testing power supply voltages on the Power Mac G4 MDD, which uses a 24-pin connector. Article 58561 covers the Power Mac G3 (Blue and White) and Power Mac G4 (AGP Graphics and PCI Graphics), which uses a 20-pin connector. Article 95064 covers the Power Mac G4 (Gigabit Ethernet), which uses a 22-pin connector.

    The PSU is original — a Samsung, Apple Part No.614-0224. I’m presuming that if the PSU’s internal 250V 8A micro fuse was blown, I wouldn’t be getting any power button lights or a trickle charge at all.
  • garp_ct Level 1 Level 1 (0 points)
    Well, I did a little more hunting around here — I’m always amazed at the resources to be found at Apple Discussions — and found another thread which linked to japamac’s excellent MDD PSU Test. The instructions indicate that “the 24-pin connector needs to stay connected to the logic board." I may be a bit dimwitted here, but how exactly does one test the individual pins on the PSU connector without first unplugging it from the logic board? I tested the pins several times with the computer plugged in, but with the PSU’s 24-pin connector removed from the logic board, and the results aren’t encouraging:

    · Pin 12 to Pin 14 should measure +25V, ±1V — good
    · Pin 12 to Pin 1 should measure +5V — good
    · Pin 12 to Pin 24 should measure +12V — nothing
    · Pin 12 to Pin 6 should measure approximately +3.3V — nothing
    · Pin 12 to Pin 3 should measure approximately +5V — nothing
    · Pin 12 to Pin 10 should measure approximately +12V — nothing

    These results may help to explain why the power buttons are glowing when pressed, but nothing else is working. Looks like I may need to go PSU shopping tomorrow.
  • xarcos32 Level 1 Level 1 (0 points)
    I have just come across a similar problem with my computer (1.42 GHz DP MDD FW800), except there was no power outage involved. The computer was working fine when I powered it down and took everything apart to organize my computer room. After I was done, I plugged everything back and when I tried to power the computer up, it would not start. The power button turns on briefly, for just a moment, and then turns off. Sometimes you can hear the fan power up momentarily and turn off as well. If I leave the power button pressed the power button flashes once and does not come on again, but the lights inside the computer (logic board, ethernet card, video card) and fans all power up for just a moment (just enough to see fan movement) and continue to do so every few seconds or so, for as long as I keep the button pressed. I reset the logic board as suggested above without any change. I have no idea if replacing the battery would be of any use. Any help would be appreciated.
  • John Bicht Level 1 Level 1 (25 points)
    Similar stuff with my MDD. It started some weeks ago, and is getting worse. For a while it wouldn't light the light for a couple of minutes after shutting down, but would progressively show mores signs of alertness over the next few minutes (th light would stay on longer). After more minutes it might even chime and show signs of starting, but I would get a message on the screen to restart the computer.

    This problem really seems as if something has to charge up to allow booting, but isn't getting enough of what it wants to allow a boot.

    Last week, after 20 minutes it would start (boot) - this week it took an hour and a bit.

    Odd to me that it will run fine for a week, and this problem only shows up at startup. I even tried to fool the unit by doing a restart instead of shutdown. Didn't work, it took 20 minutes before it would boot.

    With these bits of information someone at Apple must surely know the cause.
  • RBC03 Level 1 Level 1 (0 points)
    I had a similar problem with my G5. For what it's worth it turned out to by the power supply unit. took it to Apple and they replaced it and it's been working fine thus far.
  • garp_ct Level 1 Level 1 (0 points)
    Thanks very much. I’ve got a replacement PSU on its way to me as I type this, and will report back once I’ve installed it.
  • xarcos32 Level 1 Level 1 (0 points)
    I am curious. How much did you pay for the power supply unit? I looked them up on eBay and they seem to run upwards of $100. Not sure it is worth the expense when I probably would have difficulty selling it for more than $300.

    Interestingly, last couple of times I have tried to turn it on, the booting process progresses to the point where I can see the Apple logo on the screen before it shuts down.
Previous 1 2 3 Next