1 Reply Latest reply: Dec 5, 2009 4:18 PM by K Shaffer
PK Windmill Level 1 Level 1 (0 points)
I have a mac with 2 printers (one brand new out of the box). In the last month, it will print all colors except for black/gray on either printer. Yes, there is plenty of ink in both printers, and the printers copy/scan without issue. A Dell PC prints just fine on either printer. All colors except black/gray print. Grayscale printing consists only of the cyan component. Reds and blues print fine.

Telephone Apple support and genius bar are stumped, we looked at Color Matching under 'Print', Vendor-matching, reloading the print drivers, all without effect. The black fonts are in the document's print preview, its almost as if the mac is equating white with black.

MacBook Pro 17, Mac OS X (10.5.8)
  • K Shaffer Level 6 Level 6 (11,360 points)
    Were the printer manufacturer's drivers among those updated drivers offered in the Apple
    Support> downloads update page? If the printer disc has older drivers than those offered,
    I'm wondering if there is a problem with one or the other set of driver options for the printer.

    Have you removed the other drivers, when installing replacement drivers? There may also
    be a way to reinstall the last Combo update for the system, repair permissions before & after
    and hope this issue is resolved by a re-assertion of the earlier complete code set. Maybe.

    If only the screen were appearing reversed, such as a chalkboard, that would be an easy
    setting in Universal Access. In a printer, the chosen way could be in the printer's utility or
    a setup to print dialog window. Seems so odd the printer worked OK then it doesn't.

    What (if any) software updates were added to the system since the time this worked correctly?

    I'd bet there are a ton of CUPS and other printer logs to sort through and hope to make
    some sense of in the matter of anything printer in your OS X system logs, reports, etc!

    If you had a clone of the system from a time before any later updates, you could see if the
    previous system status reflected a stability now missing in the printer driver/printing setup
    results. Doubtful if changing user accounts, or SafeBoot + repair disk permissions simplicity
    could help resolve this. Perhaps something is either corrupted or maybe needs reinstalling.

    Good luck & happy computing!