Previous 1 21 22 23 24 25 Next 390 Replies Latest reply: Apr 16, 2014 1:23 PM by tlovecchio Go to original post
  • nzbsgfan Level 1 (0 points)

    I can confirm a few things.


    At least in my case this is not a WiFi issue.

    It isnt a DNS issue either.


    In the case of my machine the ethernet connectivity to my ADSL router is compromised.


    Renewing lease on my ethernet connection doesn't seem to make any difference, and is actually misleading - because I believe the lease isnt renewed at all - afterward I still cannot ping the router.


    Netstat, or traceroute also do not work. I get weird memory assignment messages when i try to do this.


    The fix for me is to remove the ethernet option in System Preferences>Network and immediately adding it in again.


    Everything then works fine, without touching anything else on my iMac.


    I believe this is a software issue - where the mac - upon wakeup, doesnt start up the ethernet port (and perhaps wifi) correctly.


    I'm tempted to try a wired keyboard to eliminate the possibility that my Bluetooth keyboard is the underlying cause - just to see if this issue happens less frequently.


    I'll update this thread with my findings - if anyone is interested.

  • striving to better, oft we mar what's well Level 1 (0 points)

    In my case the solution was relatively straightforward.  When, as a newbie, I set up my time capsule, I didn't appreciate that I'd need to create my own mac network and link to the time capsule through that.  Instead, I turned on my new iMac and it found my existing router and linked to the internet through that.  As a result, my backups were going through my router to my time capsule.  The Apple Fast Lane people explained to me that the size of backups is a common reason for theinternet connection to be dropped.  Once I created my mac network and pointed my iMac at that instead of the router everything worked smoothly and its been running like that now for 6 months.


    Apologies - disregard this post which is on the wrong thread.


    Message was edited by: striving to better, oft we mar what\'s well

  • g8k3pr Level 1 (5 points)

    Same here.  Time machine is turned off and I am still experiencing the issue. 

  • RatLab Level 1 (0 points)

    I just put my computer to sleep for 10 seconds and when I woke it up I didn't have an internet connection. So, I looked at the bar at the top og my screen and the little wirless symbol was searching for a connection. so I clicked the drop down box for QWEST.  And it found its self.

      Possibly the APPLE software weenies are not validating there software fully; (which I understand, it's a big job. No excuses, though).  I'm going to test it again after I send this reply.


    Well, after a brief sleep... I can say RATS!  That didnt work  -- I had to jump through the same hoops.  Click the WI-FI symbol again and click my internet provider (QWEST).


    Message was edited by: RatLab

  • Michael Streubert Level 1 (5 points)

    Probably the same issue, although not guaranteed to happen everytime my hard disk goes to sleep. I wake my iMac up (3.4ghz, i7 running Mountain Lion), no connection. Router lights are all normal. Switch over to Airport and internet works fine. Switch back, no connection.

  • Oliver Hood Level 1 (0 points)

    Having a very similar issue (same iMac spec). A restart cures it, but that's not a fix. Quite inconvenient.

  • nzbsgfan Level 1 (0 points)

    If you remove the Ethernet connection under "networking" in "system information" then add it again your connection to the network will be restored without a restart. Note - renew lease doesnt fix this. You have to remove then add the Ethernet. I believe that turning off the "wake on LAN" option will stop this issue from occurring as often. As I've mentioned previously I believe this is a startup glitch in software when the Mac wakes from a sleep session. Fortunately it doesn't happen all the time . Cheers Mark.

  • Michael Streubert Level 1 (5 points)

    I've removed the ethernet from my "Network" panel from my system preferences and then readded. I saw that recommended earlier in the thread a few weeks back, but it didn't seem to have a lasting effect (this previous week my computer was plagued with the glitch).


    I'm not sure that's exactly what you're recommending, I'm worthless when it comes to networking, and can only follow the kinds of instructions you'd give to your grandmother. I don't know where the "wake on LAN" option is.


    Thanks for your help, if you have time I'd be curious to know if I've understood your direction at all.

  • nzbsgfan Level 1 (0 points)

    No worries - ill post a better instruction for you later today :)

  • craigfromwinter springs Level 1 (0 points)

    I held some hope there for a while but the problem is back worse than ever.  I had a couple of months where the problem was only occasional and the internet connection would resume quickly.  Now after sleep the connection is lost and I can only get it back with a restart.

  • nzbsgfan Level 1 (0 points)

    If you are running Mountain Lion


    Click on the System Preferences Icon on your Dock (the icon that looks like a gear wheel)

    Under the "Hardware" heading click on the Lightbulb icon designated "Energy Saver"

    Make sure that the "Wake for Network Access" box is unticked


    There is a similar option in Lion and Snow Leopard - although it may be something like Wake on LAN...


    That improved things for me.





  • craigfromwinter springs Level 1 (0 points)

    Mark, My system is/was configured as you suggested and I had/have the problem anyway.  Craig

  • nzbsgfan Level 1 (0 points)

    Open up system preferences and go to network. Make a note of your settings as you may have to rebuild them.


    Click on finder


    On the top meny bar select Go and under that option "Go to Folder"


    put the following in .... /Library/Preferences/SystemConfiguration/


    Rename the preferences.plist file that you see in the window, to preferences.plist.old


    Reboot your mac - a new preferences.plist file will be generated. This step is important


    Check your network settings and make them the same as before if required.


    That should help.


    By the way - all this information was supplied by a user called James_N from this link...




    I've just made it simplier to follow

  • docrobc Level 1 (0 points)

    I finally figured out what my problem was and now everything works!!! I had tried several different ethernet cables I had lying around but continued to have the same problem with every one. I changed out the swtich that my home network was all going through and rewired the RJ45 plug at that end and it still wouldn't hold the connection after sleeping. Finally I pulled the wall cover off the wall in my office, replaced the RJ45 plug and connected the cable in the wall to the new plug, put everything back together, plugged in my ethernet cable from my computer and now everything works as it's supposed to. And no troubles now for several months. It must have had a bad connection, but not bad enough to just not work at all. Also my tester was reading good even before changing it out, otherwise I would have done it a long time ago.

  • nzbsgfan Level 1 (0 points)

    That's great - I'm glad you found your issue.

    Unfortunately in my case I proved it out of the physical cables.


    In the end the preferences.plist file sorted the issue for me. Now the problem only happens once in a blue moon.


    I wish apple would sort this issue - its been about since Snow Leopard :)

Previous 1 21 22 23 24 25 Next