Previous 1 23 24 25 26 27 Next 390 Replies Latest reply: Apr 16, 2014 1:23 PM by tlovecchio Go to original post
  • Nick Rooney Level 1 Level 1 (30 points)

    - choose Apple menu > System Preferences

    - select Network preferences

    - select your ethernet connection on the left ("Ethernet")

    - now use the small gear-wheel at the bottom of the panel to deactivate this service

    - click the Apply-Button on the right

    - now use the gear-wheel again to activate this service

    - click Apply once more

    BINGO!!!!

  • freshy Level 1 Level 1 (0 points)

    Deleting the Network in System preferences>Network>Advanced + clicking Apply + adding the network again and clicking Apply is what has worked for me... twice.

  • absv Level 1 Level 1 (0 points)

    sorry wrong thread

  • Peabarter Level 1 Level 1 (0 points)

    The below has solved my Safari hanging when loading web pages and eliminated my finding the wifi on boot up.  It has been a month now and waiting a minute always works for connecting to my airport extreme on boot.  I was cleaning behind my desk and realized that the ethernet cable was still attached to the back of the iMac even though I had moved the airport upstairs.  I disconnected it.  I also opened network preferences.  The wifi was moved a long time ago to the top for priority, but the inactive ethernet and firewire were still listed.  I removed both the ethernet and firewire so the only connection listed is wifi.  My computer has now reliabily found the internet for the last 3 weeks without waiting.  It appears that having the other two options disrupts the connection process on boot.  It also must cause the computer to continue trying to use the connection when using Safari.

  • fairira Level 1 Level 1 (0 points)

    Nic 91's 11/25/12 "fix" has worked very well for me since it's quicker and maybe easier on my iMac than repeated Restarts which  always worked.

     

    Also, without my having to use Nic 91's fix anywhere as often, in the past 2 weeks since I lsimply left my Network display on my desktop, Ethernet shows as  "connected" almost all the time after waking the iMac though I sometimes have to wait for up to 30 seconds.

     

    My setup is a mid-2011 iMac 21.5" desktop computer (MS812LL/A) with 2.7 GHz Intel Core i5, connected by cable to Ethernet, Mtn. Lion updated to v. 10.8.5, Apple wired keryboard.

  • Reforger Level 1 Level 1 (0 points)

    OK I think I have this fixed - been stable so far on my Mac Pro wired connection and comes back fine after a sleep/wake every time now

     

    Problem seems to lie in the automatic location setting in the network settings, so here's what I did...

     

    1. Network settings - Location - Edit Locations

    2. Add a new location .. "Home" for example

    3. With home selected, click the cogwheel below the network services and choose "Set Service Order"

    4. Reorder the services so your preferred connection type is at the top

    5. After that, select each service in turn (assuming you have a few - like Bluetooth PAN etc)

    6. Make the services you are not using inactive

    7. Apply

     

    Please post if this works for you - it's been dragging on far too long and needs sorting out by Apple but if this is a good workaround for people then it will do for now.

  • Peabarter Level 1 Level 1 (0 points)

    I agree with prioritizing the order, but find it works best to delete any connection that you are not using.

  • Ric91 Level 1 Level 1 (0 points)

    I didn't want to disappoint you but this is not a real fix. The problem is in fact a hardware problem at the assembled chipset.

    All the solutions do a rearrangement on your network settings only which causes a initialization of your network card, say it "restarts".

    It will happen again after a time that your card will not wake up from sleep (if you do not had another problem at your network settings).

    Apple changed a few logic boards on several iMacs showing this problem. All these iMacs run without network problems since.

    So it makes no difference how you change your network settings as long as it causes a restart of the network chip. But it is always a matter of time until the problem comes back.

  • Reforger Level 1 Level 1 (0 points)

    Hi Ric,

    Thanks but in my particular case I'm not sure you're explanation applies as:

    1. I have a Mac Pro not an iMac
    2. I've had the machine for a year and this problem has only appeared since Mavericks

     

    In my opinion this problem probably has several causes with the same symptom so one solution is never going to work for all cases. As you quite rightly say, there have been logic board issues with iMacs in the past - I had one (though it had different problems) but no such problems with the Pro until the new OS.

  • Ric91 Level 1 Level 1 (0 points)

    Hi Reforger, I'm sorry for not seeing this. The original thread opener mentioned an iMac and most of the posters here have seen this problem on their iMacs too.

     

    So if your problem is related to Mac Pro and Mavericks I would suggest to open an new thread. This can help others to identify the problem. Otherwise if the problem is related to Mavericks it would be confusing because this thread starts with Snow Leopard 4 years ago.

     

    But anyway thanks for your answer and good luck finding the problem.

  • Reforger Level 1 Level 1 (0 points)

    Good idea - I'll do that.

     

     

  • MHTSOSMAN Level 1 Level 1 (0 points)

    Reforger plz send me the new thread because i am facing exactly the same problem. I have a mac pro early 2008 recently upgraded to Mavericks. I have the issue of self assigned ip every time it goes to sleep.

    I changes the cable , the router, the preferences. Nothing. I go to the energy preferences and set to never the sleep computer. I think i fix it but this is not a solution. Now i am doing a time machine backup and test it. Yesterday while the time machine back up it felt to sleep and lost the IP.

  • Donald Morgan Level 6 Level 6 (12,645 points)

    When you installed Mavericks you shouldn't have lost any of your previous settings. Did you make sure there were NO other Computer Updates.

  • MHTSOSMAN Level 1 Level 1 (0 points)

    I did a clean install of Mavericks. The update from moyntain lion didn't work . I had boot problems with the macintosh hd. But i realise that i lose the IP when i start time machine on an ethernet hard drive. I check on this right now. I don't perform a backup to see if i lose the IP anyway. Until now it is ok but when i start TM after half or one hour i have a self assigned ip. I thought it is the sleep computer but it is not

  • Reforger Level 1 Level 1 (0 points)

    Link as requested - finally got round to starting a new thread

     

    https://discussions.apple.com/thread/5537854