Previous 1 2 3 Next 30 Replies Latest reply: Sep 5, 2012 6:43 PM by paulandico
Saba2010 Level 1 Level 1 (0 points)

I have just purchased an Epson PX710W and it works fine with the cable attached. I also followed the setup to run the printer wireless but that seems to be a problem.
I setup the printer on an alternative laptop that runs Windows Vista and the wireless process works fine which is odd as I followed the exact same procedure.
When I try and print a document say from MS Word on my MacBook Pro, I get the message ' Printer is currently off line' yet the same document when printed from the Windows laptop prints out just fine.
Can anyone help?

Mac Book Pro, Mac OS X (10.5.8)
  • Jonnaf Level 1 Level 1 (0 points)
    I am getting a similar problem. I have contacted Epson and gone through 3 different support tickets - nothing has soved this. I am using two macs - a powerbook G4 running 10.5.8 and a G5 tower running 10.5.8 The tower says a similar message - printer is offline (although I can print from a Windows Vista machine) the powerbook is saying Printing forbidden! Although I can print a nozzle test page. I have tried installing and reinstalling the software and a number of configurations on the printer and even reset the printing system and added the printing system. Epson have abandoned me now on this and suggest I talk to apple about the print spooling system on my mac but as both macs are not working I am feeling increasingly frustrated about not being able to use this printer with either of my macs.
  • sitcomme Level 1 Level 1 (0 points)
    I bought the same printer recently and had exactly the same problem. The install of the software went well but when trying to print over wifi the printer status was "offline!".

    After some exploration this seems to be a conflict between Apple's "Bonjour" and "EpsonNet" both trying to take control of wireless printing. Although I could ping the printer I couldn't print. However I found a simple solution and here it is:

    1) Having done the install correctly and checked your network settings go to SYSTEM PREF and select PRINTER and FAX.

    2) You should now be able to see your printer in the left side of the panel(mine appeared as EPSONF79F07).

    3) Right click the printer and select "Reset printing system". The printer will be deleted from the list.

    4) At the bottom of the same panel click the + button to add a new printer.

    5) You should now see the original printer in a drop down list but also a duplicate - mine was named EPSONF79F07(IP)- select the one with the IP suffix.

    6) Close the window and print!

    Hopefully this solution will work for you to. I'm running 10.6.2 but I don't think this makes any difference.

    Good luck!
  • Rmeale Level 1 Level 1 (0 points)
    Thank you, thank you, thank you!!

    Been trying to resolve this same issue 'Printer is offline' for hours. Read your solution and was up and running in a couple of minutes.
  • xmingax Level 1 Level 1 (0 points)
    Thank you so much!

    This offline problem was making me crazy but now (because of your advice) everything works fine!

  • el aeroplano Level 1 Level 1 (0 points)
    Many thanks sitcomme. I just got this printer today and was starting to despair until I found this solution. Interestingly, this also solved a problem I was having when printing from Adobe Photoshop Elements 8. Before the fix I was being offered really weird Print Sizes (KG anyone??) but since using your fix I get recognisable print sizes such as 6 x 4 etc

    Thanks again
  • eagresti Level 1 Level 1 (0 points)
    GREAT!!!!!!!!!!!!! it runs!!!!! Thank you so much!!!!!
  • pd49 Level 1 Level 1 (0 points)
    Works a treat.

    Great stuff
  • stevephoto Level 1 Level 1 (0 points)
    Had the same problem with the printer as stated, works fine with the USB and tried the fix as stated. Went to add the printer but there is nothing there and appears not to recognise that there is a wireless printer around. I am using an IMac but surely the same fix should help all?

    Any help would be appreciated
  • denvergrip Level 1 Level 1 (0 points)
    I have same problem with the Epson Workforce 500 printer. It printed fine with 10.4.11 via wireless. After installing 10.5 it stopped printing wireless. Works fine with USB direct. I followed your the steps but only the bonjour printer appears in the add box. How can I manually input the IP address?
  • in4time Level 1 Level 1 (0 points)
    As a a general note I've found this printer to be infernally unfriendly to set up. Despite having Admin' status as required I was unable to load the CD software in one go; I had to load each item separately.
    Whilst I have managed to get it to print, both via USB and WiFi I've yet to get it to connect wirelessly to my MBP; eg for scanning and transferring a file to my MBP. It seems like a 'one way connection' is all I have. Perhaps someone has had a eureka moment in this regard that they'd be willing to share.

    I cannot fault the print quality in fairness its just the set-up that is so counter-intuitive and distinctly un-macintosh.
  • jdayglo Level 1 Level 1 (0 points)
    This fix worked with an Epson SX425W too. Great tip.


  • qtiner Level 1 Level 1 (0 points)
    Wasted a whole day trying to set up a new Epson SX515W to work wirelessly - following Epson instructions to the letter half a dozen times and trying all sorts of tips from forums - this one worked. Thank you!
  • heathheath999 Level 1 Level 1 (0 points)
    Thanks so much for that. I am new to Mac and without your help I fear this would never have happened. Cheers ears!! Much love. XX
  • xtcnrg Level 1 Level 1 (0 points)
    Hi, just wanted to say thanks - was having same probs with my new PX820. everything installed perfect and then system said printer offline. Followed your steps and now all up and running perfectly. Cheers.
Previous 1 2 3 Next