Previous 1 3 4 5 6 7 8 Next 112 Replies Latest reply: Nov 12, 2015 8:46 AM by goingtothedesert Go to original post
  • johnmichle515 Level 1 (0 points)
    Hi !

    I agree with you that a data recovery software can easily recover your lost file or data.One i have used is Kernel for data recovery software that recover lost data due to deleted,formatted or partition.It works better for me.You can find it from for windows and for Mac

  • stilllife6189 Level 1 (0 points)
    So iLife '11 just dropped today. What do you think the chances are that this problem was fixed?
  • Bumpi Level 1 (0 points)
    I bought the new ilife 11 and i made short try and for me the problem was fixed!

    I hope for you too
  • Ryan Eaton Level 1 (0 points)
    Ive only just started experiencing this problem in iLife 11, never had a problem with the earlier versions.

    Once i save the project and reopen it, all the recordings are gone. Aif not found. Sometimes i dont even have to close it, as soon as i press "save" and try to play the track again there is no sound.

    this is stupid.
  • Bumpi Level 1 (0 points)
    Maybe you have to wait for ILife 12

    or maybe try as a different user.
  • Jerrykooyman Level 1 (0 points)

    It's ridiculous if we have to wait for iLife '12 or login as another user.
    I tried to make another user, it worked for a short while and the problem was there again.

    Only solution: Go back to Leopard 10.5 and use iLife '08 !
    I had never problems with Leopard and iLife '08.

    Since Snow Leopard released, I had only problems.
  • Bumpi Level 1 (0 points)

    I have had this Problem only with my Macbook not with my MacPro.
    They both have the same system and the same Llife.
    Normally I record with my MacPro and everything works fine.

    I think it has another reason!
  • Jerrykooyman Level 1 (0 points)

    Then I don't know the answer
    It's really strange.
  • Huggart Level 1 (0 points)
    OK .. Here is where I have go to on this issue.

    I have just installed iLife 11 and this problem has affected me for the first time, so I appreciate all the efforts on this thread.

    For everyones information, the problem is, after a successful recording session and saving the project I open the project again later and receive random eg. "no effects#01.aif" not found errors.

    Kappaclone on page 2 of this thread suggested a work around, heres what I have to add or build on their suggestion.

    There is a page on Apple Support about 'Lock Tracks" for Garageband 9.0 Garageband '11

    So I restored the missing files within the Band project package from Time Machine and copied them back to the media folder within the current project file. Voila! The project returned to glory.

    I save the file, re-open and they are lost again.

    I restore the files again and open the project. This time I lock all tracks (and make sure you play so Garageband actually locks the tracks down).

    I save the file, re-open and they are still here! Success.

    Although they have lost their wave form graphic. This approach works as long as you DONT unlock the track to edit the sound. the evidence of this is that the media files *.aif have been removed, but the locked tracks have been saved in a different folder (and name). I would continue to use the Kappaclone approach if you need to edit on each track.

    This is not a perfect solution, but I hope it sheds light until Apple fix this problem.
  • Aria-o-matic Level 1 (0 points)
    Thanks, Huggart, this kind of works, although the track is still marked as "file not found".

    Embarrasing for apple that this problem still is unsolved after a year of this thread!
  • Frank Russell Level 1 (0 points)
    So, I have just experienced this problem tonight for the first time. With all the reports over the course of a year, is it safe to say it's time to move on and purchase Logic?
  • hazmat1999 Level 1 (0 points)
    I just upgraded to Garage band '11 from (I think) '08, and all of a sudden all my projects are randomly missing files, especially if I do something to them and then save them. My work around is whenever it happens, I pull them up from archived copies, view the contents of the projects, and pull out the "missing" files, i.e. "Arena Rock#3.aif" - and manually copy them to the newer file. Never had a problem like this with garage band before, but this is enough to make me stop using it until they fix this. I just can't have stuff randomly disappear, it really makes this great program unusable.
  • David Connell Level 1 (10 points)
    This lost clip problem only happened to me after upgrading to iLife 11. The first time I opened a file after upgrading it happened, but I was able to recover a backed up file. It didn't happen again until today, when I searched online and learned it is a widespread problem. The loss today was not recoverable, which is a serious problem.

    This is only a hunch, based on these clues: over the last few days I had noticed that my trash contained some aif files that were obviously from GarageBand. As I had deleted some tracks I didn't think much of it. Last night I emptied the trash for the first time in a couple of weeks, and today I got the missing file alert. The file was fine yesterday. Going through my Time Machine backups of the damaged song, week-old+ files that definitely were ok at the time of backup, when restored they are also missing the same clip.

    Perhaps the 'missing' clip was incorrectly moved to the trash by GB, and perhaps GB was still able to find it there and read it, so never mentioned a problem. When I emptied the trash, that could have been what broke the link, causing GB to lose the file.

    So, looking forward: Time Machine does not back up the Trash, therefore I have no way of easily finding out what was in the Trash before emptying it. In the future, I will occasionally have a look at the trash and see if any aif files are in there. If there are, I will remove them to the desktop, do a backup so I have a copy 'just in case', then re-Trash the files and empty. If the error occurs, then it's a lead. If it doesn't, keep trying.

    Aside from emptying the trash, last night I also ran a general maintenance routine, repairing disk permissions, cleaning out caches, etc. This routine was done prior to and after upgrading iLife, which was the first time I encountered the problem. Perhaps another part of that routine contributed to the GB error message, but the Trash seems to be the first thing to try, as I run the maintenance script very regularly.
  • Monsi.nani Level 1 (0 points)
    I'm the latest victim of this problem that you have reported and I am frustrated, but the other hand, am so glad that I am not alone. Having read the entire thread and see the different symptoms, get around solutions, here's my settings:-
    . Macbook Pro 2.4 Ghz/ 4.0GB RAM
    . Garageband 09 Version 5.1 (398)
    . Mac OSX 10.6.6
    . No recent upgrade of software that I am aware of (may have been but not direct connection)

    My problem happened today after making 2 new Vocals recordings both ending up with no AIF file when re-opening it. So far I still haven't been able to dig up the missing audio files which I am hoping are still residing somewhere in the computer, that's why I'm not going to shut down/reset my computer until I'm sure there's no other way to retrieve the lost files, or when I have retrieved them!

    I tried the different methods suggested by others on this thread, and after many tests done, I find the quickest method is to do SAVE AS when recording is done, and do not press SAVE at all - yes that will get rid of the audio file immediately even if you hadn't closed the file, hence the file can't be played.
    You can even just SAVE AS using the same file name simply by selecting REPLACE. You don't even need to choose the ARCHIVE option as someone suggested earlier.

    So, with this problem lurking, this is indeed a pain and also risky because if you forget or just not clearheaded enough, one quick clip on SAVE will steal your audio file away. In which case, taking the suggesting of moving the xxxxxxxx#02.aif file into the root folder of the project is a safer measure.

    What triggered the bug is still a mystery to me?
    Will try to post this to the APPLE FEEDBACK forum as well.
Previous 1 3 4 5 6 7 8 Next