Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Magic Mouse - Disable horizontal scrolling ?

like the Magic Mouse a lot, just horizontal scrolling drives me nuts with some apps.

Could you disable horizontal scrolling and keep vertical scrolling activated ?

tx, W

dual 2 ghz PPC G5, Mac OS X (10.5.8)

Posted on

Reply
Question marked as Solved
Answer:
Answer:
Open a command line window using the Terminal app (in your Applications/Utilities folder):

Paste the following command, and hit Return:

defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseHorizontalScroll -bool NO

Go to the Bluetooth Preferences panel in System Preferences, turn off your mouse with its power switch (watch in the pref panel that it has disconnected), and then re-power it, and your mouse should reconnect.

Posted on

Page content loaded

Jan 10, 2010 2:37 PM in response to walter maldeghem In response to walter maldeghem

i'm with you walter. i've got long scrolling vertical scrolling to do while i'm writing code and can't stand when the mouse slides the text horizontally.

it'd be great if Apple was working to fix this ... a missing functionality preference. that system preference pane with the little video or whatever is overkill IMO... how about a couple options for scrolling... thanks Apple!

Jan 10, 2010 2:37 PM

Reply Helpful (3)

Jan 29, 2010 6:34 AM in response to Kaplan In response to Kaplan

I think holding the mouse with 2 fingers on top of the mouse is the trick for avoiding inadvertent scrolling, especially horizontal. Having a single finger touching is definitely going to cause a scroll.

It seems like trying not to touch the top, where I'd scroll was causing more accidental scrolling. Think less delicate, more ham-finger.

Jan 29, 2010 6:34 AM

Reply Helpful

Jan 29, 2010 9:38 AM in response to walter maldeghem In response to walter maldeghem

It would be helpful to somehow control the sensitivity. It is always scrolling laterally right when I don't intend that especially in Eudora and Word and Word seems a bit worse. If I make sure to drag my fingertip exactly vertical up or down, there is no lateral scrolling, but if it is slightly diagonal (which it almost always is from years of habit) it will laterally scroll. I'm at times tempted to return to my Mighty Mouse, but I like the Magic Mouse too much to return and will instead try to retrain my fingers until an update adds more control.

Jan 29, 2010 9:38 AM

Reply Helpful

Jan 29, 2010 2:29 PM in response to walter maldeghem In response to walter maldeghem

You might try looking into an additional app like MagicPrefs, or BTT. I believe both of those will allow you to re-assign those gestures to anything you like. If so, you could just assign them to "do nothing" which should disable the scrolling for you.

Jan 29, 2010 2:29 PM

Reply Helpful (3)

Feb 4, 2010 10:40 AM in response to walter maldeghem In response to walter maldeghem

I chime in on this too - When I use InDesign it especially is annoying, as my whole view mysteriously scrolls left and right as I'm working. While I'm sure it must ba a habitual movement I make that causes this, I really don't want to have to "learn" how to use a mouse again, and think if there was a good reason to turn off horizontal scrolling on the mighty mouse, there's equal reason to do it here.

And btw, when I do want horizontal scrolling (which is close to never), i t i s r e a l l y s l o w

Feb 4, 2010 10:40 AM

Reply Helpful
Question marked as Solved

Feb 9, 2010 11:54 AM in response to ideawire In response to ideawire

Open a command line window using the Terminal app (in your Applications/Utilities folder):

Paste the following command, and hit Return:

defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseHorizontalScroll -bool NO

Go to the Bluetooth Preferences panel in System Preferences, turn off your mouse with its power switch (watch in the pref panel that it has disconnected), and then re-power it, and your mouse should reconnect.

Feb 9, 2010 11:54 AM

Reply Helpful (4)

Feb 9, 2010 12:06 PM in response to walter maldeghem In response to walter maldeghem

Yes MagicPrefs is excellent. I was playing Bioshock and I found the magic Mouse really made the game difficult because the weapons kept on switching at the slightest touch.

In Magic Prefs there is a saved preferences set called Gaming, which might do the trick (i.e a desensitised preference set). I was about to test this out but my Magic Mouse died on me.

If anyone downloads MagPrefs before the end of this week and you have Bioshock installed (or any shooter game for that matter), would you mind posting back to let me know how it works out please?

Feb 9, 2010 12:06 PM

Reply Helpful

Feb 17, 2010 6:28 AM in response to LEK2 In response to LEK2

typing in this in the command promt worked!!!!!!

defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseHorizontalScroll -bool NO


Disable Horizintal Scrooling Mac OS X Magic Mouse.

I've been going crazy in inDesign with the stupid screen scrolling sideways constantly.

Thanks

Message was edited by: Paulman!

Feb 17, 2010 6:28 AM

Reply Helpful

Feb 19, 2010 12:30 AM in response to Paulman! In response to Paulman!

This worked for me. It's a relief to disable horizontal scrolling. Just to clarify the previous post:

To turn horizontal scrolling off:
defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseHorizontalScroll -bool NO

To turn horizontal scrolling on:
defaults write com.apple.driver.AppleBluetoothMultitouch.mouse MouseHorizontalScroll -bool YES

These commands are entered on the command line of the Terminal utility application.

NOTE: You'll have to restart your computer before the changes take effect.

Feb 19, 2010 12:30 AM

Reply Helpful

Feb 19, 2010 3:20 AM in response to Robert Gallup In response to Robert Gallup

BTW, I noticed the LEK2 was pretty clear about this too, and pointed out you don't need to restart your machine (though, that works), you just need to disconnect and reconnect your mouse.

Also, if you don't like using the command line, I just uploaded an Applescript application to atomicsalad.com, that allows you to toggle these settings back and forth.

Feb 19, 2010 3:20 AM

Reply Helpful

Feb 19, 2010 11:15 AM in response to walter maldeghem In response to walter maldeghem

I was using MagicPrefs last night trying to see if I could fix some other problem. I recall coming across an option to enable/disable horizontal scrolling or something very like it included in that software.

I wonder if this is what you seek, especially as it is a free app?

Feb 19, 2010 11:15 AM

Reply Helpful

Mar 25, 2010 10:15 AM in response to El Deanio In response to El Deanio

I use MagicDriver beta version which allows you to disable horizontal scrolling but can be temporarily activated by pressing the shift key as you scroll.I don't know whether the shift key command is a system one or built into the MagicDriver or Smart Scroll which I also use,however it does mean you loose diagonal scrolling.

Mar 25, 2010 10:15 AM

Reply Helpful

Apr 6, 2010 12:52 PM in response to El Deanio In response to El Deanio

Yup, this is correct. With MagicPrefs go to:

preferences>configure scrolling (bottom left)


here you can disable one finger scrolling (you can maintain this by allowing two finger scrolling if desired

working in indesign and illustrator just got a LOT less frustrating!!!

🙂

Apr 6, 2010 12:52 PM

Reply Helpful
User profile for user: walter maldeghem

Question: Magic Mouse - Disable horizontal scrolling ?