Skip navigation
This discussion is archived

Wi-fi issues with new 3.1.3 update

47488 Views 95 Replies Latest reply: Jul 17, 2010 9:20 PM by Anson Huuuuu RSS
1 2 3 ... 7 Previous Next
Goaliegeek Calculating status...
Currently Being Moderated
Feb 2, 2010 6:35 PM
Just updated to the new FW 3.1.3 and now my iPhone 3G wont connect to my wi-fi. It see's it but when I select it, after a few seconds I get a error: "Unable to join the network."
I reset my router and still nothing. MBP and PS3 can get on just fine.
Anybody else having issues?
MacBook Pro ~ Oct 14, 2008~, Mac OS X (10.6.2), 2.53GHz, 4GB RAM, nVidia 9400m & 9600mGT 512mb, 320GB hdd
  • Allan Sampson Level 10 Level 10 (122,145 points)
    Currently Being Moderated
    Feb 2, 2010 6:56 PM (in response to Goaliegeek)
    No such problem here.

    Try selecting the network to view the network settings and then select Forget Network to remove the network and network settings from your iPhone. Follow this by re-joining the network.

    If no change, go to Settings > General > Reset and select Reset Network Settings. This will delete all wi-fi network settings from your iPhone. Try re-joining your wireless network.
     MacBook Pro 15" Intel Core 2 Duo/2.53GHz/4GB RAM/500GB HD, Mac OS X (10.6.2),  iPod w/Video 30GB,  iPhone 3G 16GB
  • Allan Sampson Level 10 Level 10 (122,145 points)
    Currently Being Moderated
    Feb 2, 2010 7:10 PM (in response to Goaliegeek)
    You're welcome.

    If you did all that before posting here, you should have included all that with your post so I didn't waste my time as well as yours providing steps you have already tried.

    Have you tried anything else? If so, what?
     MacBook Pro 15" Intel Core 2 Duo/2.53GHz/4GB RAM/500GB HD, Mac OS X (10.6.2),  iPod w/Video 30GB,  iPhone 3G 16GB
  • Ziatron Level 4 Level 4 (3,255 points)
    Currently Being Moderated
    Feb 2, 2010 8:27 PM (in response to Goaliegeek)
    Try going back to 3.1.2
  • tomagion Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2010 12:06 AM (in response to Goaliegeek)
    Reading this and the other posts on Wifi problems is disturbing. My iPhone 3G is on firmware 3.1.2 so not sure that reverting back to 3.1.2 will help as I have the same problems. It also appears that 3.1.3. will exacerbate the problem. Sounds like its time to harass Apples Support staff and developers to get a proper resolution to this issue as this problem is starting to really irritate.

    I use a Netgear WNDR3700 wifi router at home. It has support for all bands. At work I use a Belkin router (exact model not remembered) I see the same problems. At my mates house with another Netgear router (DG834G) I see the same problem.

    Until the last few weeks I can't say I've had any problems with WiFi on my 12 month old iPhone 3G (firmware 3.1.2 (7D11). However, these last few weeks this phone just can't stay connected to WiFi networks for any great period of time; sometimes minutes, sometimes seconds.

    I've tried manually adding wifi networks following hints from other users on the forums, but this doesn't work reliably.

    I've now done a full reset of the network element based on advice in Apple's own iPhone WiFi troubleshooter. I'll see how that goes. http://www.apple.com/support/iphone/assistant/wifi/#section_5

    I don't believe this issue will be resolved without Apple's action, so come on Apple please help us. We love our iPhones, just don't like to see issues with them!
    handcrafted+dell, iPhone OS 3.1.2, w7+vista+2008+Ubuntu+Appletv+ps3+wii
  • koldsgaard Calculating status...
    Currently Being Moderated
    Feb 3, 2010 5:53 AM (in response to Goaliegeek)
    Hi

    I have the same problem. My iPod Touch connects to the WiFi-network but the connection is unstable and slow. My MacBook Pro runs on the same network and has no problems. This problem have been around since iPhone OS 3.x. Apparently it has something to do with the WiFi-router since it is not a problem on all WiFi-networks. The problem is just that most WiFi-routers doesn't allow much configuration of the WiFi-signal.

    I hoped that Apple had fixed this problem in the 3.1.3 version. But they didn't. And it shouldn't even be hard since the WiFi-part of the 2.x version worked.
  • louster Calculating status...
    Currently Being Moderated
    Feb 3, 2010 6:15 AM (in response to koldsgaard)
    I've had no problem with my iPhone 3G for last year and a half, until "upgrading" to 3.1.3 yesterday. Now no wifi and the battery is going down at a faster rate. I don't even have the option to turn wifi off or on, it is all grayed out and unresponsive.
    Is a restore the only way to go back to 3.1.2?
    Thanks,
    L
    iMac, Mac OS X (10.5.8)
  • paulcb Level 6 Level 6 (18,635 points)
    Currently Being Moderated
    Feb 3, 2010 6:20 AM (in response to louster)
    I suggest restoring from your backup. If that doesn't work, restore as a new phone and reset everything back up. I did this (restore as new) with the 3.0 update and it only took just over an hour. Phone ran perfectly after that.
    HP DV7 Laptop (nice but don't like Vista), Windows Vista, iPhone 3G 8GB with 3.12
  • Howie1947 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 3, 2010 7:23 AM (in response to paulcb)
    Does anyone know when the 3.1.4 update will be out to fix the 3.1.3?? My phone has been "hosed"...........very unhappy.........
    Fujitsu, Windows XP
  • CasperNZ Calculating status...
    Currently Being Moderated
    Feb 3, 2010 4:46 PM (in response to Goaliegeek)
    I was having the same issue, my router was visible in the list and looked like it was connected, but 3G was still showing on the home screen. Changed from DHCP to Static and set my IP manually and it worked. And has been connected for the last hour with no drop outs. No idea why that's any different but if it helps someone then great
    iPhone, iPhone OS 3.1.3
  • Yaxide Calculating status...
    Currently Being Moderated
    Feb 4, 2010 3:45 AM (in response to Goaliegeek)
    Since I have upgraded my 3G 8GB iphone, it is not able to find any wifi network and the thinking circle doesn't disappear.

    Any help to go back to 3.1.2?

    Thanks.
    Iphone 3G, iPhone OS 3.1.3
  • paulcb Level 6 Level 6 (18,635 points)
    Currently Being Moderated
    Feb 4, 2010 6:57 AM (in response to Howie1947)
    Nobody knew about 3.1.3 until it was out. It will likely be the same with the next update.
    HP DV7 Laptop (nice but don't like Vista), Windows Vista, iPhone 3G 8GB with 3.12
1 2 3 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.