Previous 1 26 27 28 29 30 Next 441 Replies Latest reply: Mar 10, 2010 6:38 PM by Shell Otto Go to original post
  • Shell Otto Level 1 Level 1 (0 points)
    Bought A3 installed. No problems what so ever. Been using all features including the Faces.
  • wil102 Level 1 Level 1 (0 points)
    Not sure what gives you that idea robogobo. My spinning beach ball of death a[[ears within seconds if A3 is not started with the shift key pressed. I think this thread will run for a while thanks.
  • e2photo Level 2 Level 2 (165 points)
    I did a very simple experiment which removes issues of old databases.

    1. Virgin mac, no previous exposure to Aperture.
    2. C2D with 2 GB RAM with minimal third party programs
    3. Install A3
    4. Lots of crashes from an imported library
    5. Upgrade A3.0.1
    6. Create a new Library on internal drive
    7. Import 418 D700 NEF files into this virgin library (NO A2 library exposure), all referenced on external drive
    8. Did a global change on all the pictures by
    a. Correcting white balance from grey card image
    b. Adjust contrast to 0.15
    c. Adjust vibrancy to 0.1
    d. Copy settings and stamp to about 1/2 the library
    e. Repeated steps a-d on the second half of the library
    9. Zoom to 100% to begin editing and waited 134 seconds for the spinning beach ball to go away
    10. Open retouch tool and waited 8 minutes for the spinning beach ball to go away... finally did a forced quit
    11. Report sent to Apple
    12. Reopen A3, return to same picture and do 100% zoom
    13. 3-4 retouches and A3 crashes
    14. Report sent to Apple
    15.Reopen A3 and return to same picture
    16. Did some retouching, dodging, and retouch and crash.
    17. Report sent to Apple.

    The library was built entirely off of original RAW camera files

    So I purchased a complete copy for my test machine and an upgrade copy for my two working machines. I installed the full copy on a clean machine to make sure it was ok and I understood it before I installed in on my working machines. My simple experience is described above.

    BOTTOM LINE: A3 exhibited multiply crashes and hangs way beyond expectations. Even on the very simple test described above, it seriously failed. I as much as I want to start using it to process my professional work (35-40000 images a year), it really is not ready for prime time. Something is seriously wrong with it. I returned my unopened upgrade package to the store and got a refund. The Apple person said something interesting to me. Well no one else has returned it, but have you ever tried to return opened software. No way. The only way I was able to return the upgrades was I purchased a full version and decide its performance was subpar and then I returned the UNOPENED upgrades.

    There are also those who say the problem is related to the database structure or fragmentation. If after a simple import of 418 RAW images, fragmentation or database structure is a problem causing crashes, then A3 is not ready for prime time. I have also rebuilt the database and repaired it (this very simple referenced database of 418 RAW images) without success.

    CONCLUSION: I will continue to test A3 as new upgrade become available on my full version but since it only takes me 30 minutes to cause multiple failures, this is not a huge investment in my time. When A3 becomes stable on my test bed, with enormous care and caution I will upgrade one of my working machines and make sure it is as stable as A2.1.4

    As I have said before, if I need the top end of a machine (Quad with tons of memory) for A3 to work, a much more economical solution will be to switch to LR. This is a pretty important decision for me since I have more than 100,000 images in Aperture structures and would rather not switch, but the current A3 does not achieve acceptable performance. The concepts and features are absolutely wonderful. The implementation is perhaps the worse I have ever seen. I will optimistically wait for A3.0.2.
  • Grant Symon Level 2 Level 2 (240 points)
    Wil202

    FWIW, I had an upgraded library which appeared to be working quite well. However, I at some stage did something, not sure what exactly. After this, Aperture3 would start processing almost immediately at startup. It would process around 300 files. It would finish. And then when Aperture3 was relaunched, it would start again.

    Starting with the shift key solved the problem, which meant that the processing was building thumbnails.

    I finally understood what was happening. There were some offline images, which had been accessed across a network and for which Aperture3 was constantly trying to build the thumbnails. Because Aperture3 gives very limited useful feedback in the Activity Window it was impossible to understand, that *+it wasn't being successful+*. It was failing with each image, then moving to the next, failing, moving to the next, etc. etc. *Since there are no error messages provided by Aperture3, it is impossible to know that there have been any errors.*

    I tried rebuilding and repairing the library. I forced the thumbnails to be rebuilt with the 'option' key etc., but every time I relaunched Aperture3, it started to 'Process' these 300ish images.

    The last step of my vain attempt to get my upgrade working properly (3 weeks and counting Apple) was this :

    I selected ALL of my Projects and Exported them. Aperture3 does a neat thing. It makes a new library when you do this.

    I opened this library and sure enough, it started 'Processing' these thumbnails again. I let it run. Then I made sure that all of the images were 're-connected' and Online (which they weren't). Having made sure that the offline images were now online. I relaunched Aperture3 yet one more time. Sure enough it started 'Processing' again. It went through the 300ish images. I quit and relaunched again. SURPRISE! The 'Processing' did not kick in and has not done so since. Several days now.

    So what this tells me is that Aperture3 is somewhat fragile, when it comes to Offline images. I often connect to them over the network and also, the same images connected directly via FW800. I can see why this may be a difficult scenario for Aperture3 to deal with, but it is surely a frequent one.

    It also tells me that Aperture3's fragility can result in what is currently, an irreparable library. Nothing changed with my 2 libraries (the original and the 'Exported Projects'). They were essentially identical and yet nothing I did with the original, after successfully solving the problem with the Exported, was successful in getting these thumbnails built and preventing the 'Processing' kicking in at launch.

    This is not a CPU speed, RAM thing. I loaded Aperture3 onto my sons old Mac Mini 1.66ghz with 2gb RAM and although it's slow, it doesn't hit VM and it just chugs along with its processing. It is fine. It's faster than Aperture2 too.

    ________________________________

    This final piece in the puzzle, combined with my initial findings, has eventually gotten me a successful upgrade to my Aperture2 library. In case this may be of use to someone else (and you can definitely do a successful upgrade if you can eliminate the things that trip up Aperture3) here's what I did prior to fixing this last problem :

    The other part of the puzzle, was corruptions in the Aperture2 library, which had to be sorted, prior to upgrade. These involved 'phantom' or 'ghost' files and damaged files.

    The first issue was Referenced files, long since deleted from the Aperture2 library, but which appeared after a rebuild, in the library. These images had gigantic pixel proportions, were listed as 'square' and of only around 100k in size.

    Once these were deleted, I could upgrade ... but there was a another problem.

    I had 2 images which caused incessant 'Processing' or 'Processing stalls'. I eventually found these by deleting all Previews in Aperture3 and rebuilding them one Project at a time, eventually narrowing it down to just the problem images.

    *This whole issue was really hard to track down, because Activity Window does not provide error message feedback!*

    It turned out that 1 image had a corrupted preview. Nothing I could do with Aperture3 would fix it. Re-importing the image from my backup, solved the problem.

    The 2nd of the 2 problem images turned out to be impossible to upgrade. It was a pretty large tiff (88mpx) with 238 'Retouch' edits and 1 'Spot and Patch' edit. Again, nothing I could do with this image within Aperture3 could get it to build it's Thumbnail or Preview. It just whirred and whirred with 'Processing' as the only feedback.

    So, I now have a fully functioning Aperture3 library, which is fast enough and perfectly useable.

    Aperture3 continues to have bugs. I can make it crash and I'm fairly sure it can corrupt images. I'm very disappointed with Apple and this upgrade. Aperture3 itself is a fantastic upgrade. However, the quality control has been appalling. I would guess this is because of Apple's obsession with secrecy ... simply not enough beta testing, but whatever the reason, Apple have taken a *BIG HIT* on the confidence that its loyal customers have, in the quality of their software. I hope that Aperture3.1 is out soon and fixes all the remaining issues.
  • robogobo Level 2 Level 2 (290 points)
    You're misunderstanding. The thread was marked "Answered" by the author, and it's being used as a catch-all repository for too many issues. This is never a good thing on the discussion boards. It's much more useful and helpful to look for or start other threads covering more specific issues. Otherwise your post will just get lost in the sea of complaints.
  • Shell Otto Level 1 Level 1 (0 points)
    I bought the upgrade last week. Read through these posts and the installation instructions. Happy to report no problems. Converted the library. Everything runs fine. I like t.
  • Shell Otto Level 1 Level 1 (0 points)
    bought the upgrade last week. Read through these posts and the installation instructions. Happy to report no problems. Converted the library. Everything runs fine. I like it.
Previous 1 26 27 28 29 30 Next