Previous 1 2 3 Next 35 Replies Latest reply: Apr 28, 2012 7:52 AM by a Mac user
a Mac user Level 3 (715 points)
I am at college and the campus-wide wireless network is a WPA2/Enterprise network. It requires login credentials that are the same as the student logins to the school email and other things. My problem is that often times when I open my laptop and connect to this network it prompts me for a login. I have already put in the username and password and it has been stored in the WPA profile for this network. I have checked the profile and the option for always prompting for the password is not enabled. I am a bit hesitant to bring this to the school's help desk because last time i had a problem with connecting on the network they wanted me to reconfigure my whole computer. I have tried deleting the WPA profiles and making a new one and that did not seem to change anything. Is there anything I can do to make the login prompt go away and not bother me anymore?

MBP 2.53Ghz Unibody 4GB RAM, iPod Touch 16GB 1G, Mac OS X (10.6.2), Mac Developer
  • John Huculak Level 1 (25 points)
    I have the EXACT same problem. I've followed all of the directions to connect to 802.1X WPA Enterprise locked network. I had no problems under Leopard, but with Snow Leopard, I'm locked out. Has anyone found a fix yet?
  • a Mac user Level 3 (715 points)
    I am going to give this a bump because it is still happening in 10.6.3
  • spiz Level 1 (0 points)
    I'm an IT administrator for a university and have been having this problem for several weeks as well on snow leopard machines. 10.6.3 does not fix it... It's a big problem when the whole appeal of using a wpa2 network to avoid logins every time, actually breaks and leaves the user disconnected. It's just not saving their password for the network and continually reverts to automatic.
  • a Mac user Level 3 (715 points)
    something I have noticed is that the WPA2/Enterprise network at my university seems to use a certificate that is not being registered as signed by a certificate authority. I had to press "trust" on it when I originally joined the network. Something else I have noticed is that Leopard noes not seem to have this issue, nor does my iPod touch. All other students here with macbook pros from the school are running 10.5, and they have no idea what I am talking about when I say I have to put a password in to connect to the network.

    The prompt to rejoin the network happens most times when I reboot. only sometimes does it happen when I close my laptop and then open it again.
  • a Mac user Level 3 (715 points)
    Just curious, do you have VM installed or installed at one point on the computer?
  • makesh Level 1 (0 points)
    I have the same problem too. At home it connects perfectly, but at work, it keeps prompting for userid/passwd. I have tried deleting the entries from Network Preferences & Keychain. But every day I'm having to delete and recreate the entries.

    If I don't delete, then I find multiple entries of the same network under the Airport section in Network Preferences->Advanced.
  • spiz Level 1 (0 points)
    Some have vmware, some don't. Some are different generations of macbooks/macairs. It doesn't make a difference which. Our security certificate is signed as well, so I don't think that is related.

    It just seems to be a snow leopard bug...
  • davirs Level 1 (0 points)
    same problem here, WPA Enterprise issue! SL 10.6.3

    any progress so far?
  • satcomer Level 4 (1,110 points)
    Did anyone try the procedure in this blog fix?
  • a Mac user Level 3 (715 points)
    I would give it a go, but I am already home for the summer. My only concern is that the blog post is from 2006, and this only seems to be a problem in snow leopard. Previous versions of OS X don't have this same issue.
  • a Mac user Level 3 (715 points)
    Bump, anyone know is 10.6.4 fixes this?
  • rsd99 Level 1 (0 points)
    Yes, i am running 10.6.4 and it seems to fix the wpa2 enterprise issue.
  • a Mac user Level 3 (715 points)
    That is great news, can anyone else confirm this?
  • jbsnyder Level 1 (5 points)
    I still seem to be having this issue. I was about to start going through and trashing settings files to see if that helped.

    The strange thing about all of this is that it doesn't seem to store the passwords in keychain when they're entered, though if I delete that and try setting things up again in the network under the Network preference pane from scratch it doesn't make a new entry for passwords entered after that point. I feel like this might be either that the preference pane doesn't have permission to save out settings appropriately and that it's silently failing.

    This is quite irritating. So far I've mostly just ignored the issue and re-entered my password each time, but I just ran across another user complaining of the same, also, I believe, on 10.6.4.
Previous 1 2 3 Next