Previous 1 3 4 5 6 7 Next 97 Replies Latest reply: Jul 19, 2015 2:20 PM by derrickvl Go to original post
  • tony duckworth Level 1 Level 1 (0 points)

    Still having this problem of no text appearing in mail mesages.  To go over it again - I am using a MacBook Pro with Max OS X Ver 10.6.8. For mail within the company we are using Outlook

  • braintoniq Level 1 Level 1 (30 points)

    Tony, this may not help, but the issue resolved itself for me with the latest Mt. Lion update (10.8.5) that came out yesterday. It specifically fixed the bug that "caused emails to disappear in Preview view." Totally fixed it, after weeks of trying all sorts of fixes.

  • tony duckworth Level 1 Level 1 (0 points)

    Thank you for that sir!  How do I know if I am using Snow Leopard - being quite new to Apple!!  Going to the top bar on the screen - on the apple icon - and selecting 'About This Mac' it says Mac OS X 10.6.8.  Have just ran software update and there is no update to download?



  • AaronTheMan Level 1 Level 1 (0 points)

    Wow, thanks for letting us know, braintoniq. Downloading the update now and hoping it'll fix this issue...

  • WangYa Level 1 Level 1 (0 points)

    Have a look at this link and let us know if it helps:

  • tony duckworth Level 1 Level 1 (0 points)

    Am afraid that none of that helped.  Have tried to get updates for software - but if and when you try you get a response that say's no updates available - what can you do?


    This went on for about three months, tried many forums and groups, tried Apple direct with no response at all.  Tried Microsoft to see if a problem with Outlook - a good forum but no solution.  No response at all from anyone at Yahoo.


    The only thing I could do was to create a completely new profile on the Mac, recreate the mail profile in the new profile and all the mail at Yahoo came through fine.  Then had to copy across all the files etc - from the old profile to the new.  A complete bore.


    You would think that the likes of Apple and Microsoft - who must know that these 'help forums' exist - might monotor what s going on and maybe tried to fix some of these things that just happen - for no good reason.

  • perry2012 Level 1 Level 1 (0 points)

    FYI:  OS X Mavericks


    Today I encountered a problem where one of my mail subfolders (call it "MyFolder") contained a list of emails but when I opened the email it contatined no text in the email body section.


    I went to my user/Library/Mail/SubFolder1 to look for the subfolder in question ("MyFolder").  I saw 2 mailboxes MyFolder.mbox and MyFolder-2.mbox. 


    MyFolder.mbox contained only "info.plist"


    MyFolder-2.mbox contained a folder named "C30BC29C-FE03-46EA-9EAE-7FC319B05DA8" which contained a Data subfolder which contained 10 subfolders Named 0,1,2,3,4,5,6,7,8,9.


    Each of these contained numbered subfolders, which contained 2 folders named "Attachments" and "Messages"


    I moved the folder named C30BC29C-FE03-46EA-9EAE-7FC319B05DA8 from MyFolder-2.mbox to MyFolder.mbox and all messages were now visible.


    I deleted the MyFolder-2.mbox


    All appears well.

  • tony duckworth Level 1 Level 1 (0 points)

    Yes - I tried all that above - but when I looked for those folders - none were there.  Ciould not find a folder that contained any messages at all.  And still can't in the new user profile that I had to set up to clear the problem.


    What I still don't understand is how it happened in the first place.  I had been using the Mac for several months and using the mail profile set up using Outlook for Mac (2011).  Everything was fine during all that time and then one morning, came in and started up and there it was - emails coming in with no text.  No reason for it.  I then look through Apple forums and its happening all over the place - with no response or assistance from Apple or Microsoft themselves.


    Its good that there are forums out there to find solutions to problems - but shouild it just then be left to a group of very helpful individuals - when th eoriginators of the hard and software sit bacvk and do nothing!!  Rant over!!

  • Jonathan Rayson Level 1 Level 1 (15 points)

    Okay...This is going to seem completely crazy, but I discovered it quite by accident, and it solved the problem.


    Since the update to Mavericks, I, too, had saved messages in subfolders in the "On My Mac" section of the sidebar. Some of the folders had messages that were all completely blank and some of the folders were fine...I could view messages like normal. A little like perry2012 above, when I went to user/Library/Mail/V2/Mailboxes/Saved messages.mbox, I realized that the folders in which I was having problems all had "–2" following the name of the folder. For instance, if the folder was called "My Folder" in the sidebar of Mail, in the Saved messages.mbox folder, it was called "My Folder–2.mbox". However, the folders in which I could see messages had their regular names in the Saved messages.mbox folder. (I didn't have instances of double folders like perry 2012.)


    As a test, I renamed one of the problematic folders in the Mail sidebar by simply clicking once on the folder title and adding the word "test" after the original name (i.e. "My Folder test"). As soon as I scrolled in the message pane to see if anything changed, all the messages came back! I could see the preview in the message list, and when I open a message, it's no longer blank! When I change the name back to it's original name, everything remains fine. Strangely, though...on a couple of occasions, after changing the name the first time, sometimes nothing happens until I scroll in the message pane, or until I navigate to a different folder then return. (Of course, maybe if you just rename the problematic folder and then rename it back to the original, quit Mail and reopen, it would have the same effect.) But in every case, renaming the folder and then renaming it back to its original name did the trick.


    I know it's long-winded and flukey, but I have my messages back! Hope it helps you too!!

  • seitsu Level 1 Level 1 (0 points)

    @Jonathan: I have exactly the same issue. By renaming the folders to "foobar" and then back to it's old name the suffix "-2" vanished and the emails in this folder are back to normal.


    Update: Well, after renaming it back to the old name, the folders are completely lost from the file system .. I don't know what's going on.


    Update 2: Now the folders appeared on the filesystem but not within Mail. So I opened the folder at Terminal and typed in "open ." and the folder showed up in Mail again. Strange thing.

  • kOoLiNuS Level 1 Level 1 (5 points)

    I can add my chief's experience with his MBA with 10.9 and the latest build of Mail. He has witnessed an issue like the one of Tony2012 and I've been strulling all the latest 3 hours to get those email back.


    Unsuccessfully :-(


    Everything is downloaded via POP, but restoring the DIR.mbox and DIR-2.mbox over the current installation doesn't help. After some renaming and merging of the folders I've restored their hierarchies but still no email shows up.


    Seems there's an issue with the email enumeration and identification in the mbox folders like the


    MyFolder-2.mbox contained a folder named "C30BC29C-FE03-46EA-9EAE-7FC319B05DA8" which contained a Data subfolder which contained 10 subfolders Named 0,1,2,3,4,5,6,7,8,9.


    reported a couple of posts above.


    I'm trying now with the Thunderbird messages import feature (via the ImportExportTool plugin) to get those messages in a readable format and tomorrow I'll try to catch them back into Mail…


    Wish me good luck !

  • kOoLiNuS Level 1 Level 1 (5 points)

    Here's how I solved.


    Rebuilding the directories from within didn't work.

    Rebuilding the email indexes "trashing" the Envelope Index and such didn't work.

    Renaming or merging the EXAMPLEDIR.mbox and EXAMPLEDIR-2.mobx didn't work.


    So I've downloaded Mailsmith and with it I've manually imported all the "broken" .mbox directory. Finished this step I've exported the new mbox directories into a temporary folder, fired up Mail and then asked for the import one mbox directory at a time.


    It has been a long process but in this way I could at least verify the number of items imported.

  • aredorange Level 1 Level 1 (0 points)

    same questions here... Since I updated to OS X Mavericks most of my Mail app folders files are now unreadable - the files are still there but when I try to open them they are empty... the problem seems to be with the folders... for example, just received some messages today which I was able to read in my Inbox but once I moved the messages to a Mail folder, they are unreadable... i tried to rename the folder, but it does not solve it... imported the same folder from 2 days ago, also same problem... before the upgrade to Mavericks all were working fine... any clues how to solve this?

  • veganmod Level 1 Level 1 (0 points)

    I have the same problem. Updated to OS X Mavericks and now some of the emails in my Mail app folders don't have any body, just the 'subject'. In some cases I click on the emails and some of the body is viewable but certain emails in the chain aren't. In others, nothing is viewable.


    When I look in the .mbox folder of the mailboxes which have a problem, there is only a info.plist file but no data directory.


    I don't know if it's a coincidence but the folders which have the problems seem to be the ones which contain old emails...

  • Socializing Level 1 Level 1 (0 points)

    I got the problem fixed with the shamefully simple solution.


    To repair:

    1. Quit and reopen Mail

Previous 1 3 4 5 6 7 Next