Skip navigation

"The iPhone cannot be synced. The required disk cannot be found."

128996 Views 43 Replies Latest reply: Aug 11, 2013 1:33 PM by VWlover RSS
1 2 3 Previous Next
powerweb11 Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 21, 2010 5:19 PM
I have been having this problems since I got my iphone last year. Early on the phone would sync after 2-3 tries but as of the last 2-3 months I have been only able to sync it 2-3 times even after trying all the solutions presented by the troubleshooting and reading forum posts that seem to have a similar or near similar problem.

The first message I get after having the phone sync is
"The iPhone cannot be synced. The required disk cannot be found."
After itunes attempts to sync again I get a different message that says
"The iPhone cannot be synced. An error occurred while writing to the device."

Ive ran the diagnostic and this is what I got:
Microsoft Windows XP Professional Service Pack 2 (Build 2600)
EVGA__ 132-YW-E179-FTW
iTunes 9.1.0.79
QuickTime 7.6.6
FairPlay 1.7.16
Apple Application Support 1.2.1
iPod Updater Library 9.0d11
CD Driver 2.2.0.1
CD Driver DLL 2.1.1.1
Apple Mobile Device 3.0.0.102
Apple Mobile Device Driver 1.46.0.0
Bonjour 2.0.0.34 (214.3)

iTunes Serial Number 5DD5EE0A2E39800E

Current user is an administrator.
The current local date and time is 2010-04-21 16:55:29.
iTunes is not running in safe mode.

Video Display Information

NVIDIA GeForce GTX 260

** External Plug-ins Information **

No external plug-ins installed.

The drive E: Memorex 52MAX 325216AJv2 Rev RW$5 is a USB 2 device.

** Network Connectivity Tests **

Network Adapter Information

Adapter Name: {5EC41707-0E19-4943-9EBF-169BD17E249E}
Description: NVIDIA nForce Networking Controller - Packet Scheduler Miniport
IP Address: 192.168.15.4
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.15.1
DHCP Enabled: Yes
DHCP Server: 192.168.15.1
Lease Obtained: Wed Apr 21 16:35:40 2010

Lease Expires: Wed Apr 21 17:35:40 2010

DNS Servers: 192.168.15.1
192.168.15.1

Active Connection: LAN Connection
Connected: Yes
Online: Yes
Using Modem: No
Using LAN: Yes
Using Proxy: No

Firewall Information

Windows Firewall is on.
iTunes is enabled in Windows Firewall.

Connection attempt to Apple web site was successful.
Connection attempt to iTunes Store was successful.
Secure connection attempt to iTunes Store was successful.
Secure connection attempt to iPhone activation server was successful.
Last successful store access was 2010-04-21 16:15:50.

** CD/DVD Drive Tests **

No drivers in LowerFilters.
UpperFilters: GEARAspiWDM (2.2.0.1),

D: SONY DVD RW DRU-V200A, Rev 1.60
Drive is empty.

D: SONY DVD RW DRU-V200A, Rev 1.60
Drive is empty.

E: Memorex 52MAX 325216AJv2, Rev RW$5
Data or MP3 CD in drive.
Found 1 songs on CD, playing time 255:57 on CDROM media.
Track 1, start time 00:02:00
Get drive speed succeeded.
The drive CDR speeds are: 4.
The drive CDRW speeds are: 4.

** iPod/iPhone Connectivity Tests **

iPodService 9.1.0.79 is currently running.
iTunesHelper 9.1.0.79 is currently running.
Apple Mobile Device service 3.0.0.0 is currently running.

Universal Serial Bus Controllers:

Standard OpenHCD USB Host Controller. Device is working properly.
Standard Enhanced PCI to USB Host Controller. Device is working properly.

FireWire (IEEE 1394) Host Controllers:

Texas Instruments OHCI Compliant IEEE 1394 Host Controller. Device is working properly.

Most Recent Device Not Currently Connected:

iPod nano (4th Generation) running firmware version 1.0.4
Serial Number: YM9023TZ5BF

iPhone 3GS running firmware version 3.1.3
Serial Number: 879230PW3NP

** iPhone/iPod Touch Sync Tests **

Sync tests completed successfully.

If anyone has a possible solution please let me know as its getting very frustrating not being able to update my phone.

Message was edited by: powerweb11
Personlized, AMD Quad core
  • frandango Level 1 Level 1 (0 points)
    I get this problem too - it appears to continue to sync for a while, but I have problems with deleting files on the iphone and various inconsistencies. How did you find the diagnostic you ran?
    Dell, Windows Vista
  • roueski Level 1 Level 1 (0 points)
    I had the same problem and fixed it.

    "The iPhone cannot be synced. An error occurred while writing to the device."

    I think it is caused by downloading too many apps, or large apps, and then when syncing over USB it doesn't recognise the iPhone and you get "The iPhone cannot be synced. An error occurred while writing to the device."

    To fix this:

    1. Ensure iTunes is closed & iPhone is disconnected but keep USB cable connected to iPhone
    2. hold down CTRL + SHIFT on your keyboard
    3. connect USB cable to PC and wait. If iTunes doesn't start for a minute then start it (keeping hold of CTRL + SHIFT)
    4. if it wont let you start iTunes or all your icons are selected then release CTRL + SHIFT
    5. when iTunes starts it may ask you about safe mode or something similar, say yes
    6. Your iPhone should list as a device as normal, click sync.

    It will then start the sync as normal and you may find it will transfer only one or two apps and you may get the dreaded error message again as I did. However, persist with the above steps and eventually it sync'd all my apps with no error message. Because I have only just done this I haven't downloaded any more apps so it might be a frequent thing but better than the error message.
    iPhone 3GS, iPhone OS 3.1.3
  • Ragewind Level 1 Level 1 (0 points)
    I've found out why this happens

    1: The Cord you are using to connect the phone is messed up, borrow another one to test or buy a new one.

    2: for some reason you have a faulty USB port. It may work with other items (HDD's, printers etc) but you will get the error when trying to use iTunes with that port. Choose another port.

    3:Make sure your USB drivers are updated and see 2.

    Hope this helps.
    PC, iPhone OS 3.1.3, Windows 7 x64
  • Sarge1024 Level 1 Level 1 (0 points)
    Negative... that didn't work. Tried 2 different iPhone USB cables on 2 different ports and I get the same error message.

    I know it's not the cables because Windows XP recognizes the iPhone and iTunes recognizes the iPhone
    Antec 900, Windows XP Pro
  • GKloncz Level 1 Level 1 (0 points)
    After several versions of iTunes and a year of not being able to Sync my iPhone with my x86 version of iTunes, I finally got it to fully sync. I have been attempting to sync via a USB cable through a fully loaded USB hub. I switched the cable from the hub to the USB port on the computer itself and it's finally syncing!!! I think the issue could be one of three things; 1) syncing through a hub (this one was powered), 2) syncing through a fully loaded hub, or 3) a sporadically faulty hub that mostly manifests itself through large data transfers.

    I hope this helps!

    Gary
    x86, Windows XP
  • Dawn Oz Level 1 Level 1 (0 points)
    I ended up getting assistance from Applecare. One of my problems was that I thought they were referring to a real disk, rather than a virtual disk (music). Also I had a new computer and the builder hadn't told me where the audible files were. Turned out they were stored in three different places in the old computer (the audible files decide this). So, my beloved iPhone now has OS4 and is behaving itself. Recommend Applecare. I think Apple need to give clearer instructions about this problem, not to mention the dreaded exclamation mark.
    iPhone 3GS, iOS 4, PC
  • hockeyeast Level 1 Level 1 (0 points)
    I was having the same problem until i plugged the apple usb right to the computer. Dont use an extention usb from your computer then to the apple usb. That worked for me anyway. Hope that helps.
    dell, Windows XP
  • Pinkyracer Level 1 Level 1 (0 points)
    YES!!! thanks so much! I was using a modified 1G cradle because it ****** me off that they changed the shape just enough to force us to buy all new accessories. just using the cable w/o cradle eliminated this error message. One more error message to go...
    iPhone 1G, 3G, Mac Book Pro, iPod mini, iPhone OS 3.1.3
  • demastrie Level 1 Level 1 (0 points)
    I had a similar problem after moving my iTunes library from my PC to my Macbook by backing up to DVD. If I removed the DVD from the drive and then plugged in the iPhone, I'd see this error. I was able to make it go away by running File>Library>Organize Library...>Consolidate. There must've been some reference to the physical DVD.
    Macbook, Mac OS X (10.6.4)
  • Roland_F Level 1 Level 1 (0 points)
    I had this problem. I eventually solved it by switching the phone off completely and rebooting it. Perhaps I had too many apps open at the same time when trying to sync initially.
    iMac G5, Mac OS X (10.5.8), iPhone 3Gs with OS 4.0
  • gpinto Level 1 Level 1 (0 points)
    Looks like this can happen in multiple scenarios. For my what seems to have happened was the fact that I got a new computer and had not sync'ed up my phone with the old computer in a long time. When I connected my iPhone to the new computer, I was also prompted to upgrade to iOS 4.1. I did so, and my phone ended up with the default apps. When it started syncing, it tried to move the apps that were in the new hard drive into the phone and it failed.

    To fix my issue, I synced back with the old computer and got all my apps back in the phone. Then I synced again with the new computer and, after Googling for a while, right clicked on the phone icon in the right column and chose to "Transfer purchases". They sync is happening right now and it seems to be chugging along.

    Best luck to all of you...
    2.8 GHz Quad-Core Intel Xeon, Mac OS X (10.6.4)
  • p0pp3d Level 1 Level 1 (0 points)
    This works !

    I had the same problem .. i deleted a few apps, took cd out of drive used a new cable (mine was fudged) and used a different usb port ..

    Something changed it lol
  • Drewburger Level 1 Level 1 (0 points)
    After running the diagnostic utility, I unplugged my iOS4 3gs phone, plugged it back in, and it seems to be running like a champ. Not sure if you did this or not, but the 5 apps I had deleted reinstalled to my phone, and everything else imported perfectly.
    Handmande, Windows 7
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.