Previous 1 2 3 Next 44 Replies Latest reply: Dec 6, 2014 5:41 PM by tyxlmnop Go to original post
  • appelgw Level 1 Level 1 (0 points)
    I have struggled with this for several days until I read the above posts. Clearing the history and cookies via the Settings/Safari window didn't work. Clicking on Bookmarks/History/clear didn't work. The problem is that you have a bookmark that has a URL that is showing up when you start typing in a fresh url.

    When you save a bookmark, you can give it a custom title that is different than the url. What gets confusing is when you click in the URL field and start typing www, you get all these 'suggestions' that are actually the URLs of the bookmarks you've saved. If you have one 'offending' suggestion that you don't want to see any more, you will need to go through your bookmarks and check their URLs one by one.
    To do so, click on the bookmark icon, click the 'edit' button in the upper right, then click on the bookmark - it will then show you the URL associated. (Note, don't click the 'edit' button until your inside your bookmark folders, or else you're just editing the name of the folder)
  • PaKo07 Level 1 Level 1 (0 points)
    After clearing history, cookies, cache and any offending bookmarks, try powering down iPad completely by holding down the power switch for a few seconds, and when an on-screen slider appears, power off. Then power back on. Worked for me.
  • moxtr Level 1 Level 1 (0 points)
    suggestions also come from bookmarks
  • Michael Morgan1 Level 7 Level 7 (23,825 points)
    moxtr wrote:
    suggestions also come from bookmarks

    Yes, they do! And several other people discussed this at length in the middle of the thread.
  • moxtr Level 1 Level 1 (0 points)
    My bad. I did not read the thread thru. I caught it after I posted it but couldn't figure out how to delete the post. Next time I won't be so quick on the trigger. Lesson learned.
  • Michael Morgan1 Level 7 Level 7 (23,825 points)
    You can't delete but, if done quickly enough, you'll see an Edit icon above your post and can erase or modify the offending words.
  • waetherman Level 1 Level 1 (0 points)

    Clearing the History (bookmarks/history/clear history) will remove the names of the visited sites from the history but not from the address bar auto-complete. To stop the visited sites from appearing through auto- complete, you must exit Safari, then shut it down (double tap the home button, find Safari, and click on the red minus sign on the corner of the app). This will remove any history of visited sites completely. Note that auto-complete will still bring up bookmarked sites.

  • NJPitcher Level 2 Level 2 (245 points)

    Titcr, addresses the issue.

  • Sbot234 Level 1 Level 1 (0 points)

    I was struggling with clearing history for hours - Dont know if any of you noticed, after clearing history, cache cookies etc, you can still hit the previous page button and be taken to your previous searches.

    Anyway, eventually cleared all the history, deleted bookmarks, and cleared history, cookies and cache in general settings - still nothing. Then thanks to Pako07, I powered down the Ipod - Bingo - all gone. So seems you have to power down for the clearing of the cahce etc to work.

  • BusinessPhysician Level 1 Level 1 (0 points)

    The trick is to tap in the address bar anywhere except the circular arrow or the black cross on white background. This will bring up a white cross on black background. Tap on this cross and the address bar will be cleared.

    Let me know how you get on.

  • xinfromdocklands Level 1 Level 1 (0 points)

    Instead of going to settings for Safari you can also use a private browser app such as free full screen private browsing available from the app store: http://itunes.apple.com/us/app/free-full-screen-private-browsing/id368483462?mt= 8&uo=4

     

    The advantage is:

    1. you don't need to clear history each time.

    2. it's not apparent if someone else uses your phone that you're safari is in private mode.

    3. it's fast and full screen.

  • BurzaRX Level 1 Level 1 (0 points)

    Here is a gauranteed method of clearing your search history and cookies on IPAD (IOS 3 and above)...

     

    1) Go to Settings --> Safari

    2) Change your search engine (switch from Google to Yahoo! or vice versa)

    3) Tap Home button to go back to your main base home screen on your ipad

    4) Tap Safari icon at the bottom

    5) Tap out using home and Go to Settings --> Safari

    6) Tap the following sequentially: Clear History, Clear Cookies, Clear Cache (THESE ICONS ARE BOUND TO APPEAR IF YOU DO THIS RIGHT!)

    7) Change your search engine back to what it was originally

    8) Tap Home button

    9) Launch Safari and verify search history is gone

     

    aint it !

  • BusinessPhysician Level 1 Level 1 (0 points)

    Don't tap the right hand end of the address bar. Double tap in the middle. White cross on black circle appears in right hand side of address bar. Tap on white cross. Address bar should now be clear.

    All the best John B

  • Joengcc71 Level 1 Level 1 (0 points)

    Most likely you have bookmarked the URL somewhere. Go and delete the book mark first. Then clear the history.

  • luminiferousaethers Level 1 Level 1 (0 points)

    So, I have to get rid of bookmarks to have my address bar stop 'suggesting' these pages for me?

    This is literally the worst feature I have ever seen. I can't believe that this is how they designed their browser. I want to both be able to have whatever bookmark I choose, and NOT have it pop up as a suggestion every time I type something similar into my address bar.

     

    Nice job on your crappy browser feature Apple.