Previous 1 2 Next 24 Replies Latest reply: Aug 25, 2010 2:52 PM by Crabbedh
Neville Hillyer Level 4 (1,865 points)
I prefer Safari to open my Home page when it is launched at computer start-up via login items.

Safari 4.0.5 launches OK at start-up but it does not open my home page - launching it from the Dock does open my Home page.

Is there a setting I can change to get it to open my Home page at computer start-up?

Xserve and two 733 MHz G4s with Leopard !, Mac OS X (10.5.8)
  • Klaus1 Level 8 (47,782 points)
    Safari Preferences/General:

    New Window Opens With: Home Page

    also enter the URL for your home page in the box provided.
  • Neville Hillyer Level 4 (1,865 points)
    Both of these are selected but it appears that a new window is not invoked when Safari is launched via Login items.

    Can others confirm this strange behaviour?
  • Carolyn Samit Level 10 (103,365 points)
    HI,

    From the Safari Menu Bar click Safari/Empty Cache...

    Restart your Mac and see if Safari loads with your home page.

    If not, go to the Safari Menu Bar, click Safari/Preferences. Make note of all the preferences under each tab. Quit Safari. Now go to ~/Library/Preferences and move this file com.apple.safari.plist to the Desktop.

    Now go to Safari/Preferences - General. Set your home page and restart your Mac. If it works as it should, move the .plist file to the Trash.















    Carolyn
  • Neville Hillyer Level 4 (1,865 points)
    Thanks for trying to help but I am afraid neither of these worked.
  • Carolyn Samit Level 10 (103,365 points)
    Both of these are selected but it appears that a new window is not invoked when Safari is launched via Login items.


    Only only Safari window will open at login.









  • Neville Hillyer Level 4 (1,865 points)
    Only only Safari window will open at login.


    I was not getting any open window.

    However, for some inexplicable reason, it started working after I removed non-English resources. The reason for doing this was because I discovered that Safari on another volume was working properly and the only difference I could find was that one had much larger (not more) non-English resources. I fail to see the connection but, for the time being, they are both working properly.
  • Carolyn Samit Level 10 (103,365 points)
    Glad you found a solution!
  • Neville Hillyer Level 4 (1,865 points)
    The problem has returned - most frustrating.

    Login items launches Safari OK but it fails to open a Safari window with my home page in the way that launching it from the Dock does. Apart from this quirk Safari appears to be working OK.

    Does anybody else have this strange behaviour?
  • Neville Hillyer Level 4 (1,865 points)
    I reluctantly repaired permissions (takes 5 hours) and the problem went away until the second restart.

    Any thoughts?
  • Klaus1 Level 8 (47,782 points)
    5 hours??!!

    Your system has serious problems, and I would recommend a complete reinstall.

    One of your problems is of course that your slow G4 is not officially fast enough to run leopard at all, as you need:

    A Mac computer with an Intel, PowerPC G5, or Power PC G4 (867 MHz or faster) processor.
  • Neville Hillyer Level 4 (1,865 points)
    As far as I am aware 5 hours is normal for this hardware running Leopard.

    I and many others have reported that Leopard runs surprisingly well on slower than specified G4s.

    On what do you base your assumption that my system has serious problems?
  • Klaus1 Level 8 (47,782 points)
    Sorry, it seems you are completely happy with how your system is running, so obviously you don't require further assistance.
  • Neville Hillyer Level 4 (1,865 points)
    I have several 733 MHz G4s with Leopard. They all take about 5 hours to repair permissions but this is unrelated to the reported reluctance of Safari to open a window when launched by Startup items.

    I would like some pointers as to why, an otherwise working, Safari automatically opens a window when launched from the Dock but not when launched from Startup items. - Any thoughts?
  • Neville Hillyer Level 4 (1,865 points)
    It is now working OK. Here is what I did:

    I removed Thunderbird and Safari from Login items and replaced them the other way around, ie with Safari first. I am not sure why this cured the problem.
Previous 1 2 Next