Previous 1 4 5 6 7 8 Next 113 Replies Latest reply: Apr 30, 2016 9:05 AM by rsayaAppl Go to original post
  • yfain Level 1 Level 1

    I ran into this situation in the Paris hotel. I was given three sets of id/pwd for three devices. While my iPhone and Macbook worked fine, the iPad stopped showing the login screen after some time. I tried all the suggestions in this an other forums - nothing helped. Then I decided to use the id/pwd combo that I was using with iPad on a different device. After that my iPad "recognized" that the old id/pwd was invalid and showed me the hotel's login screen.

     

    Now that it works, I'll also install a couple of other Web browsers on my iPad. If it'll happen again, I'll try to go online from another browser.

  • gs.spencer Level 1 Level 1

    After my iPad was INOP in my Comfort Suites hotel for 3 days I finally figured out my Internet connection problem.

     

    My iPad worked for only the 1st 24 hours after initially setting up a wifi connection. After my time was up, something was blocking the ability to re-register with the hotel website to get me back on the Internet. I tried all of the tips and tricks listed in other posts and reset literally everything imaginable and still could never get an Internet connection even though wifi settings were showing a valid connection.

     

    Here's where I think the problem lies: Hotels use a series of wifi range expanders and if your iPad gets hung on a range expander that wont let you re-register your wifi, then the fix is simply done by turning off your wifi and going to the hotel lobby or other hotspot within the hotel and then re-enable your wifi.

     

    As soon as I did this, my Internet was restored and I was able to re-register with the hotel website and then went back to my room and everything worked again.

  • mdlong Level 1 Level 1

    I have been to so many hotels in the last few months and always had the same issue - it would connect but hang on a blank screen or come up with some error about not being able to get a secure connection.

     

    Having read a few suggestions on this forum I fixed this issue and this is as follows:

    iPhone 5S

     

    • Turn off Auto-Join and Auto-Login once Wifi is selected. Get to this by clicking on the  next to the connected wifi. Then head to your browser, enter something in the URL (e.g google) then you'll be prompted with the Wifi Access point

     

    Please note I had also done the following:

    1. Closed all applications
    2. Turned off Settings > Safari > Block Pop-ups
    3. Turned off Settings > Safari > Passwords & Autofill > Names & Passwords and deleted any saved passwords (noticed a few hotels in here)

     

    You may find you have to renew the connection once in a while but hope this helps.

     

    Cheers,

  • CaroleHAV Level 1 Level 1

    Some Hotel and other "free" WiFi services utilize web browser sign-on pages or terms-of-use agreement pages which must be gotten through to get internet access.

  • Stbond Level 1 Level 1

    Try an old remedy, switch it off and on again.

  • Stbond Level 1 Level 1

    Have you tried switching it off and on again? Old remedy for most problems.

  • al5555 Level 1 Level 1

    Wow!  I can't believe this has been an issue for so long.

    I have a company issued ipad air 2 (wifi only) and it worked fine for months and now I suddenly have this problem.

    The problems started with the ios upgrade to 8.4.0 (now have 8.4.1)

     

    The wifi in some hotels that I had used many times suddenly wouldn't let me log on.

    Strangely, I would randomly get "unable to join network" or "incorrect password" during different attempts with the same hotel. The password was correct.

    I have tried all the suggestions (except IP and DNS modifications... beyond my skills) that were written over the past 2 years of this post and nothing has worked.

     

    Now it has suddenly stopped working with my home wifi !!!

    First I got "incorrect password" and then "unable to join network" and now I randomly get either message during different attempts.

    I did all the suggestions... forget network... clear history and data... clear passwords... turn off autofill...3 different browsers... connect through Settings>Wi-Fi... allow Pop-ups

    I have rebooted more times than I can count.  Still no luck.

     

    Nothing has changed with my network at home and every other device that I own has no problem.  This is an ipad issue and it has begun since my last 2 ios upgrades.

    It still connects to the "Personal Hotspot" from my iphone (for now)

  • Hightech11 Level 1 Level 1

    I had the same problem at a Hilton hotel.  Go to settings, WiFi, Click the circle with the i in it to go to the WiFi network you want to use and turn auto-login off.  When I went to connect the login page came right up and all was good.  Hope this helps.

  • rsayaAppl Level 1 Level 1

    I had this problem at a Holiday Inn Express.  I found out that I had the problem after I got a message from my cell phone service carrier that I had used up 90% of my data!  I had been watching videos on my iPhone thinking that I was using the hotel wifi but in fact my phone had dropped the hotel's wifi connection and had switched to my data without any message coming up.  First thing I did then was go to the App for my provider and turned off the data allowance for my number, so that it would not be able to use my data and I would know if the connection had been dropped.  The login screen had come up the very first time I connected to the hotel wifi, but after that I could not get it to come up, on my laptop or my iPhone 6.  I turned off Auto-join and Auto-login on the iPhone and allowed for Pop-ups in the Safari settings, but I still did not get internet service.  What did work was opening Safari and typing in 'Holiday Inn Express login'.  The login screen came up, I logged in, and Voila! I was connected.  Did the same on the laptop and it worked as well.  Hope this helps!

Previous 1 4 5 6 7 8 Next