Previous 1 4 5 6 7 8 Next 113 Replies Latest reply: Apr 30, 2016 9:05 AM by rsayaAppl Go to original post
  • ronheller Level 1 Level 1

    This is interesting (avoiding the emotional adjectives that continue to come into my brain...).


    Until spring 2012 I had no problem connecting to wi-fi with any of my Apple devices, even in the rooms of hotels that offer free wi-fi.  Suddenly this spring, I began to experience major connectivity problems.  I am currently in Gulfrt MS, and all three hotel chains at which I stayed on the way (La Quinta in Hickory NC, Wingste in Atlanta GA, Hampton Inn Biloxi) exhibited the same problems with all my Apple gear (1st gen iPad, two MacBooks using SnowLeopard & Lion, two iTouches both using iOS 5.x)


    Viz.., I was able to establish a connection in the room, saw the DHCP and the rest of the specs established except for the DNS service.  Suspicious, I opened Safari but was unable to get the login screen to enter the password for the wi-fi.  It appeared that I was connected to the local router but not the Internet. 


    This is not  a problem at food establishments or hotels offering free WiFi without password protection (MacD, Panera, truck stops).  It is as if I am unable to get as far as the login screen; Safari eventually times out.


    Now here is the bizarre part: On a hint from a LaQuinta desk clerk, I tried to login in the lobby and had vey little problem - a little longer wait  than previously, but always able to get the login screen.  Then curiously the wi-fi usually worked back uh the room.


    So, for me, I guess I will have to go to the lobby/breakfast room first each day.  (Is this why so many people seem to go to the free buffet breakfast in their pajamas these days...?)


    In the past I stayed at Hilton chain hotels, but I'm traveling with dogs and found myself trying out motels that would permit pets.  That's why I notices the consistency of the problem. (The little guys are rooming with a friend here in Gulfport so we coulda stay where we liked).


    As I said at the outset, this is an interesting problem in my case.  A combination off comparability with Safari and signal strength issues? Certainly the signal in the room would not be different technically from the signal in the lobby in all three hotels,would it? Have some changes required by the latest MS OS upgrades caused this Safari (presumably) problem? I do have Apple care so I will eventually have a talk with those folks; I only hoe that they will not claim that they never heard of the problem!


  • jbg7474 Level 1 Level 1

    I had this issue with my iPhone 5 today.  I was able to connect to the free hotel wifi at this Residence Inn yesterday--the login page popped right up and everything worked perfectly.  Today, it was not working.  It finds the network just fine, but then the login page wouldn't come up.  If I "forgot" the network, and then reconnected, I could get the login page to come up, but it wouldn't load.  Shutting down the phone and turning it back on fixed the problem for me (autofill was already off by default).  I suspect there's a Safari bug in iOS 6 that is causing an issue.  I did have Safari crash on me yesterday--I was pushing it pretty hard with 7 pages open, but a crash is a crash.

  • tnorga Level 1 Level 1

    I could not connect my ipad to La Quinta  Hotel in Clarksville. My iPhone  had no problem. I read a thread that recommended going to the lobby to connect and that did the trick. Went back to my room still connected. Unfortunately ,I have keep going back to the lobby every night to reconnect.

  • BartonS Level 1 Level 1

    The following worked for me, please try it and verify:


    Double-click the home button to bring up the list of all running applications.

    Touch and hold on the first application to bring up the [-] on all applications in the list.

    Close ALL your applications by clicking [-] on each one.

    Click the home button to return close the now-empty applications list.

    Open Settings and try again to connect to the hotel wifi.


    My theory is that many applications now constantly poll (facebook may be particularly egregious) so it is one of those applications that makes the first connection to the internet after the new DHCP lease is obtained.  That application "steals" the login page, preventing Settings or Safari from bringing it up for you.


    Thus it might be sufficient to close all applications that regularly use the internet ... but that would include anything ad-supported, so closing everything is safer.


    This might also be why powering off and back on works for some people; however, I was told by an "Apple Genious" that because IOS tries to restore the running applications after a reboot, it's a good idea to periodically clear them all out by hand.  (That was for a problem unrelated to wifi access, but seems like potentially good advice anyway.)

  • berserker-82 Level 1 Level 1


    Hello, I had that same issue. What you need to do is go into settings then wifi, go to where your netword ssid is displayed, your network name, open it, then use the arrow at the right of the subfield, to go into your dhcp, static all of the different ip obtain options.. blah blah. Then you will have a option to forget network, do this, then back out of everything, go back in to setings, wifi, etc, you get it. rescan for networks, when you see your network, you should be able to touch it and open up the password sub-field. enter your password to your network, and bamm you be in business... Also to anyone else, I have read others issues, I not having traveled much lately, cannot explain the hotel and other location issues. But I have noticed the ipad has very conflicting behavior when connecting to a network and then a different network and so on. Example, if you have multiple networks that have the same ssid, name, even with a different modem/router it gets them confused and tries to auto-connect. even though they are diffrent modem/routers.very odd and sloppy...  how I discovered the problem, was i set up a lot of small networks just for people at their homes or small office, and I set most residential the same, we will say, home-2013. So I had someones ipad, and I was the one who set their network up, his and my network names were the same, even though coming from completely different modems. At first, I was astonished to see that such a piece of supposedly superior technology, lacked even the basic concept of distinguishing the difference between networks with the same name. any other device can do that, Smartphones android and apple???? ***??? Well, I hope this helps some of you:] and thank you for reading my rant...


    Message was edited by: berserker-82

  • berserker-82 Level 1 Level 1

    also. I have heard several companies set up a lot of hotel chains networks, maybe they have the same ssid, name, but different password, humph worth a try good luck everyone...

  • BartonS Level 1 Level 1

    Forgetting the network and trying again works only some of the time.  The problem is that the hotel wireless networks don't have a network password, instead they allow DHCP to obtain an IP address without a password and then redirect all HTTP traffic through a gateway that makes you enter a password before you can do anything else.  This is so that they can ask you to approve a charge for the service at that gateway page if they choose.


    If the first thing that happens after the IP is assigned is that some background application attempts to use HTTP, that application will get the gateway login page, and now you're screwed.  The only way to be sure that doesn't happen is to prevent any background applications running until after you're successfully connected to the network and past the gateway page.

  • berserker-82 Level 1 Level 1

    I was mainly responding to defective sargeant, because that was the exact issue i discovered and found that forgetting the network, was the sollution to that.But like I said dont know to much about the hotel issues. But thank you for explaining that. I do a lot of computer/network/smartdevice repairs. So I am pretty efficient at solving problems, and understanding technical issues. But really with all the various issues with these ipads, I think they are very overpriced for what they do. Like I said a ipad cant recognize a different network, just cause of the same name. I have a old optimus lg smartphone and it can tell the difference. I think these devices have a lot of issues!! And the only reason I am even using an ipad is because i got it for free.... Dont get me wrong apple has some great devices, i love the new iphone, its great. But the ipad..... mehhh.

  • wainwrightns Level 1 Level 1

    I have tried everything you (and everyone else) suggested, but my iPad WILL not forget my hotel's wifi and allow me to input ID and password. Any other suggestions?

  • berserker-82 Level 1 Level 1

    What version is your ipad? And give me the exact details of what is going on. Are you staying @ this hotel now or frequent there? And what happens when you try to connect, And can you connect @ another location with out any issues? Thanks.

  • wainwrightns Level 1 Level 1

    Thanks! It's an iPad 2. I haven't tried to connect elsewhere since got to this hotel (we are in Calgary, canada, at hotel on university campus ). However it worked just fine at the airport befre we came. My phone works, my husbands phone AND iPad work. I have enabled safari cookies, enabled popups, instructed in settings to 'forget this network' (6 or 7 times), turned off all my apps and reopened, turned the iPad's power off three times. Despite this, every time I go back to wifi settings, it shows it is again connected to the hotels wifi --- and still will not offer me oppty to input ID and password, and safari still says"no Internet."


    Sent from my iPhone

  • berserker-82 Level 1 Level 1

    Is your ask to join networks on or off?

  • berserker-82 Level 1 Level 1

    You might need to give me a few to figure this out, and I may need to ask you a few other questions. Try this first, most likely will not work, sorry, but worth a shot, more of a test for me to get familiar as I can with these devices and hotel issue. Go into settings, in wi-fi, set your ask to join networks off, then forget every network on your ipad,that you can, then in settings,safari, turn on pop up blocker, have autofill turned off, then still in safari in settings, clear history and clear cookies and data, power off ipad, wait a min or so, power on, let sit and load, then shutdown all unncecessary network apps that are running. open up settings, wi-fi, search for networks try and connect or at least get to the gateway login page, and see if it will allow you to connect now, and let me know. Thanks:] Well get your issue figured out, never fear. We will get this paltry hotel wi-fi issue figured out:] Note act on this first, open up settings, then wi-fi, then click on the network it says its connected to,then push the arrow over icon on the far right , the first field it will bring up is your dhcp auto settings, ip address, etc, tell me if there is anything there, an ip adress, a subnetmask, router, dns, search domains and client ID, tell me what or if anything is there at all. Also make sure your device is updated with the latest updates out for it, that is in settings under the general tab. do this first please. thank you.

  • wainwrightns Level 1 Level 1

    I really appreciate your efforts, Berserker-82. However, at 5:10 p.m. this evening I was desperate to work on something bigger than my iPhone. I tried my ipad yet again--and <i> this </i> time it asked for the password. So it's been working and I've been working. I did nothing more to encourage it to work, but it did! Thank you, anyway!

  • berserker-82 Level 1 Level 1

    Thats greats! But you see, that is exacctly like the issues I have been hearing and seeing. They just work as intended some of the time, and sometimes you have to do nothing to solve the problem. The mystery continues, my friends. Hopefully apple will get involved and come with some anwsers that are a little easier than constantly changing things, or poof, they work, just after sitting at the network for a long enough time??? Hope. lol.. but that is great and no problem, hope it works great for you from now on:]

Previous 1 4 5 6 7 8 Next