Previous 1 2 Next 26 Replies Latest reply: Jun 27, 2015 6:11 AM by scholas
mcdoobie Level 1 Level 1
kept having problems with applications so i restored my iphone. usually a simple task, but this time around it won't get past the 'restoring iphone software' screen on itunes and the progress bar on the phone keeps getting stuck in the same spot (3/4 the way through). i let it sit for 20-30 minutes and it just stays there.

i did a hard reset three times and now i'm on my fourth time with the same problem.

any ideas?

running the most recent version of itunes (9.1.1), restarted computer, tried different usb ports.

macbook pro, Mac OS X (10.5.8)
  • iphone3Gguy Level 3 Level 3
    Check this out

    http://caffeineinduced.wordpress.com/2009/02/16/iphone-software-update-hangs-aft er-installing-att-wireless-card-this-reghack-may-fix-it/

    http://support.apple.com/kb/TS1275
    "There may be third-party software installed that modifies your default packet size in Windows by inserting a TcpWindowSize entry into your Registry. If your default packet size is set incorrectly it can cause this error. Contact the manufacturer of the software that installed the packet size modification for assistance."
  • mcdoobie Level 1 Level 1
    thanks for the link, but i'm on a mac. i let it sit overnight and it's still frozen at the same screen.
  • wjosten Level 10 Level 10
    expertise.iphone
    iPhone
    Are you trying to restore from backup or as new? Your backup may very well be corrupted, thus creating the situation you're in. Your only fix may be to restore as new & delete any backups that currently exist.
  • mcdoobie Level 1 Level 1
    i'm trying to restore as new. i just tried a backup phone i had and it's having the same exact problem.

    could it be something on my macbook pro? it freezes at the same exact point on my phones/mac.
  • wjosten Level 10 Level 10
    expertise.iphone
    iPhone
    could it be something on my macbook pro?


    Yes. Software up to date? Itunes up to date? Any firewalls on your router? You might try uninstalling itunes & then reinstalling, follow the directions here as this must be done in a certain order:

    1. Disconnect your iPhone, iPad, or iPod from the Mac.
    2. In the Finder, locate iTunes in the Applications folder and drag it to the Trash.
    3. Move the iTunes icon to the Trash.
    4. Choose Go > Go to Folder.
    5. Enter /System/Library/Extensions and click Go.
    6. Locate the file AppleMobileDevice.kext and drag it to the Trash.
    7. Choose Go > Go to Folder.
    8. Enter /Library/Receipts/ and click Go.
    9. Locate the file AppleMobileDeviceSupport.pkg and drag it to the Trash. If prompted, authenticate with the administrator password.
    10. Restart the computer.
    11. Choose Finder > Empty Trash and restart the computer.
    12. Download and install the current version of iTunes.
    13. Connect your device to the Mac again and open iTunes
  • tcb9289 Level 1 Level 1
    Can anyone offer instructions for a Windows version of iTunes? I'm having this exact same problem (Attempted factory restore results in my iPhone 3G stuck 2/3-3/4's of the way through the restore process on the apple screen). Any help would be GREATLY appreciated.
  • fabioganga Level 1 Level 1
    wjosten, you are a genius!

    I've finally managed to resolve this problem which has been plaguing my MacBookPro for ages....

    Thank you!
  • jerrydink Level 1 Level 1
    @ wjosten: This worked for me. Thanks a lot. Just wish it would work for my other iPhone.
  • fabioganga Level 1 Level 1
    Here's an update for my case: the solution suggested by wjosten only works for me ONCE.... as soon as I try the second restore/update, I'm back to square 1.... same annoying problem!

    Also, I NEVER seem to have in /Library/Receipts the AppleMobileDeviceSupport.pkg file, even after reinstalling Itunes 10.

    What else could I try to resolve once and for all?

    Any further help anyone can offer me will be appreciated greatly.
  • kd13 Level 1 Level 1
    any luck fixing problem? I have the same exact problem let me know thanks
  • fabioganga Level 1 Level 1
    Any update please anybody?

    This is really starting to be very annoying....

    Thank you.
  • fabioganga Level 1 Level 1
    I have finally resolved this problem once and for all....

    After researching and googling for a while, I have identified what was causing the problem in my case, it's the "Wi-fi sync" application that I used previously when my iPhone with 3.1.3 was jailbroken.

    I have downloaded the uninstaller from the web site and.... bingo!

    Problem solved, at last, once and for all.

    I hope this helps.
  • farazthambi Level 1 Level 1
    I had the same problem, did the reinstall steps by wjosten. I was reading online that the file is not present after a certain update so there is nothing to worry about.
    This step works for me
  • MZPACH Level 1 Level 1
    That was it! Thank you so much. I was getting really frustrated because I've had the same problem on two different Macs.
Previous 1 2 Next