Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: safari can't establish a secure connection

I have a Mac mini, and I'm the admin on it, my kids have the accounts. I can get onto Facebook on my account, but all other accounts come up with the message in the subject line. Anyone know why?

iMac 20", Mac OS X (10.5.6)

Posted on

Reply
Question marked as Helpful

Jun 8, 2010 10:14 PM in response to Mark Keirstead In response to Mark Keirstead

Hi Mark,

Try deleting the cookies in their accounts and see if that helps.

From the Safari Menu Bar click Safari/Preferences then select the Security tab. Click: Show Cookies
Delete the Facebook cookies, click Done. Relaunch Safari... see if they can access FB now.













Carolyn 🙂

Question marked as Helpful

Sep 26, 2010 5:39 PM in response to Mark Keirstead In response to Mark Keirstead

Found a temporary fix. Go to the parental controls preferences. Go to logs. Choose "websites blocked". You should find the websites that don't work listed here. They may have strange names. For me, gmail was listed as "1E100". Click the down arrow next to an entry. Click "Unknown". Click "allow".

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Jun 8, 2010 10:14 PM in response to Mark Keirstead In response to Mark Keirstead

Hi Mark,

Try deleting the cookies in their accounts and see if that helps.

From the Safari Menu Bar click Safari/Preferences then select the Security tab. Click: Show Cookies
Delete the Facebook cookies, click Done. Relaunch Safari... see if they can access FB now.













Carolyn 🙂

Jun 8, 2010 10:14 PM

Reply Helpful (1)

Jun 13, 2010 2:27 PM in response to Mark Keirstead In response to Mark Keirstead

I found that the problem seems to be with parental controls. I wasn't told when the problem actually started, and I'm sure he was fooling around with something...

Anyways, if you go into their account, go to System Preferences, click on Accounts. Unlock the padlock, and click on the account you want to correct. Click on Open Parental Controls at the bottom, and click on the Content tab. Where it says to limit access, click Customize. In the top box, you can type in the websites that will be ok to access.

This has worked for us, however, it still doesn't resolve why the problem came up in the first place. So, I'll leave it unresolved, and see if anyone comes up with the fix.

Hope this helps...

Mark.

Jun 13, 2010 2:27 PM

Reply Helpful

Jul 6, 2010 12:34 PM in response to Mark Keirstead In response to Mark Keirstead

I'm having the exact same issue on our kid's accounts with Parental Controls enabled. The odd thing, it doesn't effect all of them. I think it's happening with any https:// login screen....Facebook, MobileMe and even the support site here generated the message. I had to switch to the admin account to even login to submit this.

What I've done so far is to double/triple checked the Parental Controls settings, added the offending sites to the list of "allowed" sites. I've also deleted cookies, reset safari, etc. I even tried FireFox (same issue) so it's not browser-specific but appears to be a bug with Parental Controls.

It appears to be something to do with OS 10.6.4 and Parental Controls. Everything has worked peachy until the last few days. It seems to roughly conicide with the install of 10.6.4 (installed the day it was released) but my daughter tells me FaceBook just stopped working today (MobileMe login has not worked for some time).

Regards,
Terry

Jul 6, 2010 12:34 PM

Reply Helpful

Jul 28, 2010 7:46 PM in response to tlwyse In response to tlwyse

Parental controls can't reliably manage https connections, and these days most web services require an https connection at least for initial authentication.

So Parental Controls are now pretty much obsolete even on 10.6.4. There are workarounds but they're not practical.

Apple has to fix this. I wish I could figure out how to make Apple feel our pain.

Message was edited by: jfaughnan

Jul 28, 2010 7:46 PM

Reply Helpful

Aug 3, 2010 9:34 PM in response to jfaughnan In response to jfaughnan

I also have this same problem: my (admin) account accesses HTTPS sites like facebook and Gmail just fine in Safari 5. My children's accounts, on Parental Controls, cannot.

I added https www gmail (without spaces) to the specifically allowed sites, to no avail. Also tried Firefox. Also reset safari.

Error message says cannot establish connection with Google website. preposterous. Any suggestion, please?

Aug 3, 2010 9:34 PM

Reply Helpful

Sep 24, 2010 3:58 PM in response to Mark Keirstead In response to Mark Keirstead

Same exact problem here. Despite adding even the "https://" version of "google.com/accounts" and "mail.google.com" etc., gmail will not work on my kids account with parental controls on. Look forward to a fix.

Sep 24, 2010 3:58 PM

Reply Helpful
Question marked as Helpful

Sep 26, 2010 5:39 PM in response to Mark Keirstead In response to Mark Keirstead

Found a temporary fix. Go to the parental controls preferences. Go to logs. Choose "websites blocked". You should find the websites that don't work listed here. They may have strange names. For me, gmail was listed as "1E100". Click the down arrow next to an entry. Click "Unknown". Click "allow".

Sep 26, 2010 5:39 PM

Reply Helpful (1)
User profile for user: Mark Keirstead

Question: safari can't establish a secure connection