Skip navigation

iPad won't connect to wireless network but laptop can

159710 Views 56 Replies Latest reply: Apr 16, 2014 6:20 PM by WyoRob RSS
1 2 3 4 Previous Next
iPod Touch - Wipe Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 13, 2010 5:43 AM
My iPad recognizes the wireless network but wont connect to any websites.

My husbands lap top is having no problem connecting to the wireless network and websites.

Why won't my iPad connect to any websites?
Mac OS X (10.5.4)
  • Andy Tedd Level 1 Level 1 (0 points)
    Have you tried the iPad while the laptop is connected? My iPad does the same, it finds the Wi-Fi network but does not connect to any websites. If I turn my iMac on and make sure it's connected to the wi-fi network, suddenly my iPad connects? Not sure why or how that works?

    Andy
  • tboswell Level 1 Level 1 (0 points)
    Yesterday my iPad started having problems connecting to my home wifi. Right now it is not connected but all 4 other laptops are working using the same wifi access point.
    iPAD 32 GB, iPhone OS 3.1.2, iPad 3.2
  • Andy Tedd Level 1 Level 1 (0 points)
    I have been reading on other threads, and it seems iPad likes a certain setup of the router it is connecting to. I am trying to learn about router settings at the moment, so if I have any luck i'll let you know.

    Andy
  • princehal Level 1 Level 1 (5 points)
    I have a new iPad and tried to connect it to the router that my iMac is using ... it has full strength, accepts the password, and still doesn't let me do anything on the iPad. Am I missing something?
    iMac and iPad, Mac OS X (10.6.4)
  • SPeeDy22 Level 1 Level 1 (0 points)
    Hello Andy,

    did you find a solution yet? I have the same problem: turn in iPad, founds network but can not use internet. When turning on my laptop suddenly the iPad "wakes up"?
    Dell, Windows XP
  • funkof73 Level 1 Level 1 (0 points)
    Check your IP address on your iPad....if it's 169.254.. it will not connect to internet.

    I changed my router's security to WPA2-PSK like mentioned before in this thread and the iPad connected instantly. I had it on WEP previuosly.

    Same passcode and everything...so hopefully this won't cause problems with most of my other wireless devices.
    happy iPad now...
    iPad, iOS 4
  • tooklye Level 1 Level 1 (0 points)

    I searched online for the same issue without any luck but found this after i resolved the problem:

     

    Nasty 169.x.x.x ip address suddenly started showing up on my iPad and wont connect to the Internet.

     

    Got the router reset and changed the security and it worked.

  • AnotherHarry Level 1 Level 1 (0 points)

    I don't know what I'm doing, but I had the same problem and accidently solved it.  I went to settings-wifi and then touched the blue arrow button next to my network name.  I then touched "forget this network".  I then closed settings and opened safari.  I got a message that I couldn't access the internet because I wasn't connected to a network.  I removed this message and then waited.  Eventually (within 30 seconds) a join network box appeared, I touched it, typed in my password, and it suddenly worked.

  • pjasmine52 Level 1 Level 1 (0 points)

    I'm having the same problems.  My computers have no problem connecting, but my iPad intermittantly can't connect to the internet.  I've tried "forgetting" the network, but it that won't fix it.  The only thing that fixes it is rebooting my wireless router.  But that is not an acceptable solution, I shouldn't have to keep doing that.  Must be some conflict with the IP address, but can't figure it out.

  • mr.fromlos angeles Level 1 Level 1 (0 points)

    thanks... I had the same problem but i did what you had said and everything became normal...again thanks

  • bearwife Level 1 Level 1 (0 points)

    I had this problem at work after resetting my Ipad 2 to deal with a different problem.  I called Apple Support, which had nothing to add beyond what can be found in the threads and support articles here.  When the Apple Support person started pushing me to reset my Ipad2 to factory settings, wiping out everything, I said forget that.

     

    Here's what worked for me:  1) turn off my cellular data service 2) make sure none of my available wireless networks were "known" 3) turn on Safari and ignore/dismiss the message that Internet service wasn't available 4) when the message about available networks finally came up, pick the one I wanted and put in normal sign in.

     

    And I'm up!  Without returning to factory settings.

  • cre8iv1 Level 1 Level 1 (0 points)

    Great solution.  I never would have thought of if.  I'd tried all of the "usual suspects" without success.  Thanks for posting...

  • rayraw Level 1 Level 1 (0 points)

    Help! I'm having the same problem. My laptop PC connects fine, but my iPad finds the network, shows a connection with strong signal, but when I try to access anything on the internet I get a "serve unavailable" error. I've tried everything in this thread with the exception of resetting the server. I'm staying at a hotel in Germany and they won't do it. I've used my iPad at different hotel here so I know it's not an issue with Germany.

    Any help would be greatly appriecated.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.