Previous 1 11 12 13 14 15 Next 338 Replies Latest reply: Jan 3, 2015 9:32 AM by appleornothin Go to original post Branched to a new discussion.
  • Harshjeet Level 1 Level 1 (0 points)

    Hey Guys i was having same problem!!

    i tried one of method given in thid dicussion!!

    Settings > Wi_Fi > Press Blu Arrow Near Ur Wifi Name >DNS

    add one more DNS adrress 8.8.4.4

    AND VOILA!!!

    Problem Solved FOr Me!!

    CHeers!!!

     

    Message was edited by: Harshjeet

  • lovecookie Level 1 Level 1 (0 points)

    i dont know if this will work for other but it work for me...   general>reset>reset all settings

  • mojomuser Level 1 Level 1 (0 points)

    I bitterly regret trading up from my 3Gs to 4S - a backward step.  I cant connect to iTunes, or update Apps.  iCloud is utterly disappointing and sends constant messages telling me that password is invalid and it cant stream photos, etc. Emails wont send on 3G - they go straight to outbox and only send when WiFi connected.

    Siri is pointless for UK market.

     

     

    What do I do? Apple customer service response is to read through reams of self-help 'tips'!

     

    Have had phone for 3 weeks - shall i get refund and swap for Android?

  • geminicfl Level 1 Level 1 (0 points)

    Since iOS 5.1 was released I've been having this problem again. I managed to fix it before by restoring my iPhone as new using the latest version of iTunes. However, upgrading to iOS 5.1 is not an option for me as I don't wish to lose my jailbreak. So I decided to check all of my settings again to make sure they were correct when I noticed that my IP lease had expired despite still being connected to WiFi. When viewing the details of my WiFi connection, the IP address, subnet mask and router are all blank. Pressing the Renew Lease button at the bottom has no effect. Disabling and enabling WiFi never used to solve this problem for me before, but it does now. I suspect IP lease issues with iOS are at least part of the problem. Funny how there are multiple causes and solutions for this highly annoying error.

  • Soumyatec Level 1 Level 1 (0 points)

    Bought a mew iPhone 4S 1 day back and it seems problems started already as i have installed iOS 5.1 and now whenever i try to connect iTunes, it gives the message, 'Cannot connect to iTunes Store". Able to connect to internet through safari, able to open App Store & iBookas well, but not to iTunes Store. Very wired. Tried all the options of "reset all seetings" & restarting etc, it does not work.Any body has a colution to it?

  • Briana_e Level 1 Level 1 (0 points)

    Disabling and then enabling my wifi seemed to fix it!

  • shenvee Level 1 Level 1 (0 points)

    I encountered the same problem after updating to iOS 5.1

     

    Changing the DNS to 8.8.4.4 doesn't work for me. I went to SETTINGS > STORE > APPLE ID , and then Sign Out .

     

    Sign In again, and it works!

  • EricinJapan Level 1 Level 1 (0 points)

    I am having that issue too. Only a 3wk old i4s, software version 5.1, restored, verified account, and it still will not work through my home wifi. I can connect to the iTunes store, but it will just not update through the App Store update.

  • greatoz99 Level 1 Level 1 (0 points)

    I ran into the same issues with my iPhone 4 starting last night: on either 3G or Wi-Fi no apps would update ("Cannot conenct to iTUnes store")

     

    I tried a bunch of things, even restoring my phone, no luck.

     

    I finally tried forcing my DNS to 8.8.4.4., everything worked fine. Went back to 3G, it would not work. As I was on hold with AT&T, it started working (AT&T guy had never heard of such a thing).

     

    Reset my WiFi connection to use the default DNS and was just able to install a new app!

     

    I have to chaulk it up to some kind of weird DNS issue in my area...

  • xicer.x Level 1 Level 1 (0 points)

    I figured out the solution or at least it worked for me. Try going into settings -> general -> reset -> reset all settings.

    This will erase any passwords or wifi password and change you wallpaper but does not erase any data.

    It worked for me hope it helps out.

  • JPerione Level 1 Level 1 (0 points)

    I had the same problem for a week and I just connected my iPhone to my laptop and at the same time went to the app store and it started working again. 

  • HawkeyeGal Level 1 Level 1 (0 points)

    This is what worked for me, too.  Thanks!!!

     

         I went to SETTINGS > STORE > APPLE ID , and then Sign Out .

  • Oltens Level 1 Level 1 (0 points)

    When downloading an app from app store via WiFi a have the same issue - Cannot connect to itunes store. But it works on 3G. I tried to sign out and sign in to Store, tried resseting wifi connection - and nothing helped. So the problem underlyies in DNS settings? or should I reset all settings? plese, help. it`s very annoying:(

  • greatoz99 Level 1 Level 1 (0 points)

    Try resetting the Network settings (the full reset). If that doesn't work, force the DNS on your Wi-Fi connection to use 8.8.4.4.(done from the Wi-fi connection on your phone, just overwrite the default setting). This will allow you to update using wi-fi.

     

    In a few days 'forget' the wi-fi connection and re-join to use the default again. See if you can update using your ISP's default DNS settings.

     

    The DNS issue on both my wi-fi and 3g lasted less than 24 hours.

  • Sanz7 Level 1 Level 1 (0 points)

    Try this...

     

    • Settings
    • General
    • Reset
    • Reset All Settings

     

    It worked fine for my iphone 4s after trying everything...

     

    Good luck

Previous 1 11 12 13 14 15 Next