Previous 1 14 15 16 17 18 Next 338 Replies Latest reply: Jan 3, 2015 9:32 AM by appleornothin Go to original post Branched to a new discussion.
  • wedsky Level 1 Level 1 (0 points)

    the thing is i updated to ios 6 beta 1 or 2 i think and it says your iphone is not registred.And when i want to restore my iphone i open itunes and it says we're unable to complete your activation.What i supposed to do?pls rsp.I need a lot of help

  • arodecap Level 2 Level 2 (215 points)

    Try finishing the setup assistant and then restore from the phone maybe? just a suggestion... Hope it helps. Does it say "Welcome to your new iPhone" on iTunes when you click the name of the device?

  • irishjeff Level 1 Level 1 (0 points)

    Hello all! My problem started when i tried to create a UK store to purchase a CD. Because of geographical restrictions, you can't download certain music or videos in foreign countries. I wasn't able to even continue to create a UK account because i didn't have a postal code or address in the UK. I did this on my IMac so it tried to change my default store on my Iphone 4S and IPad to the UK also. So when i grabbed my iphone it was stuck trying to access the UK store. I signed OUT of the store through setting and then signed in. The message that i was being switched back to the US store came up and all was fine from them.



  • Ghifarr Level 1 Level 1 (0 points)

    Hii.. I've been resolve my problem because of this problem..

    And mybe my method will help you if all of method that you already try's fail

    Here it is : go to your setting> then scroll down to appstore > logout your account> then login again with your account > after you login your account will show up> click your account same as when you want to logout your account but there is 3 options will show up click view apple id > then turn on genius> follow the step till done.... And yah finally now you can back normal again without cant connect to itunes. It works for me.. You can try it

  • Ghifarr Level 1 Level 1 (0 points)

    And sorry for my bad english i'm indonesian cheers 

  • Jatojumper Level 1 Level 1 (0 points)

    If your Verizon dial *228 and select option 2 and let it update your roaming services.  Once that is finished go into settings>general>network and make sure that data roaming is ticked "on"

    I was having the same issue as everyone else and this fixed it!

  • gabet0o Level 1 Level 1 (0 points)

    Hey all! Listen up. I have tried ALL possible ways to fix that error and the only way to fix it is to reset all settings! That was the only way that helped for me!    Settings>General>Reset>Reset All Settings and you can keep ur apps and all the other things! Hope this works for you too!

  • floridana Level 1 Level 1 (0 points)

    Sorry, this did not work for me.  I am afraid that I will lose everything if I reset my settings.  any other suggestions?

  • DylanLara Level 1 Level 1 (0 points)

    I signed out but now I cant sign in again .. It still says can not connect to iTunes store .. I dont want to reset all my settings :(

  • gabet0o Level 1 Level 1 (0 points)

    Can you read??? When you RESET ALL SETTINGS there is a question after that and it asks you if you want to RESET you data and you can choose how to get ALL DATA back by iTunes or iCloud! It's simple I ALREADY DID IT!!! I am 15 and I wanted to keep my saved data in games soooo I would never do this if I had to lose everything!!! So don't worry! Really if you want cool updates and nothing else fixes the stupid problem RESET your iPhone and everything will be OK

  • pinicbasket Level 1 Level 1 (0 points)

    Just wanted to say thank you. I've tried everything & it's been nearly a week! This is the only thing that's actually worked for me!

  • blueflowerchild Level 1 Level 1 (0 points)

    I had the same problem and tried all of the above then I finally realized that the problem was I needed to update my payment information. My credit card expired and I received a new one, but forgot to update my information in itunes.

  • audioblare911 Level 1 Level 1 (0 points)

    I just upgraded to iOS 6 and I tried to open Passbook, when I clicked on App Store at the bottom, it said "Cannot connect to iTunes Store" and thus I couldn't use the app. I tried all the other suggestions and finally just reset all my settings. You don't look any data, just your settings, which you can just set back. Easy. Thanks!

  • silvurtungdevil Level 1 Level 1 (0 points)

    Good news everyone, just updated to iOS 6 and it fixed this problem.

  • Kevin Petersen™ Level 1 Level 1 (5 points)

    I was having the same problem, but somehow I fixed it.


    1. Go to "Settings" app.

    2. Select "iTunes and App Stores".

    3. Sign out of your Apple ID.

    4. Now go to the App Store.

    5. It should work.


    Worked for me. Try out. I HAVE A US APPLE ID.

Previous 1 14 15 16 17 18 Next