Previous 1 2 3 Next 36 Replies Latest reply: May 27, 2013 2:21 AM by Danc3r99 Go to original post Branched to a new discussion.
  • jedirulez Level 1 Level 1 (0 points)
    It isn't just Linksys routers, I have tried a D-link and a Netgear at home and neither works. But a different Netgear that is used for the free wifi for my HOA, plugged into the same ISP as me, works just fine. And like a few have mentioned before it worked up until around the time of the June 15th update. There was an update today to the Netflix App but still no luck.
  • CoachDJS Level 1 Level 1 (0 points)
    I have the same problem. However, I can't get mine to work anywhere. I run an airport extreme and airport express at home and can't connect. At work I have an enterprise hp system that is top of the line and it still doesn't work. And like others it once worked and just stopped. Was one of the reasons I got the iPad and now it won't work. Oh well, maybe I'll read a good book or watch something on ABC.
  • sohogirl Level 1 Level 1 (115 points)
    Did you try running a firmware update on your router? Since it works on some routers and not on others...You may have to setup the router again from scratch, run a firmware update and troubleshoot from there. What I hate about issues like this is that they come out of no where and have no logical reason for not working. If I had that issue, I would start with running firmware update, then setting up my router from scratch.

    Whatever the solution, I hope it gets resolved soon and please post resolution here.

    Good luck!

    SG
  • Babalooooo Level 1 Level 1 (0 points)
    No firmware update on my dlink router, but did hard reset the router and started from scratch : NO GO ! this is so incredibly wierd.
  • Waymen Level 5 Level 5 (5,635 points)
    I've not had any problems with a Belkin-G basestation attached to my first generation Airport Extreme (Belkin provides G-only, Airport Extreme is setup for 5GHz N-only). The Netflix iPad app has also worked through a WiFi-enabled DSL modem provided by AT&T (although DSL speeds can be a bit slow for streaming video).
  • fjsdofnsjgv Level 1 Level 1 (10 points)
    I had the same issues. After a "hard" reboot of the iPad (hold the power/lock button), it worked! (16GB iPad and Linksys WRT54G router)

    Message was edited by: fjsdofnsjgv
  • jedirulez Level 1 Level 1 (0 points)
    I have found a solution for this problem, at least it works for me 100% of the time and it is 100% reproducible. I went into my router and changed the DNS to use OpenDNS and it works flawlessly.
    This solves the problem on both my Ipad and the new versions for the Iphone/Ipod Touch. Since the new version of the App was released recently for the Iphone I no longer got the "Unable to reach Netflix.com" error, it just flat out wouldn't play the movie. Changing my DNS has fixed this completely. I have no idea what could be going on with my provider's DNS, they have double and triple checked it without seeing anything that would cause it.
    Like I said Netflix now works on all my iDevices (Ipad, Iphone 4, and Ipod Touch)
    So if you are still having problems trying using OpenDNS, www.opendns.com

    Thanks!
  • Babalooooo Level 1 Level 1 (0 points)
    How do you change the router DNS to openDNS ? Thanks.
  • Grimzly Level 1 Level 1 (0 points)
    I think this thread might be helpful to some.

    http://www.dd-wrt.com/phpBB2/viewtopic.php?t=77831&postdays=0&postorder=asc&star t=0

    Someone mentions "Netflix is poorly configured and the router was detecting a DNS-rebind attack, recently added to both OpenWrt and DD-WRT"

    I was personally affected by this and wasted 5 hours figuring it out. Downgrading my dd-wrt firmware resolved the issue.

    Anyone from Apple reading this thread should contact Netflix and have them look into this DNS issue.
  • Grimzly Level 1 Level 1 (0 points)
    Using openDNS is simply changing your primary and secondary DNS server IPs to those listed on http://www.opendns.com/

    208.67.222.222
    208.67.220.220

    You can also use Google's DNS servers which are:

    8.8.8.8
    8.8.4.4

    http://code.google.com/speed/public-dns/
  • Babalooooo Level 1 Level 1 (0 points)
    Changing the DNS finally makes Netflix work . Thanks!
  • figleef Level 1 Level 1 (10 points)

    I found this post when I had a simiar problem with Netflix. It would say "preparing" and then my iPad 2 was unable to connect. I went through the Netflix website troubleshooting guide and it told me I needed to install Microsoft Silverlight . . .

     

    Because Apple Support was closed (it was late at night) I decided to work on it myself. I had lent my iPad 2 (NEVER DO THIS!!!) to a friend and he was fascinated by the Netflix App.

     

    He looked at about 5 or 6 different movies - watched maybe 5 minutes of each. So when I went into my Queue page and clicked on "Show all INSTANT activity" the top five movies had been watched for just a few minutes each. I figured that MAYBE it was trying to 'resume' all these selections.

     

    So I clicked on each movie my friend had 'sampled' (ON MY COMPUTER, NOT ON MY iPad as I couldn't get ANYTHING to play on my iPad) and let the movie start and then use the slider bar to fast forward to the end - watching the last 15 seconds so that it would say "You have just finished watching . . . ".

     

    I did that for EACH of the five partically viewed movies.

     

    And it worked! I was able to go back on my iPad and watch a movie!!!!

     

    I am just adding this one solution in case other people lend their iPad and someone goes bananas with the Netflix App. It's not a particularly scientific fix but hey, it worked!!!

  • ShaunZimmerman Level 1 Level 1 (0 points)

    You'll probably think I'm crazy, but here is what fixed the problem for me - I found that under my preferences, the time and date were WAY off from the actual date.  I reset the time and date to current and it worked fine.  Hope this helps!  Thanks!

  • Danc3r99 Level 1 Level 1 (0 points)

    I have wifi ipad. Unable to play movies or programmes. Keep getting error message saying 'unable to play this movie. Please try again later'. Have been trying for months. There was one exception...one movie played right through to he last ten minutes and then I think I may have had to pause it but it would not play last ten minutes no matter what I did..even closing app and reloading. Tried resetting ipad. Reloading the app. Everything I can think of.

     

    Incidentally had same issue with the market competitor but do not have problems with iplayer etc.

     

    Has anyone found a solution to this yet?

  • figleef Level 1 Level 1 (10 points)

    Are you in the UK? Are you trying Netflix UK or Netflix US? Do you have a pretty robust wifi connection? IF you are in the UK I read that a lot of US films/TV shows are not yet available in the UK so it might be that every thing you pick is unavailable. Try something British and see if that plays. Are you paying the monthly fee? If iPlayer works, it is likely NOT the iPad. More info please?