Skip navigation

Wi-Fi Signal Strength Icon Not Showing - But Have Connectivity

42431 Views 26 Replies Latest reply: Sep 24, 2013 2:24 AM by Jp0502 RSS
1 2 Previous Next
mettis_software Level 1 Level 1 (0 points)
Currently Being Moderated
Jun 29, 2010 7:21 AM
I am experiencing a strange problem that just started today. The Wi-Fi strength meter which should display next to the iPad "title" text, is no longer there. This happens even though I HAVE Wi-Fi access (can surf no problem).

I first noticed this after, after I created an Ad-Hoc network (Windows 7), connected to it via the iPad, and then proceeded to shut it down, and then clicked on "Forget This Network" on the iPad. Now it does not matter which network I connect to, the strength icon is not displayed.

I have already tried rebooting the iPad, and clearing all network settings (General / Reset / Reset Network Settings).

I really want to avoid doing a full firmware install. Any suggestions?
ipad, Other OS
  • B0b Level 2 Level 2 (245 points)
    Do you see the samething when inside the settings app when looking at the wifi tab?
    pb-G3/500 Pismo/Wallstreet/9600/Newer CPU/PB-G4TI2, Mac OS 9.2.x
  • Nick Collingridge Level 1 Level 1 (75 points)
    This is very weird, because I have just started experiencing exactly the same thing, and on the same day too. My iPad 3G has been functioning perfectly up to now, but all of a sudden the Wifi signal strength icon is not there, just the 3G icon.

    Following a bit of playing around here are some further points:

    1. If you switch on Airplane mode then both 3G and WiFi switch off. You can then enable WiFi separately but although apparently it is switched on (and connected to a network as indicated by the tick in the settings pane), there is no connectivity. If you open Safari and try and access a website a message comes up saying "Safari cannot open the page because it is not connected to the internet". The wifi signal strength icon does unreliably appear (sometimes there, sometimes not), but even when it is present there is still no connectivity.

    2. If you switch Airplane mode off in Settings then at first the wifi icon is visible but pretty soon it disappears and you get the 3G icon back in its place. Internet connectivity does work but it is not clear which interface is active - in Settings there is a tick alongside the WiFi network indicating that it is active but the icon does not reflect this.

    I suspect that this is a display error, but i have no way of knowing for certain. What is weird is that this suddenly happened for no apparent reason. It was working perfectly then all of a sudden this happened, and at the exact same time as reported here by the OP.

    Does anyone know how to reset this aspect of the iPad?

    Message was edited by: Nick Collingridge
    Mac OS X (10.4)
  • Nick Collingridge Level 1 Level 1 (75 points)
    The symptoms were IMHO somewhat misleading, but I discovered where the problem lay for my iPad. What gave it away was that my iPhone started playing up as well, so I probed a little deeper and found that they both had self-assigned IP addresses. Then I connected the fact that I had changed my router the other day and in the changeover from one router to its replacement I had switched the DHCP server off on the new router (so as not to screw up the network while both routers were present on the network) and then forgotten to switch it back on when I had removed the original router. This change was not coincident with the problem occurring, but of course it took a while for the leases to expire. That is why the iPhone kept going for a while after the iPad stopped working. So probably a red herring for anyone else, but it is worth looking into your device's IP settings to see if it has a valid IP address within the correct subnet.
    Mac OS X (10.4)
  • hodges69 Level 1 Level 1 (0 points)
    My I Pad is doing...and has been doing the same thing for quite a while..The weird thing is that after 11 PM...the icon shows anywhere from 2-3 bars...and then might totally disappear once more.
    However,even with a no bar icon..i still am experiencing no wifi drop outs or connectivity probs..
    Could this be a software glitch?
    ma, Mac OS X (10.5.1)
  • SoHailiDol Level 1 Level 1 (0 points)
    Same problem here and This weird problem with my iPad still exists, I almost tried any combination of places and wi fi networks and I found absolutely no patterns here! The indicator bars are totally disapeared! Aliens?
    iPad WiFi 32GB, iPhone OS 3.1.3, MacBook 13" Black Core Duo, Powerbook 17" 1.5Ghz PPC
  • HumusKing Level 1 Level 1 (0 points)
    I think I may have cracked it.
    I had the same problem,and all I did was reset the wifi settings.
    1.Settings
    2.General
    3.Reset(at the bottom)
    4.Reset network settings

    You will have to reconnect to your wifi network.
    Good Luck
    Jonathan
    Samsung, Windows 7
  • ssandtl Level 1 Level 1 (0 points)
    I had the same problem with my iPod Touch, that just started today.

    The re-set seemed to work.

    Now as an after though to performing the re-set, does this mean that all the other WiFi sites that have registered the password into my Touch have been lost?
    iPod Touch 32 Gig Second Generation, iOS 4
  • worf63 Level 1 Level 1 (0 points)

    Yes it will, rather than a total reset, try the 'forget this network' setting. It worked for as I had lost the wifi icon for the hotel wifi I was on, and I did not have to re-enter all my other network settings, just the one I was on. It seems this problem only comes up  in public wifi places, such as hotels etc...hope that helps.

  • noreen2757 Level 1 Level 1 (0 points)

    I tried turning on airplane mode

    Then wifi turns off

    Turn wifi back on and airplane mode off

    Then the wifi icon appeared

    It worked for me

     

    Hope this helps you!

  • Mad-Fragger Level 1 Level 1 (0 points)

    I never encountered this problem until after I upgraded to iOS 5.  Almost immediately after upgrading, I encountered the problem.  On my iPad the symptom is the WiFi icon, in the top left, changes to a 3G icon.  However, it's clearly using the WiFi connection.  I know this because of the speed it's downloading a magazine.  3G isn't this fast.

  • CaryDoggyMom Level 1 Level 1 (0 points)

    I had a similar problem:  No icon, but no connectivity, even though my home network was showing in Settings as the selected network.  It was as if my iPad "knew" the home network was there, but couldn't connect to it.  (All the DHCP settings fields were empty.)

     

    I first tried syncing the iPad.  No good.  Then I tried "Reset Network Settings."  No good.  Then I tried "Forget This Network."  Voila! 

     

    I'm not sure what the heck was going on here.  This is an "original" iPad, about a year old, and it has never behaved this way before.

     

    If you have same problem, read all these posts and don't give up the ship!

     

    And thanks to all the community members who offered such good advice!

  • MatloobHussain Level 1 Level 1 (0 points)

    I had same issue with iPhone, but sorted

    First restart you iphone/ipad then Go to

    Setting then

    Wi-Fi then

    Select your network

    and change your IP address to DHCP option

     

    I hope then It will works.......

     

    Thanks

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.