Previous 1 2 3 4 Next 52 Replies Latest reply: Nov 28, 2010 2:42 AM by Basexperience
cjovejo Level 1 Level 1
GPS working fine before upgrade. Now neither google maps nor tomtom can find a sattelite. I appears that the OS and the GPS receiver can't communicate. Did restore w/ backup several times to no avail. Then did hard reset - no success either. According to forums on other Navigation app sites many people are having this problem. Anyone else find a solution other than the hard reset (which appears to work for some), resetting restrictions, and turning off 3G? Only solution that I see now is to downgrade to OS3.1.3.

3G, iOS 4, GPS
  • zover Level 1 Level 1
    Same problem with my iPhone 3GS 32gb.
    Upgraded to iOS4, since then I never had been able to get a GPS signal.

    Navigon, runKeeper, Google Maps, timetable apps, none of them can give my any location since the upgrade.

    Anyone found the solution so far, please help?
  • Yvonne Douglas Level 1 Level 1
    I am getting satellites, but the accuracy is terrible. Sounds like this feature was not regression tested.
  • sirfaba Level 3 Level 3
    Hi, sounds like you may have corrupt software.

    cjovejo wrote:
    Did restore w/ backup several times to no avail.

    Try a restore but this time try restoring to factory settings. When you do a restore from previous backup you are just putting your old software (which could be corrupt) back on the phone.
  • The.Todd Level 1 Level 1
    Nope. I've restored without backup 4 times and the GPS still doesn't work. It worked fine on 3.1.3.

    This is another serious issue that must be addressed.
  • rasselin Level 1 Level 1
    I agree. Right after upgrading to iOS4, Navigon was not able to get a good enough GPS fix to enable navigation. I tried the full restore, but to no avail. GPS accuracy just as bad as before. I've used Google Maps and it seems to work (although I'm not sure of the GPS accuracy), but I'd like to get the navigation software I paid money for working again.

    Message was edited by: rasselin
  • unixgal Level 1 Level 1
    I had been using my old 3GS for Geocaching without any issues until I recently had to switch to a spare 32gb 3GS recently. The GPS is horribly off and some of the "fixes" I've found online have helped a bit, but it is still unusable where accuracy is needed.

    Just upgraded to IOS 4.0.1 this morning and no improvement.
  • screth Level 1 Level 1
    Me too. Mine was working fine on a 16GB 3GS until I upgraded to 4.0. I also downgraded to 3.1.3 and it didn't work then either, even with a clean install. The worst part is I just moved across the country and having no gps really ***** in a new area!
  • javatoid Level 3 Level 3
    Mac OS X
    rasselin wrote:
    I agree. Right after upgrading to iOS4, Navigon was not able to get a good enough GPS fix to enable navigation...

    Ouch, you're right. It was working fine before the iOS 4 upgrade, but now it's close to a mile off in identifying my location.

    Between this, the lost wi-fi, and the battery life... I really wish I hadn't "upgraded."
  • layz51 Level 1 Level 1
    Just realized I have the same issue. At first I thought it was the heavy cloud cover yesterday, but today was very clear and same problem. Very frustrating when traveling and thought there wasn't any reason to carry around maps anymore. It's definitely in issue between the gps and 3G. If I turned off the 3G it was more accurate but of course to slow to use as a navi system.
  • dr.l Level 1 Level 1
    I tried turn on the wifi all the time and it seems that fix the problem (tomorrow I will try it in movement, now i am at home) Try and tell.
  • robin010 Level 1 Level 1
    Same problem with my iPhone 3GS 32gb.
    Upgraded to iOS4, since then I never had been able to get a GPS signal.
    did a full erase, upgraded to 4.01 no GPS on the iphone.
    GPS in combination with Tom Tom Iphone car bracket no problem (the bracket has its own build in gps receiver)
  • gerardleb Level 1 Level 1
    Same problem with Tomtom (+car kit) since I upgraded to iOS4. So, my navigator is now useless.

    And nobody in Apple to help customers in distress. Communication is for shareholders, not for these stupid guys buying (expensive) Apple hardware, not to mention the quality (???) of iOS4.
  • Adam Albright Level 1 Level 1
    Same problem here I noticed it first because as soon as I updated 4square stopped being able to locate where I was with any accuracy (stuff at the top of the list was pretty far away, and I always have to manually search to find the name of the place where I actually am)

    A trip with Navigon yesterday confirmed that it's the GPS lock - it seems to figure out where I am in about the same amount of time as before, but as soon as I start going, it's frozen at 0mph and endlessly recalculating, periodically interjecting with a very wrong location and urgently saying to do a U-turn, and then momentarily figuring things out before losing me again. It used to do tolerably well before the upgrade (maybe not as well as my $40 dedicated GPS unit, but relatively OK), but it's unusable now.
  • sskunky Level 1 Level 1
    I'm getting the same problem? I thought I was going mad but after finding this discussion I now realise it's not just me..... All my other GPS apps work but aren't that accurate since installing OS4.....
    Has anyone found a fix for this yet?
    Surely someone from Apple must read these? Can we get an answer please.
Previous 1 2 3 4 Next