Previous 1 2 3 Next 264 Replies Latest reply: Jan 11, 2016 5:14 PM by Ninebris Branched to a new discussion.
twosheds55 Level 1 (0 points)
My iPhone won't log onto my home or work WiFi. It recognizes them and I have put in the correct passwords but I just get an alert saying "Unable to join the network...".

I can't find any info on this. Any clues?

The phone connects via 3G

PowerBook G4, iPhone
  • yooperchick Level 1 (5 points)
    I too just started having this problem. Been on the phone with ATT for hours. Here is what I tried, maybe will work for you. Did NOT work for me, mine still not working. Phone finds WiFi, but says it can't connect. I get the same message you are, at all networks, not just at home.
    Tried "forget this network" Not only didn't work, doesn't ever show up anymore to forget.
    Finds networks, but have full black bars, not blue, won't accept password
    Airline mode is OFF
    Macbook connects to wifi at home just fine. Phone won't connect to ANY WiFi anywhere, open or otherwise.
    Tried entering network into "other," still won't accept.
    Under "settings," "general", then "reset": tried reset network settings, and reset ALL settings. Nada
    Tried syncing to macbook through itunes, the RESTORE, which sets it back to original settings. ATT said this would determine if it was a hardware or software problem. Tech guy said to try it before resyncing with saved data. Nada. Still didn't work. Thus not a software problem, must be hardware.
    Hope you find answer, I have no other options than to find an Apple store, about 6 hours away.
  • Neil Baltus Level 1 (5 points)
    I am also having this issue with my iPhone 4 after upgrading to 4.1. It says I am connected under the wifi settings, but only shows as 3g connection. Tried soft and hard reboots - - nothing. Reset of network - - nothing.
  • Neil Baltus Level 1 (5 points)
    ok - - got it to work. Under Settings- General - Network, I turned off "Enable 3G", waited a few seconds and wifi came on. I turned on the "Enable 3G" and it still kept my wifi connection.
    Hope this helps!
  • Neil Baltus Level 1 (5 points)
    Now I'm getting intermittent connection to wifi. Seems like when I enter the network page under settings, wifi comes on. When i exit the page, wifi drops off after a minute. Definitely seems like a software issue to me.
  • Neil Baltus Level 1 (5 points)
    UPDATE: I went into my router's security which is set to WPA2, and re-set it to WPA2, changed the password, removed the network from my iphone and then reselected it with the new password. That seems to have fix the issue.
  • alvincho Level 1 (0 points)
    I found my iPhone 4 can't connect to any WiFi network with WEP security setting. But it can connect to those without security setting. If I want to a WiFi router with WEP, I will get a 169.254.. address which means can't connect to DHCP server...
  • Ellen Goldin Level 1 (0 points)
    at first, lack of connection was intermitent. it then became constant. iphone 4 was seeing the network (name) itself but not seeing any of the dhcp addresses. all other laptops, non-iphone 4, and tivo were just fine w/the network. another clue was that iphone 4 connected to neighbors' wifi and other networks. i tried everything everyone below has tried. what finally worked for me was rebooting modem, router and airport. dhcp settings are back and all is well.
  • mjmurphy61 Level 1 (0 points)
    I too cannot connect to wifi with iphone 3g running 4.1. Was fine until upgrade. I have tried everything. I am giving up and waiting for another upgrade. Hopefully the engineers are aware of it. I have been searching around the net for a fix and have found countless people with the same weird problem. It connects but then disconnects immediately as soon as you actually try to access internet data - over and over again, connect, disconnect... Yikes.
  • theaardvarkdotcom Level 1 (0 points)
    Same/similar problem on my 3Gs. I upgraded from 4.01 to 4.1 and now my 3Gs has no WiFi!. It see's the wifi, will connect to it, but never gets an IP address and the wifi symbol never shows up on the top left of the phone. I've restored from backup, as well as reset the phone to factory defaults, still no wifi.

    Apple: get us a fix for what you broke!
  • Neil Baltus Level 1 (5 points)
    Try rebooting your router, or re- setting the security of the router. Also, see if there is a firmware upgrade available for the router.

    Re-setting of the router security (WPA2 with new password) worked for me. A simple reboot of the router worked for a few others.
  • Metalforever909 Level 1 (0 points)
    I've also been having the problem with my iPhone 3G. I'm connected to the WiFi, my IP, DNS, Gateway, etc., are all correct, yet when ever I try accessing Safari, or applications (i.e. TextPlus4, TextPlus Ad-Free), I always get the, either, "Server not Responding" error or "Requires a valid internet connection." Weird thing is, all the computers, and my mother's iPhone 3Gs, are able to connect to the WiFi just fine. I tried Restoring, and resetting my network settings, but that didn't work!
  • theaardvarkdotcom Level 1 (0 points)
    Thanks, but the problem is with the phone, not the router or anything else.
  • Neil Baltus Level 1 (5 points)
    Ok - but... I had the exact same issue as you, and I was able to correct it by re- doing the wireless security of my router.
  • Metalforever909 Level 1 (0 points)
    There isn't any security on my router.
Previous 1 2 3 Next