Previous 1 12 13 14 15 16 Next 264 Replies Latest reply: Jan 11, 2016 5:14 PM by Ninebris Go to original post Branched to a new discussion.
  • dhogan8 Level 1 Level 1

    9 months later...I was having the same problem with my 4s connecting to my wireless network. Upgraded the firmware on my router as I saw this being recommended in multiple forums. When that didn't do the trick, your suggestion worked like a charm.



  • sfrey000 Level 1 Level 1

    I recently had that sort of problem. There are so many variables that I wil not say that this is the fix-all solution for it though. So, I had a comcast supplied router/modem. All of my devices except my iphone 4s and my wife's Lucid 2 could connect to it. I dabbled around a lot on Internet forums, and then I finally experimented with changing the encryption. No sooner than I did this was I able to finally connect. I changed the encryption from WPA 2 to WPA, I hear that WEP is very insecure. I think that this problem is specific to this comcast router/modem (maybe other models, too). The reason I say this is because I have been able to connect my iphone 4s to other routers broadcasting in WPA 2 encryption. If this didn't work for you, then good luck. I will say, though, that you should eliminate as many variables as possible so that you can isolate the problem and follow the hierarchy in doing so. In other words, start with the device, make sure that it is working properly. From there, move to your router, then to the modem (if it's separate) and then check with the service provider. I'm not trying to patronize, but these things/problems can be very hard to distinguish.

  • ianabbott63 Level 1 Level 1

    Apologies if this covers old ground, I haven't spent the time to review all replies. The first few posts seemed to discuss exactly the same syptoms I experienced:


    - Loss of wifi connection without reason or warning.

    - "Unable to connect to wifi network" when in range and with full signal.

    - Attempt to connect to wifi network manually, responded with "Cannot scan for networks".

    - Reboot did not rectify.

    - Restore network settings did not rectify.

    - Reboot wireless internet router did not rectify.

    - Install/ update router firmware did not rectify.


    - Turning on airplane mode, rebooting phone, and turning off airplane mode did temporarily restore the connection to the wifi, but only for a matter of minutes.


    I continued to read responses on this and other threads that suggested a hardware fault, perhaps overheating, and under warranty Apple would replace it, which is good but not ideal, especially if anyone has exceeded the 1 year warranty time period.


    But in a last ditch effort, I decided to go back to the good old days, and turned my phone off, over night, while on charge. Having turned it on early this morning, it has reconnected to my wifi and maintained the connection so far. I will repeat the process over the next few days and see if my wifi connectivity improves as a result. Turning the phone off regularly, over night, might over come the hardware limitation. I'll report back if I continue to see positive results from turning the phone off.

  • Anti1460 Level 1 Level 1

    i just fixed this problem on my gf's dad's iphone 4.  all we did was forget the network you are trying to join, and then reconnect to it.  worked right away

  • dimbar Level 1 Level 1

    any one help please my i pone 4 the wifi worked fine until a couple of days ago now it wont find a network unless you put it fight next to the router but if you move 6 feet away away it loses it untill you go back to the router

    can anyone help please

  • Stevo66 Level 1 Level 1


    Excellent. Fixed my issue after trying many suggestions.

    Thanks heaps.




    I'm not sure which one of the following did the trick but i did all the various other solutions to no avail and then this one worked. My issue was that my iphone 4 running ios 5.0.1 would connect to any network except my home network which using an airport express base station i did:


    1. If you go into setting, then go to general, then go to reset, then select reset network settings it will fix the problem.
    2. restart both the airport base and the express to reset the whole system


    problem solved...for now

  • gregfromoakland Level 1 Level 1

    Fixed my iPhone to connect to WiFi.


    Reset network settings on iPhone.


    At Airport extreme router w/ Airport Utility: Wireless Tab/ manualy changed to "802.11n only (2.4Ghz)" *And* Channel 1, 2, 8, or 9... seems like any channel But "Automatic", but I didn't test them all...

  • dariofrombrunswick Level 1 Level 1

    have you opened your iphone and replaced any parts recently?

  • dimbar Level 1 Level 1

    no i have not opened the phone to replace parts it just stopped working

  • Lilmissangel Level 1 Level 1

    I have the same problem but when I go to forget this network it's not there. I have tried all of what you lot have done and still nothing the only thing I haven't tried is factory reset as now my iPhone 4S cos up with an error when connected to iTunes! So I can't back up my iPhone or sync it!

  • Lawrence Finch Level 8 Level 8
    Mac OS X

    What is the error code?

  • mowbs1 Level 1 Level 1

    hi,now ive had this wifi for a few days now and it was getting on my tits!!!!!! been through all the comments ppl have left and nothing ive been trying and getting no were UNTIL i turnedof my mobile (cellular) data off and my wifi seems to be holding.....if u dont hear from me again then its worked fine..hope this is some help to others.

  • Lilmissangel Level 1 Level 1

    It don't have a error code

  • Lawrence Finch Level 8 Level 8
    Mac OS X

    You said an error came up when you connect it to iTunes. What was the error? There are hundreds of errors, and each one means something different.

  • Lilmissangel Level 1 Level 1

    All I get is ITunes can not back up this iPhone 'marishas iphone because there is an error' that's it!!!

Previous 1 12 13 14 15 16 Next