Previous 1 2 3 4 5 6 Next 262 Replies Latest reply: Oct 9, 2015 6:31 PM by fstop16 Go to original post Branched to a new discussion.
  • chropro Level 1 (0 points)

    I'm not sure which one of the following did the trick but i did all the various other solutions to no avail and then this one worked. My issue was that my iphone 4 running ios 5.0.1 would connect to any network except my home network which using an airport express base station i did:


    1. If you go into setting, then go to general, then go to reset, then select reset network settings it will fix the problem.
    2. restart both the airport base and the express to reset the whole system


    problem solved...for now



  • Stg531 Level 1 (0 points)

    Okay Chropo, I don't know you, but I'm loving on you right now.  After spending the ENTIRE day working on this with various people including returning from the Apple store just moments ago, yours did the trick.  I had reset the Network earlier today, but not at the same time as the router. 


    Thank you so much...and yes, for now.

  • chropro Level 1 (0 points)

    Stg531 wrote:


    Okay Chropo, I don't know you, but I'm loving on you right now.  After spending the ENTIRE day working on this with various people including returning from the Apple store just moments ago, yours did the trick.  I had reset the Network earlier today, but not at the same time as the router. 


    Thank you so much...and yes, for now.

    it always feels good to know that i'm not wasting my time. i google for the answer of everything and anything and when i don't find the proper solution i do my best to figure it out. most of the time i share this solution on the web and get little to no credit, it's nice to hear my good deed of sharing doesn't go unoticed.

  • TracyMT Level 1 (0 points)

    I am loving this post, too!  I have been messing with this problem for a week, tearing my hair out.  I had also reset the network several times, and reset the router several times, but never together.  This was the ticket and I am soooo grateful that you posted this tip!


    Many thanks!

  • Kimzie182 Level 1 (0 points)

    I had this problem, I just 'forgot' the network, searched it again, went into my broadband properties > selected wapn2, and used that password to connect, works fine now!

  • Dovakiin Level 1 (0 points)

    I hope this helps someone.  I have been having these problems off and on with my iphone 4S.  I have to every now and then reboot my modem to get it to connect again.  It usually okay for a few weeks, then may start dropping the signal again.  I have been living with it, with minimal intrusion to my life.

    Today I had the unusual process described here and elsewhere of the wifi connecting my phone and dropping off every 5-10 seconds -- connect, drop, connect, drop ...

    This was new.  I foolishly tried several things (resets, etc.) and one of the things I did was "Forget this network" under the settings--> wifi --> then tapping the blue arrow.  I thought I might just reconnect to it with the password like when I delete a network on my macbook pro.  That not only did not work (what ended up working was rebooting , ie. unplugging and plugging back in, my router [Netgear N600] rather than my modem)  but now my iphone would never "remember" my wifi connection again!  I could now connect to it by typing in the password and it would be connected until I put the phone to sleep, but when I brought it up again it was back on 4G.  I would have to enter my password every single time I turned the phone off to reconnect to my home's wifi, rather than it automatically connecting!  Annoying !!  The "forget this network" button was no longer even available, telling me that the phone has permanently "forgot" it and would never "learn" or "remeber" it again.  After hours of scouring these discussion groups and google, I found this thread the most useful, but still not applicable to me.  (BTW, Resetting network settings as is suggested did NOT fix the issue) What I ended up doing that worked was alluded to by some posts here -- I connected to my router via it's admin website : for mine, and after messing around with some settings, which I was totally clueless what I was doing, really all it it was to rename the network.  I added a number "2" after the name I had chosen when I set the thing up a couple years ago, and modified the password for good measure, and viola! The phone now was able to "learn" the connection and not recognize it as one I had told it to "forget"  I thought there was going to be a requirement to change a bunch of ID numbers -- MAC, DNS, IP, or one of those other numerous strings of numbers that identify an connection.  But no, just changing the name and password did it and I'm back in business.


    Lessons learned:

    1. Don't press "forget this network" unless you really intend on never wanting to automatically connect to it ever again.

    2.  If you did #1, changing the name of the network is really not that hard -- if I can do it anyone can.

    3. Apple support persons and experts, geniuses, etc. are no match for a tenacious guy with a willingness to think things through for 6 hours. I am kind of disappointed that none of the "experts" seemed to have a clue ...

  • Boozad Level 1 (0 points)

    I've started experiencing a problem very similar to some the past two days, bearing in my mind my wifi has been working perfectly for months without any issue. From yesterday morning my wifi on my iPhone 4 would be connected but not do anything, web pages would just hang and time out as would all apps, email client etc. All the time my wifi was saying it was connected and at full strength but it just wouldn't download any information at all.

    I found that turning wifi off and back on again would get it to work for a minute or two, but then it would just start hanging again.


    I've tried quite a few of the suggestions in this thread but none of them seem to work. I'm about to try renaming my network as suggested above to see if that works. My setup is listed below.




    Netgear Virgin Media Super Hub. (Details linked below) LE_ID=345044&CURRENT_CMD=SEARCH&CONFIGURATION=1002&PARTITION_ID=1&USERTYPE=1&LAN GUAGE=en&COUNTY=us&VM_CUSTOMER_TYPE=Cable

    Software Version: V5.5.2R30

    Hardware Version: 2.00




    iOS 5.1.1

  • alessandrofromvenice Level 1 (0 points)

    Hi guys..........from Venice, Italy.


    I also have the same problem, my Iphone is died ...since i upgraded my 3GS to iOS 5.1.1 i lost my wifi connectivity and it says "no wifi" i can't even open it and this is so worring . I spent 2 hours continiously restoring it but theres no change and it still says "no wifi" . Resolve this problem as soon as possible APPLE . Thanks.


  • Dovakiin Level 1 (0 points)

    I don't know if you came up with a solution, buy let me say this: The problem you're describing sounds like what I was originally having and was usually fixed by actually rebooting (in my case just unplugging and replugging in) my modem.  Since you are showing a wifi signal on the iphone, it is likely the modem part that is the issue rather than the wireless router.  In my most recent case, I was seeing the wifi signal on the iphone drop off and disappear and just be replaced with the 4G symbol.  All other devices in the home were using the wifi fine, but my iphone couldn't "see" a wireless signal.  But I have modem and wireless router separate as 2 separate boxes, and it looks like yours are one in the same in that Super Hub you have. 


    In retrospect I do wonder if the issue with the modem not pushing through data through the existing wifi signal has to do with online gaming that I have been doing.  It seemed like the issue would seem to happen after a long online gaming session (PS3 connected to the same wifi signal)  A previous poster said something about this possibility.  I don't know.  If there are any others who have noticed this issue pop up relating to wireless console gaming, I would be curious.

  • Lawrence Finch Level 7 (33,995 points)

    Boozad wrote:



    I've tried quite a few of the suggestions in this thread but none of them seem to work. I'm about to try renaming my network as suggested above to see if that works. My setup is listed below.



    Have you tried turning the router off for 30 seconds or so? I know you may have tried this, because it is one of the suggestions in the thread, but as you didn't define what "quite a few" means we would have no way of know what you have tried and what you haven't.

  • Lawrence Finch Level 7 (33,995 points)

    alessandrofromvenice wrote:


    Resolve this problem as soon as possible APPLE .

    Apple doesn't hear you in this user to user forum. So you just wasted a message. Based on the small amount of information you have provided it's likely that the wifi chip in your phone has failed. A test of this hypothesis is check BlueTooth; if it has stopped working also that's the most likely answer, as wifi and bluetooth use the same chip. But this tip might help:

  • Boozad Level 1 (0 points)

    Dovakiin, LF: I haven't actually tried powering down the hub (modem and router in one) yet. I've reset it through the settings and a hard reset, but not powered down and back up again. I'll give it a go and let you know how it works out.

  • Boozad Level 1 (0 points)

    Lawrence Finch, Dovakiin, I've tried your suggestion of powering down the modem/router this morning, left it for a minute or so then powered back up. So far (about 5 minutes or so) it seems to have solved the issue. The WiFi wasn't holding for more than ten seconds before hanging, but now it seems to be running smoothly everywhere in the house. Hopefully it will be a permanent fix as it was really starting to annoy me that I couldn't solve it, I can't believe I didn't think of something so simple.


    A big thank you coming your way from me, that was very much appreciated lads. I'll update later today/tomorrow to let you know how the fix is holding up. Thanks once again.

  • Lawrence Finch Level 7 (33,995 points)

    My advice is from the general adage, "when in doubt, reboot". But the logic behind it comes from experience with many routers, which are, of course, computers with operating systems and applications. One of those applications is the DHCP daemon, the service that assigns IP addresses to devices when they initially connect. In every consumer market router that I have ever worked with the DHCP daemon eventually crashes, so newly connected devices request an IP address but don't get it. Computers that are more or less fixed aren't affected, because they already have an IP address. But mobile devices, which may be on serveral networks during the day and thus change IP addresses several times need an address every time they connect, and, if the DHCP daemon has crashed, cannot get one. The test for this is to look at the settings for the network on the phone; if the IP address begins with 169.254 you know that the router failed to assign an IP address. Addresses in that range are self-assigned so the device can participate in an ad hoc (peer-to-peer) network.


    This will probably happen again in a few weeks, and the solution will again be to reboot the router.

  • Boozad Level 1 (0 points)

    Very handy to know, much appreciated. I've always been pretty computer savvy but I'm pretty new to wireless as I never needed it before. But with a growing array of gadgets in the house that can do everything bar make you a coffee in the morning, I thought it was time to actually put both feet into the 21st century. The router threw me as everything else on the network was working fine, and it never occured to me that it was the only mobile device I had that wasn't working properly.


    Thanks again for your help mate, it's always refreshing to learn this way as opposed to 'faceless' Googling time and time again.

Previous 1 2 3 4 5 6 Next