Previous 1 2 3 Next 194 Replies Latest reply: Feb 4, 2016 11:21 AM by computer dr
mayfi944 Level 1 (0 points)
I recently switch wireless service at home to At&t.

Since, my computer "connects" to my network, accepts my password, and shows full signal, but when I open Safari, or any other app that requires internet, I just get the "failed to open page because you are not connected to the internet" page.

My roommates connect to use our wireless network with their PC's just fine, and my Mac connects to other wireless service at school and work and works just fine.

I have been on the phone with At&t many times trying to troubleshoot and fix the problem. No success.

Apple charged me $49 to talk to them, with no success.

I HAVE ALREADY TRIED RESTARTING both my Mac and my router, I have reset the router, I have restored original settings in both Safari and my router, I have tried removing the security from our network in order to connect without a password, I have tried re-configuring the router to work with Macs....all no success.

I am very frustrated with the situation as I, like most people, require internet access for both school and work.

Any help, tips, or advice on the situation would be grateful.

Thank you.

MacBook, Mac OS X (10.5.8)
  • ~Bee Level 7 (31,425 points)
    Hi mayfi --

    Welcome to Apple Discussions!
    We're other Mac users here, asking questions and sharing solutions.

    You said: +My roommates connect to use our wireless network with their PC's just fine, and my Mac connects to other wireless service at school and work and works just fine.+

    So, there's something amiss in your network at home, eh???
    I've asked for more help for you . . . Hang in there!
  • andyBall_uk Level 7 (20,490 points)
    $49 ? - we'll do it for 1/2 that

    Let's start with System Preferences-Network... is airport at the top of the list on the left, with a green indicator, and says 'connected' - or does it say something else ?
  • Steve.B Level 1 (0 points)

    I have suffered the same problem after waking the imac from sleep mode, it seems to forget how to link with the web, I can see my wireless router in safari which tells me there isn't a problem with my network or internet connection. I've tried restarts and shutdowns then after a about 2 hours with no obvious outcome by checking settings etc., things return to normal as if nothing had gone wrong.
    It's happened twice in the last 24 hours, started up when I got in from work read emails etc. about 6pm left it to go to sleep 7.30, then woke it up 3 hours later. Spent 1.5 hours trying to figure out what went wrong before giving up and going to bed.
    This morning got up started machine 8.45am no problem with internet connection on safari and itunes. Put it to sleep at 10am and woke it 8.30pm up pressing the space bar with no connection again went through all the same procedures of checking and double checking settings. Then about 11pm it springs back to life enabling me to write this.

    I have no idea what stops and what starts the problem.

    (connection error's affected safari, mail, backup, firefox, intego-netupdate)
  • mayfi944 Level 1 (0 points)
    No, no green indicator.

    It's just read and says not connected...then when you go to connect it, it doesn't connect.

    When I try and do a network diagnostic on it, I go through all the steps with all the correct info provided and setup and at the end it still says cannot connect.
  • mayfi944 Level 1 (0 points)
    I thought it might be doing the same thing as the previous problem with it going to sleep and waking back up because mine use to that but it would only last a few minutes. Mine doesn't connect at all, not with mulitple reset, restarts, sleeping, waking, different times of the day, for almost two weeks now.
  • ~Bee Level 7 (31,425 points)
    mayfi --

    Was it originally set up for your school network?
    Or your Home network?

    When you select the Airport icon with the fan-shaped bars (which I have in my menu bar above)
    Does it have suggestions for which network to join?
  • haffajappa Level 1 (0 points)
    Same problem here.

    Full bars, but no internet connection (even after multiple start ups).
    Seems to happen mostly when I'm at the coffee shop using their wifi, but also periodically at home on my own modem.

    I have also tried using network diagnostics and assist and nothing is working - searched the internet and can't find any remedies there either.

    This is so frustrating.
  • Scott Mcdougall Level 2 (175 points)
    Not only do I have this problem with my 17" mac book pro, but i've seen many mac users experience the same problem.

    I have an iPhone 3Gs with OS4 on it and it will connect to any WIFI, but at the same location my mac book pro will not connect to the internet at all. the mac book pro will handshake with the wireless modem and give full signal indication but will never allow internet access.

    no matter how many restarts, or new location settings/create new location... nothing works.
  • databank Level 1 (0 points)
    same problem here!

    full bars wifi on the menu bar with a tick on my network but it just doesnt go onto the internet at all. Safari, Firefox, Messenger and skype, nothing works. While my iphone and another PC worked just fine.
    It happened a couple of time before with it going back to normal after a few minute. However, it's getting serious this time, it's been 3 days already. Tried the network diagnosis but didn't help.

    Really getting frustrated.
  • Sparksparadise Level 1 (0 points)

    Clearly there's a ton of us out here with the SAME PROBLEM. A month ago, I installed an ATT Microcell (VERY cool if you live in the country) and all was ok until about 2 weeks ago. I've spent so much time on this...I went through the same steps as Mayfi. I've tried EVERYTHING. Setup, reenter password, look online for help, reboot, restart, delete profile and start all over again.

    And I can't get online on anyone's wireless at this point. Not friends, not the coffee shop, NADA.

    As for the Apple no-support support, I can't afford to pay Apple a one time fee of $49 bucks. (BTW, Mayfi, I hope they didn't actually charge you since they didn't fix anything.) We all know that PCs suck but is Apple going to be as bad??? Funny that I've got 2 PCs, one on VPN, that's working fine. BUT THE APPLE IS DEAD IN THE WATER.

    Get with it, Apple Genius people. FIX THIS. You have a loyal following who needs YOUR HELP. Real help. Not just discussion boards full of people complaining about the SAME problem with no real solutions that I can find.

  • Rigelface Level 1 (5 points)
    Hey guys. I have one of the newest generation of Macbooks and started having this problem earlier this week with my school network.

    I just solved it (seemingly stupidly) and would like to offer my solution just in case it might help anyone.

    What I did was as follows:
    Open: System Preferences>>Network

    At the left, there should be a pane listing ways in which your computer connects to the internet (Ethernet, VPN, AirPort, etc.)

    At the bottom of this pane there are (+)(-)(cog) buttons that correspond to (add method)(remove method)(other options dropdown)

    Highlight: Airport and hit - to remove.
    Immediately hit + and choose AirPort (on mine it is default) for the interface type.
    Click: Create

    That somehow allowed my AirPort to fully connect again.

    This seems gimicky, but I do hope it helps some of you out! Don't know how long the renewed effect lasts as I just did it within the last few minutes.

    Message was edited by: Rigelface
  • Steven Lewis Level 1 (10 points)
    That worked! Thanks.

    Macbook Pro 10.5.8
  • Drk_Mtr Level 1 (0 points)
    I seem to be having the same or a similar problem. I just started to experience this issue about two days ago, but had to wait until today to call my ISP because of the holiday. They indicated that the problem was with my computer because my IP isn't reflecting the change from wireless to ethernet connection. Unfortunately, the fix detailed here didn't work for me. Any other suggestions? I'm currently using my phone as a modem to connect and even that is acting a bit dicey now. Thanks in advance.
  • Drk_Mtr Level 1 (0 points)
    I also seemed to stumble upon a solution myself. I turned my firewall off and was able to connect to the internet. My IP addresses for the various connections have now automatically reset. I hope that helps anyone else experiencing that same issue.
Previous 1 2 3 Next