Previous 1 2 3 4 Next 189 Replies Latest reply: Nov 14, 2015 5:11 PM by montaneejo Go to original post
  • baronesse Level 1 (5 points)
    I have a similiar problem. After installing 10.5.4 from a dvd the wireless connection didn´t work anymore. I tried any of the suggestions made in diverse forums( pref delete, airport delete, keychain new, resetting the router, changing channels, opening the network without a password, trying the assistant9 even rang up apple hotline but nothing worked. So finally i installed again 10.4.6: no problem. After that I reinstalled from the dvd, this time without deleting the old system prefs: no connection via wlan. ethernet works , the imacs, the other mac book, the iphone and the ipods we got have no problem either- only the one mb with leo. Any idea perhaps concerning some terminal issue?
  • simonsach Level 1 (0 points)
    Your solution is perfect - thanks a million!!!! Really thanks.
  • Litlhorn Level 1 (0 points)
    Me too Me Too!!
    My IMac Flat screen G4 is having trouble with it's reading of the wireless signal.. Every morning when I log on and try to open the Net, although I have full bars registering on my airport and it shows it is connected to the proper network, I get an error saying "Server not found." I have a pc sitting right next to it that logs on fine. The only way I have found around this is to unplug the modem and negear Router downstairs, and then replug and it seems to be fine until I shut down and then the next morning the same drill. Tried all the above mentioned Fixes and it seems to be something in the Way the Airport extreme card is reading the signal. Am at a loss and very frustrated with this. Does anyone know what is really going on with this since it seems to be happening to so many?
    Imac Mac OS X (10.5.8)
  • simonsach Level 1 (0 points)
    Hi I've been having this problem for weeks and its particularly frustrating because you can see that the wireless is picking up a signal but failing at the network settings stage.


    Go to system preferences
    On the top row click on security
    Click on firewall
    Highlight - Allow all incoming connections

    Internet now working! (hopefullly for you too)

    The other method here also worked for me once - the one about deleting and re-introducing Airport into your network settings.

    Hope one of thos works for you - it's been braining me!
  • nudavinci64 Level 1 (0 points)
    removing airport and adding it back in worked for me. nice trick
  • vinolynyc Level 1 (0 points)
    you can also check to see the the DNS settings in your Network Preferences are correct. i found 5 settings (numbers) in my list. the top two were the same as on my other mac - which is working fine - and they were grey. the bottom 3 were in black and did not match the other machine. i erased the bottom ones, applied the changes and everything now works properly.
  • its an addams Level 1 (0 points)
    I don't know if anyone will be helped by this, but the Macbook problems connecting to the internet are directly related to DNS issues. I discovered this after an upgrade to the OS X Lion preview.

    The symptoms are as follows: a macbook (pro, mini, etc) can get an IP address from a DHCP server on any given network, but can not connect to the internet, even though other computers on the same network have no issues. If this sounds familiar, read on.

    The problem is not related to 3rd party products, routers, Airport settings, locations or public vs private DNS servers, and you don't need to reset SMC or PRAM.

    You will need to use terminal and you DO NOT want to use disk utility to repair permissions.

    The most direct way to fix this is to copy the and files from an internet connected Mac into your /System/Library/LaunchDaemons directory.

    (You should know that it probably doesn't matter what version of OS X you have or the other Mac has, you just need the files.)

    Next you will need to change ownership of the files just copied (ex: chown root:wheel /System/Library/LaunchDaemons/ and chown root:wheel /System/Library/LaunchDaemons/

    Then, you will need to set correct permissions (ex: chmod -R 755 /System/Library/LaunchDaemons/ and chmod -R 755 /System/Library/LaunchDaemons/

    The last thing you'll want to do is to verify that the ownership of the files copied is set to system (and maybe wheel) using "Get Info." (Conversely, you can use ls -l /System/Library/LaunchDaemons/ to verify owner and permissions.)

    You should not have to restart to connect immediately to the internet.
  • conniemwilson87 Level 1 (0 points)

    Thank you thank you thank you rigelface. This actually worked! It's quite astonishing that in the nine months since you posted this people are STILL having this issue!!!

  • MeMatt Level 1 (0 points)

    I was having this problem at work but not home.  I fixed it by turning off File Sharing in the Sharing screen of Preferences.  I'm thinking that it's some sort of security thing with the company WiFi.  Now if I could figure out how to do the same for my iPhone4 I'd be all set...kind of maddening because a colleagues iPod Touch works fine.



  • Mich_Efro Level 1 (0 points)

    I've been having this same problem for almost a week now! Everything else in the house is able to connect to the internet wirelessly...PCs, iPhones, iPad, but my macbook won't connect. Removing and adding Airport worked for me temporarily but I've had to do it 5 times since yesterday and it doesn't even work every time. When I open network preferences Airport is green and says "connected", but I can't open any webpages or anything else. This is so frustrating because this happened out of the blue. I didn't touch any preferences or my router and modem, didn't update anything or install anything new, so I don't understand why this suddenly started happening!


    Any other solutions??

  • BDAqua Level 10 (121,630 points)

    Hi Mich,


    If nothing here works, you'd likely get more helpers in on it if you start a new question.


    Open Network Utility, see if you can Ping this IP...



  • Mich_Efro Level 1 (0 points)

    Thank you BDAqua. I actually JUST got off the phone with Apple tech support and they seemed to have fixed my problem (we'll see how long it lasts...). They first suggested removing and re-adding "airport" in network preferences, but i had already tried that and it wasn't working for me.


    For anyone else who's still having this problem, this is what I was told to do after that:


    Open Finder

    Click Macintosh HD, Library, Preferences, and then all the way at the bottom: System Configuration

    Drag the System Configuration folder into the trash and restart your computer

    Go to airport and reselect your network


    That did it for me!

  • visitor05 Level 1 (0 points)

    Time lost over this issue is painful for me. The first two weeks with Lion, Wi Fi was fine. Not even slow. That was both before and after installing the 10.7.1 update. Then one day I turn it on -- after the system's been set for a week with no installs etc., and boom can't get to internet. Power cycled a few times. Started some trouble shooting. Tried dubious stuff from the boards like pram and smc reset . . .


    I have tried everything, even calling.  And here's the kicker!!!!!!!!


    I can open Parallels, with WinXP simulated and go on the net with Firefox -- not cahced sites-- it's emptied on exit. I can do new searches etc. I've never done and the web responds.  Go over to Lion and Safari, Firefox, even SoftwareUpdate all complain. Then I use the apple network diagnostic -- all fine it says.


    So on this home wi fi, I have a PC, working with internet just fine. And I have a Mac running Tiger -- also working just fine with the internet.


    LION is clearly having issues. I just hope they figure it out for the next release -- and send me a cd or something, although I guess I could download a fix through parallels here and move it over and run it on the mac side.


    Anyhow, I'll add that I logged onto my router -- it sees my machine (which I figured since winxp on parallels inside the mac can get to the net), and its IP add and MAC add agree with what I have in Network Preferences. I opened terminal and I can ping my router. I checked security logs and found request, offer, ack,  nothing too fishy looking (time zone was set wrong though).


    Anyhow I thought at first I was just unhappy with iCal in Lion. Now I know a greater misery.


    AppleCare / customer service wanted to push me off to the ISP. But when I've got a mac on Tiger and a PC and a virtual machine within the troubled Lion machine that can all surf fresh pages, and I can connect to the router at 192.168.x.x and ping it, well, does that really say ISP problem?


    At least I don't buy beer via the internet

  • BDAqua Level 10 (121,630 points)

    Can you ping IPs out on the internet, but not URLs?


    Like, but not

  • visitor05 Level 1 (0 points)

    I can ping both IPs and URLs from terminal. Safari and Firefox status bars will say they're connected at certain points.  But neither ever bring up a page (have even waited 30 min.)


    I hadn't changed any browser settings when the trouble started, but I did check to make sure the method of connection is right, and even troubleshoot with manual vs. automatic vs. proxy settings in conjunction with my router.

Previous 1 2 3 4 Next