Previous 1 9 10 11 12 13 Next 183 Replies Latest reply: May 14, 2015 8:55 PM by Beradadisini Go to original post
  • laureetw Level 1 Level 1 (0 points)

    @Rigelface /

     

    Your post was the most helpful yet. I also found that going to the IP address and asking for it to be reset worked wonders.

    Thanks!

  • KB_Thailand Level 1 Level 1 (0 points)

    Ok, after reading ALL of this, and trying all of the solutions offered here, and many others from the web, I came up with a workaround for my machine.  NONE of the suggested fixes worked...deleting files, changing PW type in the router, manually assigning IP addresses, etc., etc., and in fact I *STILL* cannot login directly to my router, so this is STILL a HUGE issue!  If I try to hit the router directly, I still get the dreaded 'WiFi has no IP address' error and it self assigns. The last contact with the internet according to the logs was at 3:03 AM local time (GMT+7) this morning Mar 21, 2014, so it definitely was not something *I* did.  I looked for a log listing update installs, but could not find one, so I have no idea if an update caused the issue.  It worked fine for the last two years with no issues, so why did it suddenly quit working at 3:03 in the morning? A good question for Apple!

     

    My workaround: (definitely NOT a solution)

    I have a TimeMachine, and set it up to be a wireless base station.  Easy enough, but you have to watch the IP's.  It will probably assign an IP outside the range your router is set to.  My router, like many, is 192.168.1.1, so I changed the IP address of the TimeMachine to 192.168.1.2 from 169.something and assigned the network range from 192.168.1.3 to 192.168.1.200.  So after twelve hours of reading and trying many different things, always getting more and more frustrated, a half hour was what it took to make a workaround.  My MBP can now get on the internet!  WOO-HOO!

     

    However, it is scary how many people are having this issue, and it would behoove Apple to figure out what the REAL issue is and fix it!!!  I am pretty technically proficient, but I cannot imagine if my wife were trying to solve this problem!  It does not normally take me 12.5 hours to solve something, or figure out a workaround, which points to how nasty this issue is!

     

    KB

  • LiquidSmoke87 Level 1 Level 1 (0 points)

    Best way to fix the problem. Thanks! apple please fix this problem with the next update. Its more than frustrating.

  • Bladnoch Level 1 Level 1 (0 points)

    I've tried many different solution ideas for this problem, then came across your solution and it works. Cannot tell you how grateful I am - many, many thanks.

  • brighamanderson Level 1 Level 1 (0 points)

    awesome GwenFromNV this worked for me, but then i restarted the machine and now it doesnt work again. i checked the 8888 8844 dns thing and it was still there, so not sure what to do next

  • BDAqua Level 10 Level 10 (120,065 points)

    Hi, you might want to start a new topic to get the most helpers in on it & more directed to your situation.

     

    https://discussions.apple.com/community/mac_os/mac_os_x_v10.5_leopard?view=overv iew

  • xoAnna Level 1 Level 1 (0 points)

    Thanks KB_Thailand for your workaround. I, too, have/had the same dreadful "no IP address" issue when trying to connect to my network. My husband, who has a PC, has NO problems connecting whatsoever, whereas I have a MBP and have been nothing less than frustrated by this connectivity issue....proving that it's definitely a problem derived from Apple and not from the router nor my own fault.

     

    Anyway, your explained work-around helped me (which is why I can currently type and send this reply)!

    Big thanks!


  • KB_Thailand Level 1 Level 1 (0 points)

    Glad it helped you out xoAnna!  It is quite frustrating to have what is billed as a top tier product, that does not work!

     

    A month and a half later, I still cannot connect to my home router, and have had the same issue with WiFi hotspots at various locations, while others work just fine.  At home, I still use the connection through the Time Machine, which seems to work 100% of the time, while Windows and Linux boxes connect to the router just fine.  When out, if it will not connect, I just use my Samsung Note 10.1 to do whatever I need to do, as it never has issues with connecting to pretty much anything.

     

    APPLE-->THIS IS A HUGE ISSUE AND NEEDS TO BE FIXED!!  If you're going to claim to be a technology company, at least do things as well as your competition!

  • Brunetol Level 1 Level 1 (0 points)

    Did not work AT ALL. The problem I have makes no sense. It affects either Airport and my Ethernet connection. I have a MacBook Air Sept 2013 fully loaded with best options. Almost everytime it gets asleep, I lose my Airport connection, and get the stupid exclamation mark, with Preferences Network telling me my computer has no IP adress. And, after a while, sometimes a couple of minutes, sometimes more, it comes back, out of the blue. Exact same thing can happen with my Ethernet (through Thunderbolt) connection. Same stuff : "the cable is connected but your computer has no IP adress". Same thing : I gotta wait, between one and (rarely) 30 minutes before it comes back without me doing anything. It can happen everywhere, has nothing to do with the router or the network, slow, fast, whatever... What the **** is this ????

  • OniTheC4t Level 1 Level 1 (0 points)

    I tried all the precedent solutions but nothing worked for me.

    So, I went in my router panel and i switched the router's channel from 6 to 1, this solved my problem, hope can solve yours.

  • eges Level 1 Level 1 (0 points)

    Thanks bsorense,

    You saved me...

     

    This is what he suggested:

    I finally got this MacBook back on by changing the computer name:  System Preferences - Sharing - Computer name.

  • jarabian Level 1 Level 1 (0 points)

    Hey, your solution worked great.

    Thanks for the help.

    Jack

  • mohammad nedae Level 1 Level 1 (0 points)

    attention:.... it might be cisco anyconnect app problems.i have install cisco on my mac pro and after 3 day my internet gone.u can solve this problem by uninstalling from your mac.

  • ieymah Level 1 Level 1 (0 points)

    Can't access internet ?

     

    it happened to me..

    ethernet is green but no internet connection

    has tried to diagnostic , on off firewall n etc still no worked...

    just try this

    1) empty trash

    2) Restart laptop

    and it work's (^_^)/

  • tna_ng Level 1 Level 1 (0 points)

    hey! ive got the solution (one that works for me, but i livenin canadanso it might work differently)

     

    i actually had that problem too but it isnt because of the mac its due to your wifi being weak.

    what you'll need to do is

    1. open network preferences>advanced

     

    2. go to the second tab TCP/IP

     

    3. in the configure IPv4 bar select 'manually'

    (sometimes the mac cant find or access the ip address, subnet mask or router)

     

    4. go to a device thats connected to the wifi youre trying to access and find the ip address, subnet mask, and router (you can find that info if you click into the properties of the network. its easier to find on your iphone though.

     

    5. put in all the information, they should look like this:

    ip address: 192.168.2.143

    subnet mask:255.255.255.0

    router:192.168.2.1

    yours will be different numbers though 

     

    6. click 'ok' then click 'apply'. wait for a few seconds and see if wifi works, if not all you need to do is click the 'assist me' button and go through these steps:

    a)  click diagnostics>automatic>continue>wifi>the network youre trying to access>allow>itll ask about the manual ip address, click yes, continue>continue>no>no>quit

    and it should have fixed by now

     

    it works for me and my roomate and our house has the worst wifi ever. elsewhere you wouldnt need to go through so much trouble. oh and if you wamt to connect to other wifi outside of home, make sure you change the settings back from manual to 'using DHCP'

     

    hope it helps! sorry for the nad grammar, im currently using a windows tablet to type all of this out and theres no autocorrect or anything