Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iTunes Enterprise 12.6.5.3 Fails to download apps

I'm using iTunes version 12.6.5.3 (https://support.apple.com/en-us/HT208079) which is the latest version that supports the App Store on Windows 10.


Suddenly, on the evening of 2/7 whenever I try to update or download an app the app will download, get to the "processing part" then throw either error 8288 (An unknown error occurred. Please check that the network is active & try again). If I re-try to download the error comes back 416 (An unknown error occurred. Please check that the network is active & try again). I can sync without issue as well.


I've also noticed that in my "Mobile Applications" folder a ".app" file appears with any App that's being downloaded/updated. So say Twitter has an update, I'll get a "Twitter.app" file sitting in there & the original "Twitter 7.41.1.ipa" remains as well.


Not sure if it's an Apple problem or what. At the same time this issue is happening I've downloaded updates to podcasts without issue & can access the App Store from the App Store tab. The PC is connected to the internet.


I've tried the following:


  • Rebooting
  • Deleting anything in the Downloads folder
  • Deleting anything in the iTunes Media folder


Any suggestions? I cannot contact Apple as this version does not have support. Everything worked fine on the morning of 2/7, but since then I haven't been able to update or download a single app without getting the 8288 or 416 error.


Thanks in advance.

Windows, 10

Posted on

Reply

Feb 10, 2019 4:26 PM in response to turingtest2 In response to turingtest2

I disabled my 3rd party AV, then even disabled Windows Defender completely. Same Error.


The amount of issues happening (even on Mac) makes me think this is an Apple issue.


See this thread for the Mac problem, exactly the same: https://discussions.apple.com/thread/250151949


Feb 10, 2019 4:26 PM

Reply Helpful

Feb 11, 2019 8:51 AM in response to Tario70 In response to Tario70

I’m also have if the same issue. Worked fine 7 Feb and then the error when I tried to do app updates on 9 Feb. from what I can tell I get the 8288 error when I initially download and then the 416 error when I retry the download. I checked the downloaded file size and it appears to download it all but it’s like iTunes isn’t converting the file from .app to .ipa I think it is. I contacted Apple support and he had me uninstall/reinstall iTunes but it didn’t work. He was supposed to call me back at 4 pm yesterday but didn’t. Afraid they are dumping the business edition of iTunes so we won’t have app support any longer.

Feb 11, 2019 8:51 AM

Reply Helpful (1)

Feb 11, 2019 4:12 PM in response to Tario70 In response to Tario70

Ditto for me as well--I noticed it this past Saturday 2/9 but for all I know the issue may have reared its head before then as OP noted but I can say that whatever is causing it, it apparently started some time after 2/1 which was the last time I was able to successfully update my apps via iTunes 12.6.5. I thought that maybe something changed on my Windows PC so I installed iTunes 12.6.5 on my Windows laptop and tried it there--same failed result. I then thought maybe it's something with my router but if other folks are experiencing the same issue, then I kinda doubt that the issue lies with my router.


I should also mention that even with the failed attempt it does download the app but with an .app extension and is not zero bytes in size, however of course iTunes does not recognize it as a valid IPA file. I should also add that I am able to download new podcasts; I didn't try to download a song though to see if it occurs with music as well.

Feb 11, 2019 4:12 PM

Reply Helpful

Feb 11, 2019 4:17 PM in response to turingtest2 In response to turingtest2

Huh? Wait, this thread is about not being able to download apps on iTunes 12.6.5.3 yet your post implies that you are able to do so. Or are you saying that you can't download apps you've never downloaded or purchased before but are able to download app updates for apps you've previously downloaded? FWIW I get the error regardless of whether I attempt to download an app update or an never-before downloaded one.


Update--nvm, I read your reply in the other thread where you're running that version w/o issue on High Sierra.

Feb 11, 2019 4:17 PM

Reply Helpful

Feb 11, 2019 8:51 PM in response to Tario70 In response to Tario70

After experiencing the same issue on multiple machines with the same operating system and iTunes versions i spoke with an experienced Apple Enterprise Support team member. They provided a solution with seems the be simplicity itself after two days of careful consultation and screen sharing. By the way, they couldn't reproduce the problem from their end, hence the feeling the the account file itself might be the culprit. It is not an app version blocking issue per-se, more an iTunes/Apple Account security 'feature'. If your account details or payment methods have been flagged for 'non-authorised activity' or 'suspicious transactions' it maybe suspended (without notification or human intervention) until such times as your ID is re-established and the flag removed. Sometimes this flagging can occur well after the said suspicious event (weeks, months). I my case i had multiple Apple accounts in several countries. Only one of which had the 'update error 8288' issue. This one account had been not been flagged as needing ID verification strangely. After changing the account payment method to "NONE' and then re-entering the required credit card details, the Enterprise rep verified my ID using the 3 questions set when the account was first created. Violå. Problem solved in this instance. All updates completed successfully and all machines. The Mac operating version or iTunes version was not really the issue in my case.

Feb 11, 2019 8:51 PM

Reply Helpful (1)
User profile for user: Tario70

Question: iTunes Enterprise 12.6.5.3 Fails to download apps