Question:

Question: PDFs won't open since Catalina

After updating to catalina, i noticed that all of my PDF icons changed to Affinity Photo. when I went back in to change the default to Preview, it took care of that issue, but now nothing is opening at all. Preview opens, but the PDF does not. i now cannot open PDFs at all. Is anyone else having this issue or know of a workaround?

Posted on

Reply
Question marked as Solved
Answer:
Answer:

OK. Same issue here I think... Recently I noticed all PDF file icons were defaulting to to Affinity Photo. I used "Get info" on one PDF file and used the "Open with" to reassign to Preview by default, and then hit "Change all". PDF file icons started showing up as Preview again, but trying to open any PDF resulted in Preview getting focus, then a few seconds of nothing, followed by Finder animating the file icon as if it was opening, then nothing... not even an error. Restarted. Nothing. Did some disk first aid, nothing. Hitting space for a quick preview of a PDF worked fine, reassigning PDF's to another app worked fine, reassigning back to Preview and nothing. Opening other image formats in Preview worked fine (jpg, png), opening PDF's in other apps worked fine. I did some of the suggestions listed here, deleting Preview preferences and also the Preview Container directory, logged out and back in again and still no improvement. I created a new test user and logged in – PDFs opened fine in Preview there! Hmmm... It felt like a securities/permission type bug so logged back into my own account (PDF's still failed to open in Preview) and followed https://support.apple.com/en-gb/HT203538 Initially after following the steps and logging out and back in, still no luck. I gave up at this point, and tried to get on with some work. About an hour later I had to restart as a couple of apps were now unexpectedly starting giving the pinwheel of death opening files. After the restart, PDF's were opening again in Preview! I'm going to assume the guidance to "Reset permissions" procedure in Finder followed by a:


diskutil resetUserPermissions / `id -u`


...may have done the trick, and just required a full restart and not just a logout and login again, however at some point in desperation I did also try a:


/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user


...so can't be 100% as to what the fix may have been. Good luck!

Posted on

Oct 8, 2019 3:41 PM in response to mdebernardi In response to mdebernardi

well i can't imagine what is happening. everything was working fine prior to my installing Catalina last night, and now i cannot get Preview to open documents. i've rebooted numerous times and still getting the same issue. to top it off, my alternate pdf reader was adobe acrobat pro x, which has also been broken by the update (it was 32-bit, i assume).


so, does anyone have a suggestion for a good, free pdf app that will allow me to fill in pdf forms as well?


thanks

Oct 8, 2019 3:41 PM

Reply Helpful

Oct 8, 2019 3:58 PM in response to mdebernardi In response to mdebernardi

Get Adobe Acrobat Reader (free) and see if it will work. I had Adobe Acrobat Pro but it started having issues when I went to Mojave so went with Adobe Acrobat Pro DC (the subscription version) and i love it...and, issues with Catalina (at least for me) BTW, with the DC version you can edit PDFs, convert PDFs to Word or Excel docs.

Oct 8, 2019 3:58 PM

Reply Helpful

Oct 11, 2019 10:11 AM in response to mdebernardi In response to mdebernardi

I'm having the same issue. Can't open any PDFs in either Preview or Acrobat.

Acrobat: Adobe Acrobat Reader could not open 'filename.pdf' because it is either not a supported file type or because the file has been damaged (for example, it was sent as an email attachment and wasn't correctly decoded).


Preview: The file “filename.pdf” could not be opened. It may be damaged or use a file format that Preview doesn’t recognize.

Oct 11, 2019 10:11 AM

Reply Helpful (4)

Oct 11, 2019 10:30 AM in response to mdebernardi In response to mdebernardi

Os it possible to upload one such file (one without any personal or sensitive information, of course) to some place online and post a link, so we can test whether or not the file is corrupted? It seems unlikely that a lot of files got corrupted, and my guess is that this is caused by some software conflict.


Also, try booting in Safe Mode. Do these same files open in Safe Mode?

Oct 11, 2019 10:30 AM

Reply Helpful

Oct 11, 2019 10:33 AM in response to mdebernardi In response to mdebernardi

I have had a similar experience. I regularly need to open password-protected PDFs, and Preview would not let me open one despite trying the password a couple of times. It would just sit at the password entry. I ended up downloading Acrobat Reader to get around the issue.

Oct 11, 2019 10:33 AM

Reply Helpful
User profile for user: mdebernardi

Question: PDFs won't open since Catalina