Previous 1 2 3 4 Next 45 Replies Latest reply: May 24, 2014 10:34 AM by Hargos Branched to a new discussion.
Evelyny Level 1 Level 1
When I selected "update all applications" on my iPad, it showed "waiting" and has been frozen there for the last 2 hours for all applications!! I've tried hard reset of the iPad but it still shows the same greyed out "waiting" for all my fav apps. Thinking it was a wifi problem, I tried downloading a couple other new apps from the AppStore. Now those are frozen at "waiting" too. I can't seem to uninstall before reinstalling again either.

I've never experienced this with my iPhone. What's wrong? Help!

Ipad
  • domthecalm Level 1 Level 1
    I have exactly the same problem!
    Where can we get some help???
  • HassanAli Level 1 Level 1
    hey guys!
    I also have exactly the same problem, tried to download apps from the app store through wifi, and i guess the connection was lost.

    i think the only way to get rid is by doing a full restore... not the worst thing to do, but still annoying!
  • Backpackready Level 1 Level 1

    Same just happened to me. Did you find another solution than a full reset? I have two grey apps frozen on "waiting". I cannot uninstall them from the phone, and a uninstall from iTunes wouldn't do it.

  • timfromthunder bay Level 1 Level 1

    I have this same problem !

    I have restored 4times .. they stay away until I login to app store and they return... telling me to hook up to wi-fi or sync thru iTunes which I do and they still remain grey

  • butterflymom Level 1 Level 1

    I've seen this also.   Eventually they come back.

     

    I'm thinking a larger app somewhere is downloading and you don't see it, except for the ones waiting.

     

    Sync with Mac or PC and see if this resolves issue.

     

    Wait and be patient.

  • AlyssaMoses Level 1 Level 1

    Well I have this problem.. but it will not connect to my PC..?

  • yonix85 Level 1 Level 1

    I just had the exact same problem. Turns out it was a large video being downloaded from iTunes U, maybe it's the same for you guys

  • lindafromviola Level 1 Level 1

    Having same problem.  Also itunes giving me error message that iTunes has stopped working. I've tried about 15 times!!!   Does Apple reply/look at these posts?

  • Ian Ho! Level 1 Level 1

    I had this problem in both 3G and Wi-Fi mode. I then discovered I had some podcasts waiting for download in the iTunes store which were also frozen. (When I tried to access the same podcasts from my Mac I couldn't find them, making me think they were not really available, and were some sort of artifact.) When I stopped them from trying to download, the apps that had frozen at "Waiting" suddenly came to life and came on through.

     

    So I think it's a blocked queue issue.

  • ferchik Level 1 Level 1

    I have the same problem here with my iPad 2!

     

    I tried to change my WiFi network, sign out my iTunes account, resume the apps, syncronize with the computer and iPad's reboot, but the problem is still there: I cannot install/upgrade any apps.

    Anyone know a solution to this

     

    Thank you!

    F/

  • ferchik Level 1 Level 1

    I solved the problem!

     

    After try many suggestions, I was trying to figuring out why I could not install apps when I entered to iPad's iTunes and I realized that I had many podcasts (at least 12) frozen too! (like the apps).

     

    When I paused the download of the podcasts, the "frozen at wating app" was installed!

     

    I do not know why the podcasts are stuck, because I tried yo download another podcast and I did not have any problem.

     

    Despite that, I am happy now because I can enjoy my iPad with a lot of apps again.

     

    Regards,

     

    F/

  • quist1 Level 1 Level 1

    thanks - I had some songs downloading and I just stopped them and now I can update app's and download them - books too!!!

  • sherif Tek Level 1 Level 1

    It was the Podcast

  • alexahss Level 1 Level 1

    OK I got it. When I restored my phone, it started downloading all the photos from the photostream first. I had about 800 photos, including some videos, that took it about 48 to download through WiFi.

    After it finished restoring the photos, it started downloading and installing all the apps one by one...

    Hope this helps.

Previous 1 2 3 4 Next