Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: 11.0.1 printer driver for Epson printer

I just installed OS 11.0.1 Big Sur and now my Epson Printer does not mount or work. Is a new software driver needed?

iMac Line (2012 and Later)

Posted on Nov 15, 2020 10:47 AM

Reply

There’s more to the conversation

Read all replies

Nov 17, 2020 8:03 AM in response to gonzalo188 In response to gonzalo188

But when I did the same, i.e. went to Epson to download a driver for my printer all they had to offer is the one I was using which worked for all variants of OS 10. When I went ahead and downloaded what they offered and tried to install it my OS 11 jumped in and said the file was corrupted and could not be used. There are no phone numbers anymore to talk to a live human being at either Apple or Epson about this. Right now it appears I am stuck with an non-operable printer and neither company is giving me a means of solving the problem.

Nov 17, 2020 8:03 AM

Reply Helpful (1)

Nov 19, 2020 5:48 PM in response to MizCrush1 In response to MizCrush1

Just spent the best part of the day with Apple Support only to learn that my printer manufacturer (Epson) has not yet released the updates for my printer to align with Big Sur 11.0.1 The Epson webpage acknowledges that they are addressing queries about macOS Big Sur 11 updates "on an on-going basis" My Apple tech advised that I probably just have to wait until Epson releases their new driver (probably V10.85 ?) So glad it's not my MacBook !

Nov 19, 2020 5:48 PM

Reply Helpful
User profile for user: MizCrush1

Question: 11.0.1 printer driver for Epson printer