1 2 3 Previous Next 36 Replies Latest reply: Jun 7, 2014 5:23 AM by mart22n
abimpg Level 1 Level 1 (0 points)
I have been trying to do this for 2 days and I am unable to get it to work. I have sync'd my new iphone 4 to itune (all ok!) when trying to put on a play list from itune to the phone it "says" it's done it but when i go to my phone (the ipod app) it doesn't show anything in there.

I have been through and sync'd it with the play list clicked and then un clicked it and re-sync'd it so it deleted it again. it does show up on the itunes sync page (when phone is connected) as having 952.46 mb of music on there (which would be the playlist) but when i go back to ipod on the phone (again) there is nothing there.

I have sync'd and un-sync'd so many times I just don't get it! The itunes panel says it is on teh phone but the phone can't find it.....

I know th emusic works as it's all on my actual ipod and i play it at work etc so I nkow teh music is teh right format for apple etc just don't know where it can be hiding on the phone!

Any help would be very welcome!

iPhone 4, iOS 4
  • 1. Re: Iphone 4 syncing music but not showing on phone
    jamd90 Level 1 Level 1 (0 points)
    I'm also having this problem, if anyone can help?
  • 2. Re: Iphone 4 syncing music but not showing on phone
    jamd90 Level 1 Level 1 (0 points)
    bump
  • 3. Re: Iphone 4 syncing music but not showing on phone
    Itang Level 1 Level 1 (0 points)
    I am having this problem as well. One thing I noticed is at first the disk space usage will show the space is taken up by Music, but then after the phone is disconnected/reconnected, the disk space usage is shown as used up by Other, no longer by Music. I believe there is a corruption internally in the directory, but I tried restore with no success; the same problem comes back after a restore.
  • 4. Re: Iphone 4 syncing music but not showing on phone
    Itang Level 1 Level 1 (0 points)
    Update from my prior post:

    I just loaded iTune on another laptop of mine, and I was able to upload music from that system. I am cleaning up my first system to see if it helps. If you have the same issue, try iTune from another PC/laptop/Mac, and let us know if that works for you as well.
  • 5. Re: Iphone 4 syncing music but not showing on phone
    BabyDinosaur Level 1 Level 1 (0 points)
    ALso having the same problem. I activated the phone, then as part of a Restore from previous iPhone backup, I spent 6 hours waiting for my music to convert to 128k and transfer. At the end, iTunes complained that it couldn't fit all my music on. My iPhone 4G drive was totally filled, but nothing on its iPod, despite iTunes telling me there was over 11GB of music.
    I removed the Music sync to get rid of all my music, and have been slowly adding playlists one-by-one. It's annoying, but it's working at the moment.
  • 6. Re: Iphone 4 syncing music but not showing on phone
    Chimmychong Level 1 Level 1 (0 points)
    TOP

    This is killing me...
    Has anyone figured this out??
  • 7. Re: Iphone 4 syncing music but not showing on phone
    popikoff Level 1 Level 1 (0 points)
    I just got my iphone and I have the same problem. Help!
  • 8. Re: Iphone 4 syncing music but not showing on phone
    AxeBox360 Level 1 Level 1 (5 points)
    For me I have to resync it to fix this issue. I do not know a way to prevent it from happening. In the short term, my plan is to simply open the iPod app after each sync and make sure my playlists are there. Hopefully a patch will come along soon that fixes this issue
  • 9. Re: Iphone 4 syncing music but not showing on phone ("no content" message)
    ooklibrarian Level 1 Level 1 (0 points)
    My brand new (as of yesterday) iPhone 4 (sync with iTunes 10) had this problem straight out of the box - sync Music etc, all seems to go well, no error messages but when I open the iPod app is displays the message "no content".

    In frustration, I did a full software restore which ended in a sync. This time, iPod shows my stuff. I play music, watch video and go to bed happy.

    The following day, iPod shows "no content" again! I have done nothing other than switch it on! Clearly, there is some part of OS4 that is corrupting the iPod content.

    What I find very disappointing is that there is a 200+ page topic in the forum that lists all those people who had this on iPhone 3 with OS3! So, Apple have preserved a bug across major versions of the OS.

    What I find most disappointing is that there is no trace of this issue in the online support - only in the forums. There's not even an article saying "we know it's there and we're looking at it, but haven't got a solution yet". It feels as though Apple is in denial about the whole issue.

    Anyone in Apple willing to comment?
  • 10. Re: Iphone 4 syncing music but not showing on phone
    cdgarcia87 Level 1 Level 1 (0 points)
    just noticed SAME problem here... 32gb iphone 4 - ios4.1

    phone showing 6.2gb free of 32gb total... ipod app says no music??? seriously this is annoying
  • 11. Re: Iphone 4 syncing music but not showing on phone
    thesolidstates Level 1 Level 1 (0 points)
    same problem here! my iphone is on repair now...
  • 12. Re: Iphone 4 syncing music but not showing on phone
    lauren9127 Level 1 Level 1 (0 points)
    ok, so i'm having this same problem with iphone4. synced the phone and looked at ipod app and says no content. so i did a restore and it fixed it. but i got a new app and had to sync the phone again to itunes and it caused the same problem. this is getting very annoying...
  • 13. Re: Iphone 4 syncing music but not showing on phone
    only1rick Level 1 Level 1 (0 points)
    I had the same problem with my iphone just after I updated my software to the 4.2 version. Luckily I was able to fix it. First I downloaded a song from iTunes to see if it would remove the "no content" message on my phone when in tried to use my ipod on my phone. It didn't work; however, I reconnected my phone to my computer and clicked transfer purchases and, after that, the message was gone from my phone and all of my music showed up again. I had to spend $1.29, but it worked. I hope this helps resolve your issue as well.

    -Rick
  • 14. Re: Iphone 4 syncing music but not showing on phone
    xiomi Level 1 Level 1 (0 points)
    I just found this problem after I did the 4.2.1 iOS update. Noticed that if I go to the "first screen" to do a Search in the iphone, there they are! But when selected to play, "No Content" appears!!! What's going on here? I have over 600 songs and some videos and now nothing shows. iTunes says the space in Audio is occupied (have the same size as before), but again, NOTHING!!

    Please HELP!!!!
1 2 3 Previous Next