Previous 1 2 3 4 5 6 Next 84 Replies Latest reply: Mar 3, 2014 10:13 AM by Mahambaig Go to original post
  • applegrant Level 1 (0 points)

    I tried the cleaning the hoovering the resets the clean install but none of those things worked.


    Then I tried slapping the phone gently on the back and that worked straight away!


    I think this is a hardware issue and not a software issue, there must be some contact points sticking or something similar.


    I hope this helps.

  • alaskabarbi Level 1 (0 points)

    After working fine all day and no possible way for it to have gotten wet, my home key suddenly stopped working too. I am wondering if some of these issues are hardware issues.

    I tried the vaccuum since I had the phone in my back pocket during 4 of July celebrations. That did not work. However, applegrant's suggestion did!!!

    Thanks so much for that idea.

  • zxcvbnm986 Level 1 (0 points)

    My home button suddenly stopped working and the steps I've tried:


    1. backing up - can't lose all your contacts, texts, vmails, notes, calendars, photos, music, ringtones, etc..
    2. restoring and backing up.. - still did not work
    3. restoring and backing up.. for a second time - worked for a bit, then stopped after awhile
    4. restoring and starting anew.. then restoring and backing up - still did not work
    5. restoring and backing up.. - since i still wanted all the info on there
    realized it may not be software problems or a virus.. updated necessary software at step 2 "restoring"

    tried cleaning out with toothpick, brush, and air cleaner.. = still no response of home button


    finally- got to this last thread..
    decided to slap the phone on the back and worked great..!!
    i guess it's hardware problems- from all the dropping and throwing..

  • Kaput33 Level 1 (0 points)

    I wonder if there is a type of "plug" that we can get to block dust from getting in there while we are not charging it. It would make sense, right?

    In my case, the vaccum has worked, but only for a while and I think it is because I got more dirt in it and I'm too lazy to vaccuum my phone every day. If there was a plug, that would make all our lives easier.


    The slapping works for me too.

  • Herbertlee Level 1 (0 points)

    1) Connect with USB cable to charge your iPhone4

    2) Hold Home button till Voice Control show up

    3) Now press Cancel and your Home button should be reactivate.

  • Winston Wolf Level 1 (0 points)

    Herbertlee's solution worked for me.

  • VoodooGB Level 1 (0 points)

    Found this and it worked perfectly.


    1.) Open any application


    2.) Press and hold the power button until the slide to shutdown swipe bar appears.


    3.) Release Power button


    4.) Press and hold Home button Lightly

    until screen returns to icon screen


    5.) Enjoy your functioning home button!!!


    This procedure recalibrates the home button after normal wear or heavy use.

  • bradleyfromlouth Level 1 (0 points)

    i went away for two days without my iphone 4 and came back and the home button was not working at all it has been like this for three days now and i have tried everything! the tooth brush, the vaccum, the slapping on the back, plugging it in and out of my idock, rebooting it on itunes! the lot.... should i go to the itunes store or is there anything else that may work?

  • os4 Level 1 (5 points)

    This appears to have worked for me, too.  I have both the built-in Camera app, as well as Camera+, running.


    When I could "force quit" those processes, the Home button magically started working perfectly again.


    The problem started right after I did a full clean upgrade to 4.3.5.  I ran the upgrade and then did a clear restore.

  • Kaput33 Level 1 (0 points)

    This is more of a warning than anything for all of you - I had the same issue. None of the above worked for me. I called apple because the maritimes do not have apple stores at all (I was told by CSR). So I told them what was up, what I tried, and the CSR simply suggested I replace it. I had applecare, so she said it was no problem.     


    Don't beleive them for a second.


    The CSR told me NOTHING about how to check for water damage (i.e. moisture detector, the worst peice of technology to ever exist) and so when I sent it in, they charged my credit card without telling me how much, or why. After a LONG phone call, I guess my phone was water damaged. I still call bull to this day, because other than maybe some rain or sweat from a water bottle (just a guess), water has never gone near it.


    So to conclude: be very careful when sending it in for repair. They are sneaky.


    Also: apparently all of this that happened to me are in the "terms and conditions" that I "accepted" when I sent my phone in. Isn't that illegal, that I never received these "terms and conditions" in any shape or form? Really shady business. I think it was a CSR fail, because she never sent me any emails or told me anything about being charged.

  • zeya2006 Level 1 (0 points)

    YA thanks forr all suggestion i got my home button  working again   hurrayyyyyy ,so i want to share what i did

    1-first i plugged in charging

    2-then i pressed the home button for sometime

    3-then voice control came and i made cancel

    4-then i slapped gently just behind the home button

    and then it worked finally

    but i dont know wt worked among the option no-3 or 4 but finally i got it

  • Stickynick Level 1 (0 points)

    I had similiar issues with the home button - intermittant working - It seemed like a busy cpu sort-of issue and once I sync'd it and dealt with a few upddates and turned off a radio app the button worked.  My best guess is the phone was overwhelmed looking to resolve app issues, some purchased on the phone and some on itunes etc. It is not my phone and as I was troubleshooting I noticed that it was not automatically syncing when plugged into the itunes it is synd to.  A manual sync was required to get things moving.


    So far so good.

  • Jacques here Level 1 (0 points)

    Well i finally fixed mine.Mine is less then a year old and hardly used so, it better not be the button. After trying all the fixes it was still unpredictable? Anyway i did Vacume, and it helped for a day it seems. Then it acted up again. I finally hooked it up the the Comp. and did every fix i have read about like this: from i tunes (Device/ Iphone on the left panel)" i did the "save settings" and then "rerstore" (you loose the apps) to original software several,several times!!!! (Notihing there?) also, i was pushing the sync button several several timesalong with that!!!, another heavy duty vacume treatment (nothing there?) and then the "power off and back up (several times) while holding the home button to get it to go into "voice control mode" finally it went to home after powering up several times with and with out the home button held?(several times!!) it then started going into the "voice control mode"(holding the home button for 15-20 seconds or so) after powering on several times!!! then i carefully disconnected and it was working? I reloaded my music and apps and every thing is fine now? I think something that unpredictable is software. Thing ac


    ts like it has a little bit of PC in it..LOL.. Also it kept the 4.3.5 software version when i did the restore and didnt change?? Hope this helps somebody

  • txturbo Level 1 (0 points)

    I have read through the solutions, none of them work to address the root cause.


    The clue to the problem is the "smacking of the phone" or pushing very hard on the home button.


    The problem seems to be the electrical connection between the button and the logic board. I suspect that after thousands of presses the connector flexes slightly causing it to become disengaged from the socket on the board. This is why pressing very hard on the button allows it to work intermittently. It also explains why using a toothpick, placing the usb cable in the jack or software updates makes it work temporarily. Flexing the connector moves the circuit board and allows the temporary connection of the connector because it's in direct proximity. But it never allows enough pressure to reseat the connection.


    To fix it:


    1. Remove the back of the phone by taking out the two small screws and sliding the back up gently. You can see details of how to remove the back here. Do not remove anything else from the Iphone.
    2. Using gentle pressure push down in the area behind and in proximity to the button. If you have a phone that's definitely not working you can see the immediate before and after effects.
    3. Put the back on and enjoy.


    I don't yet know how long the fix will last as the connector may become weak. It may also be a poor solder connection between the actual button and the flex cable.