Previous 1 2 3 4 Next 45 Replies Latest reply: Nov 26, 2012 6:42 PM by scooter131313
bvdman89 Level 1 Level 1 (20 points)
After upgrading to iOS 4.1, all my camera roll thumbnails were replaced by a giant black box. Anyone else having this issue?

iPhone 4, iOS 4, iOS 4.1
  • Kwopau Level 4 Level 4 (1,725 points)
    I had this issue when the genius guy transfered photos from my original iphone 4 to my replaced iphone 4, somehow if I tap anywhere on the black box, I can still view photos, not sure why it does it. I want to know whats the fix to this as well.
  • a1000 Level 2 Level 2 (215 points)
    Same here. The photos are still there but displayed as a black box across all of them. Nice one apple. Any photos taken after the update seem to appear OK though.

    Message was edited by: a1000
  • bvdman89 Level 1 Level 1 (20 points)
    Yep, if I tap anywhere on the black box a photo appears. It seems as though just the thumbnails are an issue. Restoring back to 4.0.2...
  • subspd Level 1 Level 1 (0 points)
    Yep add me to the list on this one. Big black box but can still view the photos if you click anywhere on the black box.
  • Lawrence Finch Level 7 Level 7 (31,430 points)
    A lot of people reported this problem with 4.0, 4.0.1 and 4.0.2. So it is probably not the version that causes the problem.
  • subspd Level 1 Level 1 (0 points)
    So what is it then? And why hasn't anyone figured out how to fix it? Apple???
  • Lawrence Finch Level 7 Level 7 (31,430 points)
    I have no idea what it is, but it has been reported with most versions of the firmware by a few people. It is not a "universal" problem that affects all iPhones, or even a significant number of iPhones. It may be related to insufficient free memory on the phone. How much free space do you have?
  • subspd Level 1 Level 1 (0 points)
    I have 8gig of free space. That can't be it.
  • doubleocrow Level 1 Level 1 (0 points)
    I'm having the same issues as well. I read in another blog that you can try trashing the iPhone cached photos by opening iPhoto by right clicking and selecting "Show Package Contents". I do not know which file I am supposed to dump, so I haven't tried it myself. Supposedly once the file is dumped, you resync and it's back to normal. Does anyone else know about this?
  • CharismaG4toMBP Level 1 Level 1 (10 points)
    *+A SOLUTION*!+

    Guys I had the same issue with the black box. Only maybe 30 or so images were affected though at the end of the roll but still as you all describe.

    This is my first post so I hope you find it useful.

    *_THE FIX_*
    Download 'iPhone Explorer' (Google that one and it's free for Win/Mac).

    Plug iPhone in and navigate to the PHOTODATA folder.

    Locate these three files:
    1. Photos.sqlite
    2. PhotosAUX.sqlite
    3. com.apple.photos.caches_metadata.plist

    Save them to your computer.

    Delete them from your iPhone.

    Restart your iPhone and let if boot fully.

    Open 'Photos' and wait for the iPhone to 'rebuild the library'.

    Enjoy your thumbnails once more!
  • macnimation Level 1 Level 1 (0 points)
    I actually do not get what the fuss was all about with the release of 4.1

    Apart from HDR photography, which as a photography, it isn't great and will not be everyones choice, the Game Centre, which is basically social networking for games, again not everyone will use this, and a few minor tweaks, nothing has really changed.

    I updated today to 4.1 and I had to go onto the Apple site to actually find out what the changes were, because apart from the Games Center App, I saw little change.

    Holding the phone in my left hand still drops a few bars but I haven't lost a call yet anyway.

    I'll be impressed when they provide FM Radio Support, Flash Support and the ability to use the iPhone Wifi as a Wireless Dongle on a computer without wireless abilities.
  • ernloji Level 1 Level 1 (0 points)
    Thank you. I had this problem and this fix helped me. And it is really easy to do.
  • otisalex Level 1 Level 1 (0 points)
    Thank you, Charisma! It works. I just today downloaded 4.1 to my iPhone 3G and had the nasty camera roll display problem described above, but the fix you posted worked like a charm!
  • pberk Level 2 Level 2 (280 points)
    I had the black box issue on my original install - turned out to be some corrupt photos files - once I got rid of those photos, the issue went away...
Previous 1 2 3 4 Next