Previous 1 2 Next 24 Replies Latest reply: May 6, 2011 7:57 AM by BuzzT38
harv55 Level 3 Level 3 (600 points)
Has anyone received error 3259 when trying to update an iphone 4 to iOS 4.1? I have received this every time I have tried to update. My wife has a 3G and it updated without issue the first time from the same computer via the same iTunes account. The error states a network timeout occurred--could this be an apple server capacity issue?

iPhone 4, iOS 4
  • makan1 Level 1 Level 1 (20 points)
    Why not try and download the update 1st.

    If u cannot Download from itunes try these links.
    iPhone 3G 4.1 – (iPhone1,24.1_8B117Restore.ipsw)
    http://appldnld.apple.com/iPhone4/061-7932.20100908.3fgt5/iPhone1,24.1_8B117Restore.ipsw

    iPhone 3GS 4.1 – (iPhone2,14.1_8B117Restore.ipsw)
    http://appldnld.apple.com/iPhone4/061-7938.20100908.F3rCk/iPhone2,14.1_8B117Restore.ipsw

    iPhone 4 4.1 - (iPhone3,14.1_8B117Restore.ipsw)
    http://appldnld.apple.com/iPhone4/061-7939.20100908.Lcyg3/iPhone3,14.1_8B117Restore.ipsw

    If you wanna apply the new firmware open iTunes and go to summery page click SHIFT key + RESTORE button and select the firmware,
  • Sidlu Level 1 Level 1 (0 points)
    Had same problem! I disabled antivirus prog. Now I have updated 3G with iOS 4.1.

    Check also windows firewall setings.

    Good luck!!!
  • harv55 Level 3 Level 3 (600 points)
    thanks makan, I may try that as a last resort. I would like to update my iPhone via the official channels through iTunes. Weird thing is that now there is no "error 3259", but just a message that states I have network timeout....the update downloads (I can see it in Windows Explorer as the file is downloading) and in the "processing file" stage the error occurs and the update file is deleted.

    *Exact Error*
    There was a problem downloading the software for the iPhone "<phone name>". The network connection timed out. Make sure you network settings are correct and your network connection is active, or try again later.

    -----
    For now, I'll just "try again later"
  • harv55 Level 3 Level 3 (600 points)
    That was it! I run Kaspersky 2011 and had to add iTunes.exe to the excluded applications list. I only selected, "Do not monitor network traffic", since the timeout error is network related, and now I am able to update to 4.1.

    Thanks again!!!
  • dcallaghan Level 1 Level 1 (0 points)
    I tried disabling Kaspersky as you mentioned but it still didn't work.

    My download reaches 380.0MB of 380.1MB and I am on my fourth try now. Not much fun on a 512kB connection,
  • Mr.C UK Level 2 Level 2 (410 points)
    Do you have a firewall ? If so then try temporarily disabling that too.
  • Nabeel Mohammed Level 1 Level 1 (0 points)
    Hello people, even I'm receiving the 3259 error. I have tried 2 times yesterday and today but the issue is same. I read the post saying to disable the antivirus and then download, not tried that yet but will have to give it a try.
  • CGSprite Level 1 Level 1 (0 points)
    Im having the same problems with iPad and iPhone downloads. Only on my iMac though not the iBook!! My router has no firewall enabled and neither the iBook or iMac have any antivirus software. I'm totally stumped.
  • x55 Level 1 Level 1 (0 points)
    i turn off the everything,but still get this error

    <Edited by Host>
  • BGZBABY Level 1 Level 1 (0 points)
    same here^
  • Nabeel Mohammed Level 1 Level 1 (0 points)
    I can't believe this. All my DATA is gone. I have no pictures. All my Apps are messed up and the audio is gone as well. The Shift + Restore key option will revert the IPhone to its original factory settings. Which means that you have opened a brand new device just from your box. People I strongly disagree and not recommend this way t update the software. Its a real real mess. Even I restore the settings from the old backup, only a few things come back and not all. Apple has to get solutions to these issues. All my previous updates were done without any issues, Its just this 4.1 has created a lot of issues.

    REALLY ANGRY
  • NemesisX Level 1 Level 1 (0 points)
    I don't see why you are REALLY ANGRY, it's your own fault. This isn't a 4.1 related issue, it always happens when u press restore (it even says it's gonna delete all your data, and that you should back up). You have to use Update instead :P

    Oh and thnx for the solution to the original prob this topic was referring to, KIS 2011 decided to interfere with iTunes downloads.
  • chiltondarlo Level 1 Level 1 (0 points)
    After 2 days of the same happening to me and getting ready to throw the thing out of the window, I disabled all of the security on Kaspersky and tried again. Not that happy doing it but's finally updated my iPhone 4 to 4.1!!
  • andy1982_UK Level 1 Level 1 (0 points)
    I've had similar problems updating my iPod touch from iOS 3.1.3 to 4. I got the following behaviour:

    1) The download finished (with 0.1MB being listed as remaining)
    2) The system said processing file
    3) After waiting a while iTunes informed by that the network connection had timed out; it deleted the download.

    I finally managed to fix this by disabling my anti-virus and firewall.

    1) I disabled my firewall by clicking on the start menu, choosing the run command and typing "services.msc" into the run box. I then found the service named "Windows Firewall/Internet Connection Sharing (ICS)" and stopped it.

    2) I disabled my antivirus (in my case NOD32) by right clicking on the icon in the system tray and clicking "disable real time antivirus protectoin".

    3) I ran the iPod update. This time it worked.

    4) Once the update was completed I re-enabled my firewall and virus scanner.

    Note that the update seems to involve backing up the iPod, deleting everything from your iPod, installing the new iOS, and then restoring the backup. Therefore if you just install the new software there is every chance you'll end up with a blank iPod/iPhone.

    I know other people have said this, but thought someone might find more detail helpful.

    Message was edited by: andy1982_UK
Previous 1 2 Next