Previous 1 2 Next 20 Replies Latest reply: Sep 18, 2010 7:41 AM by Murat Lahur
qtrules Level 1 Level 1
so i have a mid-2009 macbook pro: 13-inch, 2.26Ghz.

it was running 2GBs of RAM until this afternoon when i upgraded it myself to 3GBs with a 2GB stick.

i followed the instructions from apple to the absolute letter. however now, my keyboard lights aren't working. but it's funny... usually in direct light, the Fn keys that control the keyboard lights won't allow you to adjust the light, right? but they will for me, except there's no light to adjust.

i couldn't have done something, right?! i mean... i was was super careful and only handled the ram section, after which i blew off some dust and sealed it up again.

please help!

macbook pro mid-2009, 13-inch, Mac OS X (10.6.4)
  • Murat Lahur Level 3 Level 3
    try to revert to the old setup and see if your lights come back
  • qtrules Level 1 Level 1
    that didn't work.

    there was one thing i noticed while i was checking the innards though; just to the left of where the RAM is installed is a tiny bit of plastic that juts out from the underside of where everything is (in this orientation). it looks like it should connect to a tiny piece of plastic, but i wasn't feeling brave enough to really try and wedge it in.

    could that be something to do with the keyboard lighting? could i have knocked it off?
  • Murat Lahur Level 3 Level 3
    now that's not enough information for me to respond ..If you can take a picture of what you describe and upload to a free image hosting site and post the link then I can have a better look
  • qtrules Level 1 Level 1
    http://guide-images.ifixit.net/igi/FkpKKrqQlYsgNBq6.huge

    it's to the left of the ram, beside a screw. there's a black rectangle, and then below it is a little strip, and then white.

    this is definitely not attached in my mbp.

    i guess i'll have to open it up once more.
  • Murat Lahur Level 3 Level 3
    you mean the one with 4 cables coming in ??
    yes that has to be attached lol

    be careful to insert the plug really straight without applying much force .as the pins inside can get bent
  • qtrules Level 1 Level 1
    it's not the big one. it's a teeny, tiny one. i'll try and describe it as best i can.

    it's on the bottom row, right before the battery.

    in the picture, at the far left, there's a sort of teal-coloured square.

    to the right of that is a long rectangular-shaped connector.

    and then, finally, exactly to the right of that is my connector in question.

    i just tried to reconnect it myself, to no avail. i couldn't seem to get it in the whole way.

    i'm currently located in south korea, and there's a big public holiday coming next week, so getting to a repair place might be difficult.

    can anyone offer any insight? is this the culprit? it's the only logical reason i can see... it was completely loose after all!

    ps, thank murat for your help!
  • Murat Lahur Level 3 Level 3
    I am not sure what that connector is for .. but common sense dictates there should not be any disconnected wiring inside your computer ..

    Altho if it doesn't go in nicely I would just leave it to a technician ..

    Try to reset your SMC as described here since it is what's responsible for the backlight control
    http://support.apple.com/kb/HT3964?viewlocale=en_US
  • qtrules Level 1 Level 1
    i don't think that worked...

    darn!

    it'll be long and dim week before i can go get it looked at x_x

    Message was edited by: qtrules
  • Murat Lahur Level 3 Level 3
    please repeat the smc reset steps exactly as described without skipping any a few times over
    it's a bit tricky to get it but you will get it
  • qtrules Level 1 Level 1
    okay!

    i have all night

    haha.
  • Murat Lahur Level 3 Level 3
    I hope you report back with success stories
  • qtrules Level 1 Level 1
    sadly... no success

    i followed the instructions exactly; restarting and all. no luck. i did hold the buttons though... is it supposed to be a hold, or a quick "hit"?

    i saw your post about a better look, so i opened the back again and took a better picture.

    http://i1220.photobucket.com/albums/dd457/jakemoney/IMG4175.jpg?t=1284811603

    you can see the connector just below. i tried, again, to make it go in. it fits, but i can't get it to stay. that must be the job of a professional. i can't do anymore now - i'm too involved, and i'm worried i may break more than just some stupid backlighting on my keyboard.

    in other news: iphoto does open a lot faster now!

    thanks again.
  • Murat Lahur Level 3 Level 3
    indeed that's an unplugged connector .. and given that it only has two legs it might be the backlighting ..but I couldn't really see where it's supposed to be connected there ..maybe underneath ??

    I'd say don't play around too much and show it to apple store
  • qtrules Level 1 Level 1
    i'm 99.9% sure that it slides into the black square you see just underneath it.

    i've attempted to slide it in, and had some success. but it's doesn't stay. it just sort of... slides out. i can't get enough leverage underneath it to get it inside properly. but then again... i'm not even sure if it's supposed to go inside x_x
Previous 1 2 Next