Previous 1 6 7 8 9 10 Next 182 Replies Latest reply: Oct 24, 2013 5:28 AM by kcullinan Go to original post
  • Brewers_Wife Level 1 Level 1 (0 points)

    After reading every post on this forum, and trying everything suggested to no avail, we spoke to a tech who talked us through changing the security security settings on our router (Netgear).

     

    The router was set to broadcast on both channels WPA-PSk & WPA2-PSK. However the computers (both on Windows Vista) were set to one of either. Hence, in iTunes world, they are not on the same wireless network. The tech advised us to switched to the single channgel WPA-PSK and then reconnect all devices that lose connection to our wireless network again. All good. Now can see the library for the first time in homesharing.

     

    Only problem, one phone, HTC Desire doesn't like WPA-PSK which is probably why we changed it in first place.

     

    However... can anyone help with this... I can only see a list of all songs. I can't look at it by album, artist, nor see any of the playlists, etc. Any clues?

  • TK1137 Level 1 Level 1 (0 points)

    Thank you! I'd all but given up until I came across your post. I have a N600 WNDR3800 Netgear router. I followed your instructions & it worked. I also went back into my Windows firewall & made sure the bonjour & itunes boxes were checked. Working perfectly. I have a 64 bit Windows 7 PC. Thanks again!!!

     

    From Ryanboys post:

     

    Found the solution. I am 1000% sure this is correct. I have been troubleshooting this for two days. There are pieces here that are correct in these posts, it's just a matter of assembling them and understanding them. Here goes:

     

    My setup:

    - I have a Win 7 64 pc, latest updates. Windows firewall ON.

    - I have 3 iPad 2's, 1 iPhone.

     

    The problem:

    - I decided to enable Home Sharing so I could share the music and videos from the iTunes on my Win 7 pc with my other devices (iPads, iPhone and soon.....Apple TV's).

    - Worked for a few hours and then mysteriously stopped working for good. Rebotted the router, reinstalled iTunes, all the suggestions. Nothing worked.

     

    The Solution:

    - I  began searching the forums and trying everything suggested. Everything! Nothing worked.

    - Here's what I discovered and I promise you it's the solution (at least it was mine):

    - First of all like one of the previous posters suggested, when you click DONE after enabling Home Sharing, the Shared category on the left pane in iTunes IS SUPPOSED TO DISAPPEAR. I agree that it is a bad design. The only time it reappears is when one of the other devices actually connects to your iTunes and starts sharing (streaming)...until then the "SHARED" group will remain HIDDEN.

    -As many prior posters have stated the actual problem lies within your router (doesn't matter whether you're connected wirelessly or whether you're wired). The issue is Multi-Casting....or as some routers refer to it RIP.

    -The reason that some posters have had success with rebooting routers, etc, imho, is that there are so many routers out there that some routers might reset or automatically enable the multicast feature....other routers don't.

    -The problem is your ROUTER.

    -log into your router and do some poking around. You will have to know the login and password and ip address (192.168.1.1....or whatever).

    - In my router, a Netgear N600, model WNDR3400, I had to go into Advanced, then LAN Setup. Then I had to do 2 things: 1.) I had to make sure that RIP Direction was set to "BOTH" and just as importantly 2.) make sure RIP version was set to RIP_2M....which is what actually sets it to "MULTI-CASTING".

    - each router is different so you will have to look at your router's documentation, call support, or log into it and try to find where you set "MULTICASTING ON" or RIP BOTH DIRECTIONS and version to 2M

     

    GOOD LUCK everyone. I am quite confident this will solve your problems!

  • TK1137 Level 1 Level 1 (0 points)

    *UPDATE* After a short while, I started to lose connection with my homesharing. So, I followed up with some other advice found in this thread. I rebooted my router. I turned off itunes. Rebooted my router. Went to my control panel > remove program > repaired Bonjour > opened itunes. Now everything is working. I have 2 apple tv's gen 1, 1 iPad 1 & i iPhone 4 running 4 seperate movies off homesharing & no problems. The only problem is that "homesharing" does not appear on the left of the screen along with the devices connected to homesharing. However, when these devices are connected & I go to close down iTunes, a message pops up saying there are 1 or more devices connected. So, there's that for you. Hopefully this helps out. Good luck!

  • dcpart2tunes Level 1 Level 1 (0 points)

    I had the same issue and here is my fix:

     

    Windows 7 Professional 64bit

    iTunes 10.5.3.3

    Apple TV2 Software: 4.4.4

     

    In short, after upgrading iTunes, the Bonjour service was disabled.

    To enable, right click on My Computer and select Manage

    Click on Services under Services and Applications

    Right click Bonjour Service and select Properties

    Change Startup type to Automatic

    And, click Start under Service Status

    Click Ok

    Restart iTunes

     

    Cheers

  • jlh379 Level 1 Level 1 (0 points)

    After having spent hours on this, deactivating and reactivating each computer worked.  Thanks for this SUPER SIMPLE solution, Natilus13!!!

    PC, Windows 7

  • rainiej Level 1 Level 1 (0 points)

    i rebooted the router   and it worked   home sharing is there for me   both machines  win7

  • ptrain814 Level 1 Level 1 (0 points)

    I had the same problem. Here's what I did and it worked. I opened the itunes on my other computer and voila, the homesharing magically opened up  instead of ending after done!! I can't believe it was so simple!!

  • jlh379 Level 1 Level 1 (0 points)

    Just spent an hour with technical support.  I had tried all of the suggestions in these posts:  resetting router, deactivating computer, opening both computers, etc..  I had to temporarily deactivate the firewall in my virus protector program on both computers and that worked!  I'm now downloading to each computer.  Hope this helps someone else.

  • ChrisCarroll Level 1 Level 1 (0 points)

    What worked for me: Restart the Windows Bonjour service.

    On Windows 7, immediately after download and installing iTunes 10

    thanks for all the tips,

    Chris

  • icegy Level 1 Level 1 (0 points)

    FINALLY FIXED!!!  And here's a solution that I've not seen anyone else mention in this thread (I tried resetting Bonjour, re-installing iTunes, resetting router . . . nothing worked . . . until this).

     

    So here's what finally worked for me.  I had to remove my prefrences folders (BOTH of them) and have iTunes re-create them.  When I restarted iTunes it asked me to agree to the license agreement and Voila!  I was back up and running.

     

    So here's the steps.

     

    1.  Close iTunes application

    2.  Remove all of the contents from inside of this folder - C:\Users\YOUR USERNAME\AppData\Roaming\Apple Computer\iTunes (it is recommended that you move them to your desktop as a backup - so that you can move them back in case this does not work).

    3.  Repeat step 2 for this folder as well - C:\Users\YOUR USERNAME\AppData\Local\Apple Computer\iTunes

    4.  Launch iTunes application. 

     

    At this point - itunes will re-create all of the data inside of these two folders that you just removed and you should be back up and running.

  • robertgibsonglasgow Level 1 Level 1 (0 points)

    Worked a treat been at this for ages and these 2 simple steps above sorted it, disappointed in apple though.

  • icegy Level 1 Level 1 (0 points)

    Glad to hear the solution worked for you.

     

    One more thing - I think I found the cause of the issue (at least for me).  Turning on WiFi sync for your mobile devices seems to cause problems with home sharing.  After I got everything back up and working again, I plugged in my iphone 4s and my iPad to back them up and sync them.  While plugged in, I checked the option for WiFi Sync on each device.  After I unplugged them from the USB cable and disconnected them from the computer, they continued to show up under devices via WiFi.  Then after about 10 minutes, iTunes slowed to a crawl and crashed.  When I restarted iTunes, all of my home shares were gone again.  So I deleted the 2 preferences files (as described in my other post above) and the home shares came back.  Since then, I haven't turned WiFi Sync back on and the home shares have continued working flawlessly (as has my AppleTV which was not connecting either)

     

    I would be interested to hear if this causes the problem for others as well.  If so, it's certainly something that Apple needs to address.

  • formengr Level 1 Level 1 (0 points)

    My guess is trouble comes wifi sync and abundandant iOS devices. Had iPad set up wifi prior to Xmas & ATV. Added 4s & iPod touch after. Ipad and ATV were fine before the new additions to my iOS family. After new arrivals which were setup wifi, home sharing vanished on all devices. I disabled wifi synch on all devices and homesharing is good again  i did none kf the other suggestions above.

     

    This is very disappointing. I am on 64 bit W7 and iTunes is super buggy.

  • slwilliams Level 1 Level 1 (0 points)

    I've been experiencing the problem described above (when activating Home Sharing, pressing "Done" caused Home Sharing to disappear from the left side of iTunes). After trying many of the suggestions in this thread, I realized something that led to a solution for me: My work computer wasn't logged into my home computer--the one with the media I wanted to share.

     

    On my work computer, I opened Windows Explorer and right-clicked on the Network icon in the Preview pane. I could see the icon for my home computer, and when I double-clicked on it, I was presented with the Windows Security dialogue box. From there, I entered my home computer domain and user name (domain\username) and then password. Once I connected, Home Sharing worked fine.

     

    My work computer is on my company's domain, and my home computer network is password protected. Not everyone experiencing the Home Sharing problem will have this situation. But if one of your devices defaults to a different domain, try logging on to the network device where you're trying to run Home Sharing.

     

    Good luck to all!

  • D_Chestnut Level 1 Level 1 (0 points)

    SIMPLY AMAZING, I didn’t know this was the problem until there was another computer on the network that had iTunes. I just home sharing stopped working.  After I took this path in to my Control Panel I found “ITunes” listed 3 times and not all boxes were checked. After checking the unchecked box ATV2 is finally back up after over 2 months!!!  Thank you 

Previous 1 6 7 8 9 10 Next