Skip navigation

Iphone 4 - Not connecting to wifi (incorrect password)

227075 Views 85 Replies Latest reply: Jan 28, 2014 11:41 AM by iH85CH001 RSS
1 2 3 ... 6 Previous Next
swmasson Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 22, 2010 8:46 PM
Hi there,

I seem to be having problems connecting my iphone to my home network, it keeps coming up with the error "incorrect password for STEVE_NETGEAR" - The strange thing is that i have two iphone 4's and the other one connects to my home network perfectly, so its just my one that does not - However, it still connects to other networks just fine, so its just my home network that it doesnt connect to... i really dont understand this issue... very strange! I've tried everything:-

1) Mac Filtering
2) Disable passkey
3) Used 128 HEx
4) Reset the iphone back to factory settings
5) Reset Network settings
6) Upgraded to 4.1 OS
7) Changed the SSID
8) etc, etc, etc

None of which resolved the issue, i'm at a loss as to how one out of the two iphones can connect and the other cannot... Why can it connect to all other wifi networks but not my own... Could it maybe be a conflict between the two iphones?

If anyone has any ideas it would be much appreciated!

Thanks in advance for your help

Regards

SWM
iphone 4, iOS 4
  • HolmanGT Level 2 Level 2 (205 points)
    Tell it to forget STEVE_NETGEAR. Power the phone off and back on then go into network and reselect STEVE_NETGEAR and re-enter the password and you should be good to go.

    If you entered the wrong password the first go-around it will keep trying to use the bad password - I think.
    Dell-PC, iPhone-4 iOS 4.1, Windows 7, 64 Bit
  • Iskor12 Level 1 Level 1 (55 points)
    Go to Settings>>General>>Reset>>Reset Network Settings.

    Then try to connect to it.

    OOPs..I just noticed that you already tried this. Have you reset your router yet?
    Custom Built, Windows 7, Iphone 4 with iOS 4.1
  • TomLapple Level 1 Level 1 (0 points)
    Have you had any resolution to this? I'm having the same exact issue. 2 iphone4's in the house, one connects, the other does not. The one that won't connect also can connect to other wifi signals outside of the house. It's absolutely bizarre. I've tried resetting network settings and all that. Still nothing. I've noticed a lot of people on here with this problem seem to have VZ Fios. Wonder if that has anything to do with it.
    iMac, Mac OS X (10.5.4)
  • Greg Fletcher Level 1 Level 1 (5 points)
    Any luck sorting this out?

    Have exactly the same issue.

    BT collapsed last night, so reset router and modem.

    This morning, network is back up, my wife's iphone 4 conntects, as does imac, macbook pro x2, however my iphone 4 will not connect.

    Positive that the password is correct and case sensitive - checked via keychain.

    Trying to connect to an apple airport network....time capsule & 2 expresses...everything else is fine...just not my iphone 4.

    Have current OS4 on iPhone, Timecapsule up to date.
    imac, macbook pro, iphone 4, Mac OS X (10.6.4)
  • EBSkater Level 2 Level 2 (490 points)
    So you're paying for internet that you're not using because you're stealing it off of your neighbor? Smart.
    MacBook Pro 13.3", Windows XP
  • Macaby Level 3 Level 3 (910 points)
    EBSkater wrote:
    So you're paying for internet that you're not using because you're stealing it off of your neighbor? Smart.


    How can you be stealing something that is drifting around inside your home? While I very seldom use my neighbors network (only when mine goes down), I "bootstrap" quite frequently when I'm out and about.

    If you feel it's stealing, you should not do it. I DON'T and I will bootstrap anywhere I please (including your network if I happen to see it when I'm out and about.) If you don't want that to happen, WPA it.
    MB Pro 15-21.5 iMac, Mac OS X (10.6), IT 8GB--IP 4 32GB--Nano 16GB
  • blythspirit Level 1 Level 1 (0 points)
    This problem just cropped up for me after months of owning my iphone 4 and having everything work just fine on my home network... then, all of the sudden it tells me my wifi password is wrong. I tried (unsuccessfully) resetting the router, resetting my phone's network connections, resetting the routers password, "forgetting" the network... All to no avail, though I could connect to the network of the coffee shop in my building.
    Finally I resolved the issue by creating a guest access account on my router, which my phone was able to see and connect to without any issues.
    Odd, and frustrating.
    hp dv7, Windows 7
  • blythspirit Level 1 Level 1 (0 points)
    Finished posting and picked up my phone to see that wifi again wasn't connected, attempted to access my handy new guest network only to have the same error message pop up... incorrect password.
    So... disregard my last. I apparently am not the genius I would like to think.
    hp dv7, Windows 7
  • lazer310 Level 1 Level 1 (5 points)
    Having the same issue. 2 iphones, one is fine. The other is sporadically telling me the password is wrong. This is a new router, only 2 months old. All other wifi connections to the router are fine.
    I forgot the network, reset network settings, reboot the phone, still nothing. I did all those again, and still got bad password. I verified the password was correct on the router, and just kept hitting join on the WAP password screen. After 4 times if finally connected. For how long, I dont know.
    Has anyone else heard of a resolution or cause for this?
    MacBook 2.1GHZ 1GB RAM, Mac OS X (10.6.4), iPhone 4 16gb
1 2 3 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.