Previous 1 2 3 4 Next 91 Replies Latest reply: Jun 20, 2015 8:48 PM by joshids Go to original post Branched to a new discussion.
  • Royal Raider Level 1 Level 1 (0 points)
    I've been having the exact same problem as described above ie. password is incorrect (even when you know you typed it in perfectly!) Anyway, I tried to log on to the wireless network and instead of entering the password I entered the modems address ie. http://???.???.?.? It was, of course, incorrect. Then I tried to log in again, entered the password and BOOM! IT WORKED! I've been unable to log on to this network for weeks even though others at work with iphones have no problem. Hope this helps.
  • arbitrary Level 1 Level 1 (0 points)
    I have the same problem
    Wife's Iphone, Wii, macbook, netbook all connect with no problem. As soon as my wife brought her phone home and logged into the network, my phone couldn't logon saying the password was incorrect.

    I changed the password, but that didn't help.
  • ReubenV Level 1 Level 1 (0 points)
    I'm in the same boat all of a sudden. Two laptops, an iMac and an iPad 2, all able to connect to my Airport Extreme without ANY issues (rebooted multiple times and reconnected with stored password). Verified password in keychain, so I'm using the right one, but both my wife's and my iPhone 4 can't connect to my home network.

    Huh??
  • RestlessFool Level 2 Level 2 (380 points)
    If you go to Settings > WiFi is 'Ask to Join Networks' on or off?

    If it's off then it's possible that your iPhone locked onto another network without you realising....

    If it's 'OFF' then turn it 'ON'. We've found that OpenZones could pick us up without us realising it was happening with this setting set to 'OFF'.

    It's also worth having a look at the networks in the 'Choose a Network' list to see what your iPhone thinks is around you locally.
  • EBSkater Level 2 Level 2 (490 points)
    Macaby wrote:
    EBSkater wrote:
    So you're paying for internet that you're not using because you're stealing it off of your neighbor? Smart.


    How can you be stealing something that is drifting around inside your home? While I very seldom use my neighbors network (only when mine goes down), I "bootstrap" quite frequently when I'm out and about.

    If you feel it's stealing, you should not do it. I DON'T and I will bootstrap anywhere I please (including your network if I happen to see it when I'm out and about.) If you don't want that to happen, WPA it.

    That's why my network is secured.
  • jpsm Level 1 Level 1 (0 points)

    Having the same problem.  Have an iphone 4 that won't connect (all of a sudden stopped connecting rather) to my Time Capsule.  Everything else on the phone and time capsule seems to work.  All other devices connect to the Time Capsule fine, and the iphone connects fine to other networks.   Updates have been run on both.  The iphone keeps telling me the password is incorrect.  I restored original settings to both devices, and even changed the password in the time capsule, etc.  Nothing hepls.  It had worked fine since I bought the iphone 4 over 5 months ago until a few days ago.  Help!

  • Browntown Level 1 Level 1 (0 points)

    Hi Steve.

    I just upgraded to iphone4 from my 3gs. My home wifi network would appear on the "network connections" list, & show signal strength. However, it wouldn't ever use the wifi to connect to the net etc, it'd just use 3G.

     

    After speaking to apple on the phone for 30 mins, we'd tried resetting the network, but no help. It wasn't until i re-checked my modem settings & realised i'd changed my WEP password from the original to a harder one a year or so ago. Guessing that because my other connections weren't affected because they were already known to the modem previously. Once i changed the iphone 4 to the correct password (after resetting the network on the phone) the problem was fixed.

     

    Apparently, the WEP key won't tell you that you've got the wrong password, rather it will just refuse to connect. Also, if you check your network in "wifi settings" & the "ip address" is completely wrong, this could answer your problems. My IP address was supposed to be 192.....etc, but it was nothing like it. Once i changed the password it reverted back to the proper IP in the DHCP column.

     

    *Hopefully this is all it is Steve. This threw me off-track for ages, as i could connect anywhere else (eg my neighbour's wifi) but not on my own network.

     

    Ben

  • craigfrombristol Level 1 Level 1 (0 points)

    I've been experiencing a similar problem since last night. My wife's iPhone connects to our WIFI yet mine didn't. Fortunately, I've now managed to resolve my problem so hopefully this will be of some use!

    • On your PC, go to: http://192.168.0.1 (or whatever your IP address is)
    • Log-in to view your router settings
    • Click on 'Attached Devices' to see what's connected to the WIFI (although at this point my iPhone was showing as being connected on my WIFI settings, I was still seeing 3G and no WIFI connection)
    • Click 'Refresh'
    • Check your mobile for a WIFI connection (at this point, the WIFI connection was shoowing on my phone and now working)

    I hope this helps. The phone is now connecting fine for me!

    Regards

  • Luloh Level 1 Level 1 (0 points)

    I am actually using 4 Airport Extremes and just had the same problem.  I solved it by making a minor change so an upload was necessary (not the password, that didn't work) and did an upload.  This fixed the problem.

  • eteyemd Level 1 Level 1 (30 points)

    ***? Same thing just happened to me right now. I've had my iPhone 4 for months and never had a problem and all of a sudden it can't connect to my home network anymore and says I have the wrong password. All other connections in the house work fine (two iPads, laptops, desktops, AppleTVs, etc.........) just the iPhone is affected. What is the issue all about? Has anybody been able to figure this out yet?

  • a0b9180 Level 1 Level 1 (0 points)

    Suddenly my iphone refuses to connect to the home wifi. My wife's iphone is connecting though. I wonder if this started happening after I updated my software thru itunes!! Wake up Apple!

  • yfromriverdale Level 1 Level 1 (0 points)

    Hello everyone.  Just thought I'd chime in with my experience:  I too wasn't able to connect my iPhone4 to my home wi-fi.  It would connect to other wi-fi networks (e.g. work, etc.), but at home it would only use 3G.  I knew I had MAC filtering enabled on my wireless router, so I entered my iPhone's MAC address into my router's admin page.  It turned out I had accidentally entered the *Bluetooth* MAC address and not the wi-fi MAC address.

     

    Oops! 

     

    As soon as I corrected the MAC address (different by one digit!), the iPhone connected to my home wi-fi immediately!

     

    Good luck folks.

  • Trajan UK Level 1 Level 1 (0 points)

    Hi, I had this problem with two I phone4 s in the house, two networks and loads of computers, some wired some not, plus network tv and PS3. All working fine and all of a sudden one I phone downs itself from both networks! It hooked back up to one on the second attempt at clean password entry, but steadfastly refused to join the netgear network. This is a new 150 high speed router so quite surprising. I disconnected the 2nd iPhone from the netgear and the other network, and this phone duplicated the firsts behaviour exactly! Tried tinkering with all the phones settings on one of the phones, deleting cookies etc, to no avail. Then I turned off the netgear router for twenty seconds and when I fired it up again both phones connected fast on the first password entry. To conclude it sounds like a router issue, bit hopefully not terminal. Perhaps a good ideas to cycle them on e in a while?

    Cheers

  • salman217 Level 1 Level 1 (0 points)

    So

  • salman217 Level 1 Level 1 (0 points)

    so basically this is what everyone should do to make the iPhone 4 reconnect with ur home wifi...and yes it's the stupid router's fault, not iPhone 4 (as the Verizon idiots tell you).

     

    This is a ONE step solution...all you have to do is press the "RESET" button on the back of ur router. Yup...that simple.

     

    Before you do that, just go to ur router's IP configuration settings, look at all the devices connected to ur network from ur desktop or laptop computer. After you hit "reset" on the back of your router, come back to this and you should see that all those previous devices are no longer listed. That means ur reset was successful.Your iPhone should easily connect to ur wifi :-)

     

    To check your Router IP configurations Settings:

    • Open ur browser, go to ur Router's IP configuration settings...192.168.1.1 (this isn't the same for everyone)
    • default username should be "admin" and default password is "password" "password1" or your router's Serial #....it is case sensitive....HINT: you may see notice that when you try to enter just ONE character in the password box, it shows up as multiple characters. This is an encryption to protect your password from people who look over your shoulders. Just ignore it, and type in "password." if this doesn't work, enter your router's serial # and it will grant you access!
    • I have verizon FiOS so I went under "My Network" which shows me which device is connected to my network.

    :-) problem solved

     

    - SaLmAn

Previous 1 2 3 4 Next